• 0
TechnoHair

Esseker NO LOOT

Question

Hello folks once again (:

I finally made my server run with Esseker map, and all mods required for it.
Most seems fine, ofc i still need to adjust alot of things, but no loot at all?
I tried using loot guides Exile, and Exile Esseker but nomatter what i do no loot?

I know Theres alot of threads about it already, but i could use an updated method.

EDIT: CUrrently using loot spawns by @Hollow

Edited by TechnoHair

Share this post


Link to post
Share on other sites

14 answers to this question

  • 0
46 minutes ago, [AFR]Froozone said:

Make sure you're using steam version of esseker on the server and your PC both.

Sorry im confused haha, so is it not working only because i have used the same version of exile on my client?

Server is using @Esseker from their google drive. 

Share this post


Link to post
Share on other sites
Advertisement
  • 0
4 minutes ago, [AFR]Froozone said:

It's not working because you have used non-steam version of esseker. Propably. Use the one from steam and lets see what happen.

The one from Steam on my server or how so? 

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, BetterDeadThanZed said:

One fix for loot not spawning has been to upload the Steam version of Esseker to your server. So, download Esseker from Steam Workshop, then upload the files to your server. See if that fixes the problem.

Didn't help however it made my @Esseker green in server browser so thanks for that tho.
But do i need to do this modification now? 

( POST #2)

Thanks in advance.

Share this post


Link to post
Share on other sites
  • 0

wasn't sure if you are only running around in A3 buildings or looking around in A2 buildings as well but I did have to specify loot for damaged A3 buildings as most of Esseker's A3 buildings are damaged and they are a different class from the default Altis loot table's non-damaged buildings.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, yukihito23 said:

wasn't sure if you are only running around in A3 buildings or looking around in A2 buildings as well but I did have to specify loot for damaged A3 buildings as most of Esseker's A3 buildings are damaged and they are a different class from the default Altis loot table's non-damaged buildings.

I did check a whole town, maybe I didn't check for long enough but I really see no spawn stuff at'll.

If I have to specify those buildings, damn, isn't there a kind sould out there who got loot table who wants to share?
 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, TechnoHair said:

I did check a whole town, maybe I didn't check for long enough but I really see no spawn stuff at'll.

If I have to specify those buildings, damn, isn't there a kind sould out there who got loot table who wants to share?
 

if you've cranked up the amount of loot to spawn from your exile config and then try verifying below.

such as, from where you specify the building class which will spawn loot, find

Land_i_Shop_01_V2_F

then search for 

Land_i_Shop_01_V2_dam_F

if you don't have the _dam version,

copy Land_i_Shop_01_V2_F portion and place under then rename class name to

Land_i_Shop_01_V2_dam_F

so then you'll have 1 loot pos for Land_i_Shop_01_V2_F and one for Land_i_Shop_01_V2_dam_F (since they are basically the same houses, just the later is damaged type)

then go in to game and see if it still doesn't spawn or not.

at least you'll be able to debug if you're at that point or not.

that land shop looks like this

150px-Arma3_CfgVehicles_Land_i_Shop_01_V

so should be fairly easy to find in town.

reference: https://community.bistudio.com/wiki/Arma_3_CfgVehicles_EMPTY

If still nothing from above, I would go back to using default A3 Altis loot table and at least verify if it spawns in A3 buildings with that or not (you'll have to find a non damaged A3 building in the map somewhere), if it does, then start adding in bits of A2 (Esseker) buildings in and validate where your failing point is.

If not spawning even with default A3 Altis loot table, along with the mentions of using Steam version of Esseker, I think you may have a typo prob or something somewhere else as I've had a situation as well where I couldn't figure out why my loot wasn't spawning after I did a server update so reverted part of my edits to previous version an restarted from there to fix it.

Edited by yukihito23

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, TechnoHair said:

I did check a whole town, maybe I didn't check for long enough but I really see no spawn stuff at'll.

If I have to specify those buildings, damn, isn't there a kind sould out there who got loot table who wants to share?
 

https://github.com/gianni001/ExileReborn/blob/Reborn_Zombies/%40ExileServer/addons/exile_server_config/esseker.hpp

Copy and paste that code into a blank file, call it esseker.hpp and put it in your exile_server_config.pbo and add this to the config.cpp:

	///////////////////////////////////////////////////////////////////////////
	// Castles & Lighthouses & Life Guard Towers
	///////////////////////////////////////////////////////////////////////////
	#include "esseker.hpp"
	class Land_LifeguardTower_01_F

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.