Sign in to follow this  
Powerstriker46

ZEUS Auf (exile)server installieren... Aber wie? Hat noch jemand paar ideen bin am verzweifeln^^

23 posts in this topic

Die pbo entpacken, dort sind dann die Moddateien, unter anderem ein Ordner namens "functions", dort ist auch eine config Datei, Endung müsste hpp sein. In dieser Datei steht das hier:

class CfgFunctions
{
    #include "hpp\functions.hpp"
};

Wenn du infiStar nutzt, solltest du eine description.ext besitzen im Serverordner. Hier schreibst du auszuführende Dateien rein, also Scripts oder Server Mods etc. 

Ohne infiStar kannst du eine init.sqf nutzen, also auch eine config im Serverordner. Falls diese config nicht existiert, einfach selbst erstellen und den Code einfügen. Eventuell ist diese "class CfgFunctions" sogar in der exile config, bin mir also nicht ganz sicher.

Das ganze dient dazu, den Ordner beim Serverstart mit auszuführen, so dass serverseitig die benötigten Scripts zur Verfügung stehen.

 

Wenn das alles nicht ganz klappt, kannst du mir auch gerne auf Steam schreiben oder auf mein TS³ kommen, dann versuchen wir das zusammen!

Steamname: ZeusBrocken

TS³: 78.31.64.83

Edited by ZeusBrocken

Share this post


Link to post
Share on other sites
Advertisement

also ich habe die datein jetzt entpackt und bei mir gibt es eine datei

functions.hpp da steht das drin

Spoiler

class SLZ{
	class functions{		
		file = "sl_zeus\functions";		
		class initServer			{postInit = 1;};
		class initClient			{};
		class isAdmin	 			{};
		class isStillAdmin			{};
		class adminRespawn			{};
		class addObj				{};
		class remoteStartIsAdmin 	{};
		class findDisplay			{};
	};
};

 

und unter

config.cpp steht

 

Spoiler

class CfgPatches
{	
	class SL_Zeus
	{
		units[] = {};
		weapons[] = {};
		requiredAddons[] = {};
		author[]= {"seelenlos"};		
	};		
};

class CfgFunctions
{
	#include "hpp\functions.hpp"
};

 

 

 

aber ich kanns dann auf gut glück mal einfügen

Edited by Powerstriker46

Share this post


Link to post
Share on other sites

also wenn ich das einfüge unter init.sqf dann kommt

ErrorMessage: Include file mpmissions\__cur_mp.Namalsk\hpp\functions.hpp not found.

war ja zu erwarten weil das ja in der Missionsdatei nicht drin steht sondern halt serverside in einer PBO gepackt ist

entweder stell ich mich heute besonder blöd an oder es funktioniert einfach nicht bei mir xD

 

EDIT:

ich habe jetzt eben die functions.hpp einfach mal noch in die missionsdatei eingefügt, die fehlermeldung war auch weg aber das problem ist dass es  trozdem nicht geht xD

wie gesagt ich denke ich brauche einfach deine version :P , die neue scheint nicht zu funktionieren zumindest bei mir nicht

Edited by Powerstriker46

Share this post


Link to post
Share on other sites

hier dann den gesamten Ordner laden und bei dir einfügen:

https://drive.google.com/open?id=0B_LPKD5WIGgmRi1aWHNwTVJnQ2M

Hab auch grad gesehen, dass ich selber gar nichts eintragen musste, könnte also nur an der Version liegen. 

Bei dieser älteren Version gibt es allerdings keine Funktion, um sich mittels UID anzumelden. Geht also nur über "'login" command auf dem Server!

Share this post


Link to post
Share on other sites

und dann einfach Z drücken wenn man sich als admin angemeldet hat oder? weil es geht irgenwie immer noch nicht aber auf meinem test serversind aber auch 14 mods drauf, vllt liegts daran ich probier dass dann nochmal auf meinem anderen server wo nur 5 drauf sind...

Share this post


Link to post
Share on other sites

muss man da in der steuerung was ändern bei der tastenbelegung... denn bei mir geht auch deine version nicht

wenn ich Z drücke passiert einfach mal gar nix... bin echt ratlos, das kann doch nicht sein dass es bei dir geht und bei mir nicht -.-

typisch arma, ich habe CBA_A3 drauf kann das der grund sein?

bei armaholic steht dass @Ares noch empfohlen ist aber das braucht man doch nicht unbedingt oder?

 

bin also offen für weitere vorschläge xD

 

braucht man dafür infistar damit der mod läuft? (ich denke zwar nicht weil das wäre ja das erste mal dass ich dann davon hören würde dass man da infistar bracuht :P)

 

verdammt nochmal  ICH WILL DAS TOOL HABEN  :(

Edited by Powerstriker46

Share this post


Link to post
Share on other sites

gute frage ich denke aber nicht....

in welche datei müsste man das gleich reinschreiben habe von solchen befehlen hier schon ab und zu mal gehört habe das aber noch nie gebraucht...

denn in meinem webinterface (g-portal) gibt es so was schon mal nicht zum ankreuzen

 

danke erstmal dass sich hier doch noch jemand gemeldet hat habe schon ehrlich gesagt nicht mehr damit gerechnet :D

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.