• 0
MistahGrim

Help Required: Mods Not Loading Into Server.

Question

Hello guys, if you're here with a solution I want to first thank you for helping a bambi.

On to the problem:
I've been attempting to install addons on to my group's Exile server. Unfortunately the server is stuck on "Selecting Mission" and the server says there are no mods loaded on the server. I've pasted the addon folders into the server root folder, and have placed the Keys into the Keys folder. I'll be pasting my parameters and my rpt file below, along with some additional details, in hopes that somebody out there has a solution to my problem. Thanks again!

Steps I've Taken:
1) Copied and pasted mod folders into server root folder.
2) Copied the mod keys into the Keys folder.
3) Set the parameters as described below.

Host: GTXGaming.com

Map: Esseker

Parameters: -mod=@Exile;@Esseker;@CUP_Terrains_Core;@Arma_Enhanced_Movement;@Zombies_and_Demons;@Extended_Base_Mod;
                       -servermod= (Last time we had a server we kept this blank and it worked just fine. Unfortunately our files were deleted.)

RPT File: http://pastebin.com/Lj6qULAa
 

Edited by MistahGrim

Share this post


Link to post
Share on other sites

16 answers to this question

  • 0

Hi, looking at the server.rpt which seems to be different from your paste in the post, first error that quickly jumps out is in the launch params. 

Sorry, on phone so will do my best to explain.... 

On your -mod= you only need to wrap it with "" if there are spaces in your mod folder names. Yours don't have spaces so just remove the "" completely. 

Also, if you did have spaces you have put one of the " in the wrong place. You have:

-mod="

When it should be:

"-mod=

Hope this helps. 

Edited by BaroN

Share this post


Link to post
Share on other sites
  • 0

From your RPT

-mod=" @Exile;@Esseker;@CUP_Terrains_Core;@Arma_Enhanced_Movement;@Zombies_and_Demons;@Extended_Base_Mod;" 
-servermod="@ExileServer;@ExileServer;" -autoInit -enableHT

should be

-mod=@Exile;@Esseker;@CUP_Terrains_Core;@Arma_Enhanced_Movement;@Zombies_and_Demons;@Extended_Base_Mod; 

-servermod=@ExileServer; -autoInit -enableHT

 

then if you look at the bottom of your rpt it is not finding your mission

  1.  6:05:59 Can't find a mission collection / mission with template name: 'Exile.Esseker', skipping to next mission.
  2.  6:05:59 Connected to Steam servers

 

make sure in your config you are loading the right mission.

in your server.cfg

class Missions
{
    class Exile
    {
        template = Exile.Esseker;  

        // do NOT use custom difficulties!
        // Use either ExileRegular or ExileHardcore
        // or you will break Exile!
        difficulty = "ExileRegular";
    }; 
};

 

Edited by Renegade2k6

Share this post


Link to post
Share on other sites
Advertisement
  • 0
8 minutes ago, BaroN said:

Hi, looking at the server.rpt which seems to be different from your paste in the post, first error that quickly jumps out is in the launch params. 

Sorry, on phone so will do my best to explain.... 

On your -mod= you only need to wrap it with "" if there are spaces in your mod folder names. Yours don't have spaces so just remove the "" completely. 

Also, if you did have spaces you have put one of the " in the wrong place. You have:

-mod="

When it should be:

"-mod=

Hope this helps. 

Hello, and thank you for your response! Weirdly enough while editing my parameters, I'm not seeing any " quotation marks, as I didn't put any in. However in the RPT file it adds them. In the configuration editor, in which I edit the parameters, I have it pasted exactly as so, with no quotation marks.

 @Exile;@Esseker;@CUP_Terrains_Core;@Arma_Enhanced_Movement;@Zombies_and_Demons;@Extended_Base_Mod

I don't know why the RPT file is showing those quotation marks.

Share this post


Link to post
Share on other sites
  • 0

Another quick tip for you

You can rename these folders to make them shorter and without the _

@CUP_Terrains_Core;@Arma_Enhanced_Movement;@Zombies_and_Demons;@Extended_Base_Mod; 
@CUPTerrains;@AEM;@Zombies;@EBM; 

Just make sure the mod folders match the same as your command line or vice versa

Share this post


Link to post
Share on other sites
  • 0
24 minutes ago, Renegade2k6 said:

From your RPT


-mod=" @Exile;@Esseker;@CUP_Terrains_Core;@Arma_Enhanced_Movement;@Zombies_and_Demons;@Extended_Base_Mod;" 
-servermod="@ExileServer;@ExileServer;" -autoInit -enableHT

should be


-mod=@Exile;@Esseker;@CUP_Terrains_Core;@Arma_Enhanced_Movement;@Zombies_and_Demons;@Extended_Base_Mod; 

-servermod=@ExileServer; -autoInit -enableHT

 

then if you look at the bottom of your rpt it is not finding your mission

  1.  6:05:59 Can't find a mission collection / mission with template name: 'Exile.Esseker', skipping to next mission.
  2.  6:05:59 Connected to Steam servers

 

make sure in your config you are loading the right mission.

in your server.cfg


class Missions
{
    class Exile
    {
        template = Exile.Esseker;  

        // do NOT use custom difficulties!
        // Use either ExileRegular or ExileHardcore
        // or you will break Exile!
        difficulty = "ExileRegular";
    }; 
};

 

And here's why I'm confused. I didn't place those quotations in, and the template is set to Exile.Esseker. When pasting the parameters in, it fills in the -mod= for me, and there are no quotations.

What I see to fill in parameters:
http://imgur.com/i7UU3LN

EDIT: Ignore the -mod= and the -Servermod= in the text box. I just put those in to test something, and it didn't work.

Edited by MistahGrim

Share this post


Link to post
Share on other sites
  • 0

Your host is most likely putting the quotations in automatically so I wouldn't worry about it.

I take it your mission is also called  Exile.Esseker ?

Share this post


Link to post
Share on other sites
  • 0

Something is a miss, clearly in the rpt it can not find your mission. 

Either your mission name

1.doesn't match the name in your server.cfg 

2.is in the wrong place

3.in the wrong format i.e .pbo

Share this post


Link to post
Share on other sites
  • 0

I'm going to go with option 2, as the file is a pbo (or did you mean it's not supposed to be a pbo? All the other templates are.), and the name matches. Is it not supposed to be in the mpmissions folder located in the root? This is where all the other templates are located. I.e. "Exile.Altis" "Exile.Tanoa" "Exile.Namalsk"

By the way, thank you for your help in resolving this issue. I really appreciate it as my friends and I have been wanting to play Exile for a while now, but we've been busy trying to fix our server.

Share this post


Link to post
Share on other sites
  • 0

It should be in the same folder as the other missions you have listed and in the same format.

Some hosts allow you to have the mission in a folder not a pbo then when you start the server it creates the pbo itself.

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.