ILLUXNNN

Cannot get to disable FOG completely

11 posts in this topic

Hi there,

I'm running into a pesky problem here, even though I put the fog off in the exile_server_config.pbo, it still gets hella foggy when its getting early morning.

Below are my settings:

        keyframes[] = {"Sunny"};
        class Sunny
        {
            fogValue = 0.0;
            fogDecay = 0.0;
            fogBase = 0.0;
            overcast = 0.0;
            waves = 0.2;
            wind = 0.25;
            gusts = 0.1;
            rain = 0;
            lightnings = 0;
            rainbows = 0;
        };

I'm also running infistar:

/* Terrain Grid Value   */ TGV = 45;    
/* ViewDistance Value   */ VDV = 1700;
/* ObjectViewDistance   */ VOV = 1700;
/* ShadowViewDistance   */ SVD = -1;

 

Any solution? Thanks.

Share this post


Link to post
Share on other sites
Advertisement
On 23-12-2016 at 9:13 AM, hogansheroes said:

everything that you have set to 0.0 set it to 0 

Thanks, Ill try this !

 

Edit: Works! Thanks. ArmA -_-

Edited by ILLUXNNN

Share this post


Link to post
Share on other sites

UPDATE: That didn't change anything at all, it was a false positive. I still see the fog kicking in HARD now and then, especially early in the morning... I can also see it in our infistar menu. Any solutions?

Share this post


Link to post
Share on other sites

Same problem. It also rains on my server while I did not set that up ANYWHERE...

I'm running a kind of fasttime script, which looks like this:

Spoiler

if (!isServer) exitWith {};
_fnc_time =
{
    switch (true) do
    {
        case ((daytime >= 6) && (daytime <= 6.75)):
        {
            setTimeMultiplier 2;
        };
        case ((daytime > 6.75) && (daytime <= 11)):
        {
            setTimeMultiplier 32;
        };
        case ((daytime > 11) && (daytime <= 15)):
        {
            setTimeMultiplier 8;
        };
        case ((daytime > 15) && (daytime <= 16.75)):
        {
            setTimeMultiplier 4;
        };
        default 
        {
            setTimeMultiplier 100;
        };
    };
    true
};
if!(isNil 'Fnc_timeThread') then { [Fnc_timeThread] call ExileServer_system_thread_removeTask; };
Fnc_timeThread = [60, _fnc_time, [], true] call ExileServer_system_thread_addtask;

Are you running something fimiliar?

Share this post


Link to post
Share on other sites

I also occasionally also get the rainbow lakes around the map on my  CUP Chernarus server, from what I can tell it's just at twilight or daybreak. I do have my fog set to zero for all weather types too.

For me, it's short lived typically as once the sun rises or finishes setting it's back to normal. I use Occupation's fast nights to increase the speed of the time on the server and it's configured to be 3 hours day and 1 hour night and I have the times the fog seems to occur in the high speed timeframe. It means for me that it's short lived when it does happen so I haven't worried about it - I've always assumed it was a weather effect that is mandated as part of the sun rising or setting cycle and not something that can be controlled.

I'll be keeping an eye on this thread in case someone comes up with a solution though......

Update 15/3 - I've now noticed the rainbow lakes occasionally during daytime on the server :( No idea what causes it but it does seem to be linked in some way to inclement weather as I've never seen it yet in full sun. Ahhh, the joys of Chernarus on A3!

Edited by Riker2335
Updated to include additional information.
1 person likes this

Share this post


Link to post
Share on other sites

Bump, anyone have a solution yet?

I tried adding this to initServer.sqf ( I know it's not pretty but I had to try it ) and it didn't work out :(

Spoiler

[] spawn {
0 setFog 0;
forceWeatherChange;
sleep 1*60;
};

 

Share this post


Link to post
Share on other sites

@GolovaRaoul

Try this in the bottom of your initPlayerLocal.sqf:

setTerrainGrid 3.125; 
setViewDistance 2000;
ObjectViewDistance 2000;
ShadowViewDistance 50;
0 setFog 0;

You will still get the view distance fog at the 2km mark.

Share this post


Link to post
Share on other sites
On 14/01/2018 at 4:37 AM, aussie battler said:

@GolovaRaoul

Try this in the bottom of your initPlayerLocal.sqf:

setTerrainGrid 3.125; 
setViewDistance 2000;
ObjectViewDistance 2000;
ShadowViewDistance 50;
0 setFog 0;

You will still get the view distance fog at the 2km mark.

Does this work without having infistar?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.