Bones51

[RELEASE] ExileMod Re-Arm/Repair (New Release 16/09/18!)

276 posts in this topic

I got some issues with the script, hope its on me doing stuff wrong, as I was not able to get AVS working correctly and put all hope into this.

The issues:

1. Getting multiple selection entries on the rearm with any vehicle when rotating the mouse wheel, it seems just infinite. Only a cosmetic isse though. Rearm works fine, poptab reduction works, poptab check works.

2. Can't repair vehicles with duct tape anymore at all, the "get in as driver first.." message appears.

3. Land vehicles seem fine for what I have tested but helicopters get problems: I tried the CUP ARMED Mi17 helicopter and rearm somehow allows me to put 1.5k (PK?) bullets into the magazine of the chief/commander gun. Haven't managed to get them into the rear gun yet, but might be possible too.

Reproduction:

a. Rearm at service point (guns stay at 0/0).

b. Go to gunners seat and push the "rearm TK" button that appears on the selection menu. Then you get 1500/0 loaded in which should actually be 100/5 or something like that.

 

After restarting the server I was able to repair again with duct tape.


Tried CUP's UH1H armed and got the following:

1. Picture shows loads of different ammunition types to reload with. I picked 200 round m240.

2. Picture: After reloading and getting out, I got no selection menu at all anymore to get inside the helicopter.

------

After relogging, I could get inside again. Rearm didn't happen 0/0 on both guns.

I reloaded with first selection rearm 100 size magazine. Rearm doesn't happen either.

------

 

 

 

Something else:
Wouldn't it be the easiest thing to have vehicle ammo carryable items like in A2 that can be reloaded manually once in inventory of player or vehicle?

We just need the magazine type items/models for that. Do they by any chance already exist in arma3?

 

Repair01.jpg

Repair02.jpg

Edited by sjJACKit

Share this post


Link to post
Share on other sites
Advertisement

new test with UH-60:

1. Screenshot shows multiple selections for each magazine/weapon type. Them are exactly 7 for each sides gun and like ~10 for flares.

2. Screenshot shows (not) flickering pilot selection menu. Pilot is popping up and going away frequently without moving the mouse when just aiming at the helicopter. The screen shows a point of time when the 'get in as pilot' was gone for the fraction of a second.

 

New test with exile's very own Huey helicopter.

It starts with 200/0 magazines on both sides which reload unlimtedly after getting emptied. 

3. Screenshot shows how I reloaded a new full magazine inside after I emptied it before.

Repair03.jpg

Repair04.jpg

Repair05.jpg

 

Conclusion after testing 4 helicotpers and one land vehicle:

Land Rover M2 CUP

Mi17 CUP

UH1H CUP

UH-60 CUP

Exile_Chopper_Huey_Armed_Green

 

Effects appear to be fully random and I have jack of an idea why that is or what to do about it. Stopping tests here.

Anybody any idea where to start?
Could there be interferences with advanced_towing or anything else?

The whole vehicle reload thing with Exile seems to be vicious. 

 

Edited by sjJACKit

Share this post


Link to post
Share on other sites

I am not sure what I have missed, but when I try to repair a Vehicle it says I need poptabs.. When I have the poptabs it repairs the vehicle but doesn't take them from me. Can anyone give me a pointer to what needs changing  so it removes the poptabs from me

Share this post


Link to post
Share on other sites
7 hours ago, Chainsaw Squirrel said:

Anyone having issues with this since 1.04 and infistar v92 ? can repair, and refuel. rearm flashes sometimes then goes poof  ..also now am x64 db3 as well

It stopped working for me using something else now.

  • Like 1

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.