• 0
Sign in to follow this  
Wardbeek

How to remove radiation zone? (Solved)

Question

7 answers to this question

  • 1

Mission.sqm

Scroll down until you find entries that look like:

class Item1
	    {
	        dataType = "Marker";
	        position[] = {9383.25, 0, 6203.86};
	        name = "ExileMarker1";
	        text = "";
	        markerType = "ELLIPSE";
	        type = "ExileTraderZone";
	        colorName = "ColorBlack";
	        fillName = "Border";
	        a = 79.787;
	        b = 79.787;
	        drawBorder = 1;
	        id = 101;
	        atlOffset = 0;
	    };

Find all the ones that are like: 

type = "ExileContaminatedZone";

Delete the entire Class. All the way from "class Item1" all the way to the last }; 

(Including the bracket and semicolon, as well as the words class Item1)

Also delete the corresponding marker class (type = "ExileContaminatedZoneIcon";)

Now here's the tricky part...

Everything after that, you have to adjust the class numbers. So say you have a class 41 that is a contaminated zone. The next one will be 42 (the marker). Then 43 and 44 and so on. 

So you delete 41 and 42. The next one is 43, so you must change it to 41 so that it keeps going. Then you have to change 44 to 42... and so on all the way down. The classnames have to be in order. 

 

THEN as a last step, scroll all the way back up to "class Entities". You will see 

class Entities
	{
		items = 59;

		class Item0
		{

Change the number 59 to how many classes you have now. So for instance, in the example above, you deleted 2 classes. (The exileContaminatedZone and exileContaminatedZoneIcon) So you would subtract 2 from 59 to get 57. Just subtract however many you deleted from that number. 

 

Save the file and recompile, and start up your server. 

 

Clear as mud? 

  • Like 1

Share this post


Link to post
Share on other sites
  • 1

In your mission folder, open of config.cpp and search for the word radiation. You'll see 

class Radiation 
		{
			// 1 = enabled, 0 = disabled
			enable = 1;
		};

Change that 1 to a 0. 

  • Like 1

Share this post


Link to post
Share on other sites
Advertisement
  • 0
3 hours ago, papahyooie said:

In your mission folder, open of config.cpp and search for the word radiation. You'll see 


class Radiation 
		{
			// 1 = enabled, 0 = disabled
			enable = 1;
		};

Change that 1 to a 0. 

I did that, now i have no radiation anymore. But players still cannot build or find loot.

Share this post


Link to post
Share on other sites
  • 0

Loot should spawn in a radiation zone. As a matter of fact, in the loot table, there's a specific table just for the radiation zones. A player wouldn't be able to build in the radiation zone (or other places) if it's within X meters of a trader, spawn zone or another territory. Check your config.cpp for those settings.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.