Its me ZovkT

Real Restart Time

14 posts in this topic

Hello Chris /Other Guys. 

I Set up the Real Restart time in Infi...  

must Change any Stuff in the exile Server config ?  to bring the real time restart to work ?. 

habe alles editiert in der infi datei  und muss ich noch etwas ändern in der exile server config wegen dem restart da ?. 

kann mir das jemand mal erläutern oder erklären wie das perfekt geht ? .

 

Thanks for helping me guys. 

Share this post


Link to post
Share on other sites

I too am keen for an answer to this. I need to understand how the Exile system and the infistar systems work together. When talking about restarts. You would think that you should be able to disable the restart options in exile's config and use infistar, but infistar doesn't have the locking and post restart locking/unlocking options. 

I'm using the following in EXILE_AHAT_CONFIG.HPP

Spoiler

/* show time left to next restart */
USE_RESTART_TIMER = "true";

USE_RESTART_TIMES_ARRAY = "true";
/* if USE_RESTART_TIMES_ARRAY = "true"; -> {hour,minute} .. put in the times when your server restarts (server real world time) */
RESTART_TIMES[] =
{
    {00,00},
    {04,00},
    {08,00},
    {12,00},
    {16,00},
    {20,00}
};

/* if USE_RESTART_TIMES_ARRAY = "false"; -> restart time in minutes (default: 180min == 3 hours) */
RESTART_TIME_IN_M = 180;
TIME_FUNCTION_USED = "diag_tickTime";    // diag_tickTime (starts with arma3server.exe), time (starts with mpmission init)

/* show restart announcement message x min before restart -> SERVER RESTART IN: X MINS  |  (calculated from RESTART_TIMES[])*/
RESTART_ANNOUNCE_X_MIN[] = {1,2,3,5,10,30};

/* SERVER_END_FUNCTION -> #shutdown or #restartserver */
SERVER_END_FUNCTION = "#shutdown";
USE_RESTART_TIMER_SHUTDOWN = "true";
RESTART_WARNING_SOUND = "Alarm";    // for example: Alarm or air_raid

But what is required in the exile config.cpp class RCON? To ensure the restart is called by and managed by infistar.

Spoiler

class RCON
    {
        /*
            Note that for this to work you need to have serverCommandPassowrd defined in config.cfg and BE enabled
        */

        // This needs to match config.cfg serverCommandPassword
        serverPassword = "removed";

        // Autolocks server until its ready to accept players
        useAutoLock = 0;

        // Server will autoLock at that time before restart (minutes)
        restartAutoLock = 3;

        /*
******** but I dont want the exile system calling the restart - I want infistar to *************            

Number of hours and minutes of your restart period.

            Examples:

            {4, 0} = Every 4 hours
            {1, 30} = Every one and a half hour (who the hell would do this?)
        */
        restartTimer[] = {4, 0}; 

        /*
            Kicks players before restart to prevent gear loss.
            We strongely recommend to use this!

            0 = off
            1 = on
        */
        useAutoKick = 1;

        /*
            Number of minutes before the server kicks players that did
            not disconnect before the restart. Should at least be two
            minutes!
        */
        kickTime = 1;

        /*
            Self-explanatory

            0 = off
            1 = on
        */
        useRestartMessages = 1;

        /*
            Number of minutes before the restart to inform your players.

            Only use full minutes here. Value like 5.5 have not been tested.
        */
        restartWarningTime[] = {15, 10, 5, 3}; 

        /* 
            If set to 1 server will execute '#shutdown',
            to try to shutdown the server
        */

        useShutdown = 1;
    };

 

Share this post


Link to post
Share on other sites
Advertisement

Yes thats the Question..    Then i set the same Time in exileconfig     random restart  from exile and infistar  so not working. and without rcon  pw is bad to for Locking the server. and in the readme from infistar  say nothing about that.   it gives no changelog or any stuff i hope  here gives any help for us. :D

 

But we make the Exileconfig Restart off ?  i try it with off or 0  or nothing and the restart thas 5 minits after the server thas online.

Edited by Its me ZovkT

Share this post


Link to post
Share on other sites
21 hours ago, [ZSU]Dr. Rockso said:

I too am keen for an answer to this. I need to understand how the Exile system and the infistar systems work together. When talking about restarts. You would think that you should be able to disable the restart options in exile's config and use infistar, but infistar doesn't have the locking and post restart locking/unlocking options. 

I'm using the following in EXILE_AHAT_CONFIG.HPP

  Reveal hidden contents

/* show time left to next restart */
USE_RESTART_TIMER = "true";

USE_RESTART_TIMES_ARRAY = "true";
/* if USE_RESTART_TIMES_ARRAY = "true"; -> {hour,minute} .. put in the times when your server restarts (server real world time) */
RESTART_TIMES[] =
{
    {00,00},
    {04,00},
    {08,00},
    {12,00},
    {16,00},
    {20,00}
};

/* if USE_RESTART_TIMES_ARRAY = "false"; -> restart time in minutes (default: 180min == 3 hours) */
RESTART_TIME_IN_M = 180;
TIME_FUNCTION_USED = "diag_tickTime";    // diag_tickTime (starts with arma3server.exe), time (starts with mpmission init)

/* show restart announcement message x min before restart -> SERVER RESTART IN: X MINS  |  (calculated from RESTART_TIMES[])*/
RESTART_ANNOUNCE_X_MIN[] = {1,2,3,5,10,30};

/* SERVER_END_FUNCTION -> #shutdown or #restartserver */
SERVER_END_FUNCTION = "#shutdown";
USE_RESTART_TIMER_SHUTDOWN = "true";
RESTART_WARNING_SOUND = "Alarm";    // for example: Alarm or air_raid

But what is required in the exile config.cpp class RCON? To ensure the restart is called by and managed by infistar.

  Reveal hidden contents

class RCON
    {
        /*
            Note that for this to work you need to have serverCommandPassowrd defined in config.cfg and BE enabled
        */

        // This needs to match config.cfg serverCommandPassword
        serverPassword = "removed";

        // Autolocks server until its ready to accept players
        useAutoLock = 0;

        // Server will autoLock at that time before restart (minutes)
        restartAutoLock = 3;

        /*
******** but I dont want the exile system calling the restart - I want infistar to *************            

Number of hours and minutes of your restart period.

            Examples:

            {4, 0} = Every 4 hours
            {1, 30} = Every one and a half hour (who the hell would do this?)
        */
        restartTimer[] = {4, 0}; 

        /*
            Kicks players before restart to prevent gear loss.
            We strongely recommend to use this!

            0 = off
            1 = on
        */
        useAutoKick = 1;

        /*
            Number of minutes before the server kicks players that did
            not disconnect before the restart. Should at least be two
            minutes!
        */
        kickTime = 1;

        /*
            Self-explanatory

            0 = off
            1 = on
        */
        useRestartMessages = 1;

        /*
            Number of minutes before the restart to inform your players.

            Only use full minutes here. Value like 5.5 have not been tested.
        */
        restartWarningTime[] = {15, 10, 5, 3}; 

        /* 
            If set to 1 server will execute '#shutdown',
            to try to shutdown the server
        */

        useShutdown = 1;
    };

 

This is the Problem.  

@infiSTAR    Have you a Idea Chris ?. 

Share this post


Link to post
Share on other sites
55 minutes ago, Tobias Solem said:

Chris is aware of this issue, but I don't think it is a priority. He's been notified several times. :)

ahh  ok.    Thanks for Information Tobias Solem.

Notification issue. 

 

and After a restart  then the server is back online you spawn 500 Meter or more not from the spawn who you dc. 

and i think the Lock System from Exile and Autokick in Infistar Real time Restart Woud be nice.

Share this post


Link to post
Share on other sites

just disable the exile built-in restart function when using infi to do it

useShutdown = 1;  -> useShutdown = 0;

simple as that...

 

i would also disable useRestartMessages and useAutoKick because the times wont match

Share this post


Link to post
Share on other sites
29 minutes ago, AFC~Gagi2~ said:

just disable the exile built-in restart function when using infi to do it

useShutdown = 1;  -> useShutdown = 0;

simple as that...

 

i would also disable useRestartMessages and useAutoKick because the times wont match

i try it yesterday  its work but @moment i use the normaly restart from exileconfig.  

this with infistar is working but you have no display timer for restart 10 minits then restart or so.  and after a restart you spawn 5km or so away. i think he must implementet auto lock autokick in infistar  this revolse then.  sry bad eng... ^^ ride me steam ? :D xDD 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.