• 0
Sign in to follow this  
TheRavenBlue

ExAd not loading map!

Question

The RTP error:

"ExileServer - Database Error: Error Statement Exception"
Error in expression <umberOfVehicles - 1 do 
{
((_vehicleIDs select _i)select 0) call ExileServer_obj>
  Error position: <select _i)select 0) call ExileServer_obj>
  Error Generic error in expression
File exile_server\code\ExileServer_world_loadAllDatabaseVehicles.sqf, line 25
Fresnel k must be >0, given n=1,k=0

What is the problem, I'm not familiar with ArmA 3 error but if I understand this correctly is it a MySQL problem?

 

Share this post


Link to post
Share on other sites

3 answers to this question

  • 0

Did you update your database for ExAd Virtual Garage? Did you update your exile.ini for your database? Does your database logs say anything?

Edited by Beowulfv

Share this post


Link to post
Share on other sites
  • 0
12 hours ago, TheRavenBlue said:

The RTP error:


"ExileServer - Database Error: Error Statement Exception"
Error in expression <umberOfVehicles - 1 do 
{
((_vehicleIDs select _i)select 0) call ExileServer_obj>
  Error position: <select _i)select 0) call ExileServer_obj>
  Error Generic error in expression
File exile_server\code\ExileServer_world_loadAllDatabaseVehicles.sqf, line 25
Fresnel k must be >0, given n=1,k=0

What is the problem, I'm not familiar with ArmA 3 error but if I understand this correctly is it a MySQL problem?

 

I had this problem too, for me the solution was adding the database update:

Read the instructions here for VG Install: https://github.com/Bjanski/ExAd/blob/master/docs/VirtualGarage/installation.md

  • Run the following sql command in you database.
    ALTER TABLE `vehicle` ADD `territory_id` INT(11) UNSIGNED NULL DEFAULT NULL;
    ALTER TABLE `vehicle` ADD CONSTRAINT `vehicle_ibfk_2` FOREIGN KEY (`territory_id`) REFERENCES `territory`(`id`) ON DELETE CASCADE ON UPDATE RESTRICT;
  • Copy over content from "@ExileServer\extDB\sql_custom_v2\exile.ini" - Follow the instructions in the file.

Share this post


Link to post
Share on other sites
  • 0
37 minutes ago, manOwar_AFD said:

I had this problem too, for me the solution was adding the database update:

Read the instructions here for VG Install: https://github.com/Bjanski/ExAd/blob/master/docs/VirtualGarage/installation.md

  • Run the following sql command in you database.

    ALTER TABLE `vehicle` ADD `territory_id` INT(11) UNSIGNED NULL DEFAULT NULL;
    ALTER TABLE `vehicle` ADD CONSTRAINT `vehicle_ibfk_2` FOREIGN KEY (`territory_id`) REFERENCES `territory`(`id`) ON DELETE CASCADE ON UPDATE RESTRICT;
  • Copy over content from "@ExileServer\extDB\sql_custom_v2\exile.ini" - Follow the instructions in the file.

Thank you I had missed that!

  • Like 1

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.