Cloud22

[Done] ExtDb3 Compatibility with Exile

835 posts in this topic

On 11/12/2017 at 5:27 PM, Cloud22 said:

It would be more efficient to check if the object is an air vehicle. Ground vehicles don't seem to have this issue.

Already did, but it seems to only effect some maps, such as Tanoa
 

if(_vehicleObject isKindOf "Air")then
{
    _vehicleObject enableSimulationGlobal true;
    _vehicleObject enableDynamicSimulation false;
}
else
{
    _vehicleObject enableSimulationGlobal false;
    _vehicleObject enableDynamicSimulation true;
};

 

  • Like 1

Share this post


Link to post
Share on other sites

So how do I go about setting up a new server once the database has been converted to 64 bit?  I already have one running in 64-bit.  I set up the new server, create the new schema, and then run the SQL query that comes with the 32-bit Arma in order to create the tables.   I figure once that is done, I'd run Exile_Database_Update_64x.sql.  But when I run the base exile.sql, I get this error:

Spoiler
0 4 18:57:34 playerhitpoints-- -------------------------------------------------------- -- Host:                         127.0.0.1 -- Server version:               5.6.26-log - MySQL Community Server (GPL) -- Server OS:                    Win64 -- HeidiSQL Version:             9.2.0.4970 -- -------------------------------------------------------- /*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */ Error Code: 1064. You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'playerhitpoints-- -------------------------------------------------------- -- Ho' at line 1 0.000 sec

I'm using mySQL workbench.   So of course the tables don't get created.   And I can't just run  Exile_Database_Update_64x.sql because there are no tables to update.

Edit:  D'oh!   extra characters in line 1... I didn't look closely enough at what the logfile was telling me.

Edited by Bob_the_K

Share this post


Link to post
Share on other sites
Advertisement

Can anyone help me? i got this error
 

Spoiler

[21:34:35:927625 +01:00] [Thread 41388] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Callname insert_infiSTARLog
[21:34:37:761140 +01:00] [Thread 50400] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Input String loadTerritoryVehicles:10
[21:34:37:761417 +01:00] [Thread 50400] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Callname loadTerritoryVehicles
[21:34:37:765740 +01:00] [Thread 50400] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Input String loadTerritoryVehicles:11
[21:34:37:766080 +01:00] [Thread 50400] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Callname loadTerritoryVehicles
[21:34:37:770907 +01:00] [Thread 50400] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Input String loadTerritoryVehicles:12
[21:34:37:771251 +01:00] [Thread 50400] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Callname loadTerritoryVehicles
[21:34:37:842291 +01:00] [Thread 50400] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Input String loadTerritoryVehicles:14
[21:34:37:843215 +01:00] [Thread 50400] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Callname loadTerritoryVehicles
[21:34:37:868825 +01:00] [Thread 50400] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Input String loadTerritoryVehicles:15
[21:34:37:869135 +01:00] [Thread 50400] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Callname loadTerritoryVehicles

 

Share this post


Link to post
Share on other sites

@Syarho hi ,

change that in your exile.ini

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;;    Author: Chris(tian) "infiSTAR" Lorenzen
;;    Contact: infiSTAR23@gmail.com // www.infiSTAR.de
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;;    please add everything below this comment to the bottom of your exile.ini file
;;    to allow your exileserver/infiSTAR to communicate with your database!
;;    
;;    path where exile.ini should be:
;;    Arma 3\@ExileServer\extDB\sql_custom_v2
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

 

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; infiSTAR Logs
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

[insert_infiSTARLog]
SQL1_1 = INSERT INTO infistar_logs SET servername = ?, logname = ?, logentry = ?
;; Number Of Inputs = 3
SQL1_INPUTS = 1,2,3

[getTotalConnections]
SQL1_1 = SELECT first_connect_at,last_connect_at,total_connections FROM account WHERE uid = ?
;; Number Of Inputs = 1
SQL1_INPUTS = 1
OUTPUT = 1

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; infiSTAR WhiteList
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

[getAccountWhitelisted]
SQL1_1 = SELECT whitelisted FROM account WHERE uid = ?
;; Number Of Inputs = 1
SQL1_INPUTS = 1
OUTPUT = 1


;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;;    Author: Chris(tian) "infiSTAR" Lorenzen
;;    Contact: infiSTAR23@gmail.com // www.infiSTAR.de
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;;    please add everything below this comment to the bottom of your exile.ini file
;;    to allow your exileserver/infiSTAR to communicate with your database!
;;    
;;    path where exile.ini should be:
;;    Arma 3\@ExileServer\extDB\sql_custom_v2
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;


;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; infiSTAR Territory Management
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

[setTerritoryName]
SQL1_1 = UPDATE territory SET name = ? WHERE id = ?
SQL1_INPUTS = 1,2

[setTerritoryFlagTexture]
SQL1_1 = UPDATE territory SET flag_texture = ? WHERE id = ?
SQL1_INPUTS = 1,2

[setTerritoryPos]
SQL1_1 = UPDATE territory SET position_x = ? , position_y = ? , position_z = ? WHERE id = ?
SQL1_INPUTS = 1,2,3,4

[getAccountName]
SQL1_1 = SELECT name FROM account WHERE uid = ?
SQL1_INPUTS = 1
OUTPUT = 1

[getFlagStolenBy]
SQL1_1 = SELECT flag_stolen_by_uid FROM territory WHERE id = ?
SQL1_INPUTS = 1
OUTPUT = 1

 

Share this post


Link to post
Share on other sites

i changed this but problem stil exist
 

Spoiler

[15:18:30:299284 +01:00] [Thread 52272] extDB3: Locked
[15:18:37:856863 +01:00] [Thread 52272] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Input String loadTerritoryVehicles:10
[15:18:37:857084 +01:00] [Thread 52272] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Callname loadTerritoryVehicles
[15:18:37:861238 +01:00] [Thread 52272] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Input String loadTerritoryVehicles:11
[15:18:37:861449 +01:00] [Thread 52272] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Callname loadTerritoryVehicles
[15:18:37:865692 +01:00] [Thread 52272] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Input String loadTerritoryVehicles:12
[15:18:37:865884 +01:00] [Thread 52272] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Callname loadTerritoryVehicles
[15:18:37:951627 +01:00] [Thread 52272] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Input String loadTerritoryVehicles:14
[15:18:37:951836 +01:00] [Thread 52272] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Callname loadTerritoryVehicles
[15:18:37:956786 +01:00] [Thread 52272] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Input String loadTerritoryVehicles:15
[15:18:37:957046 +01:00] [Thread 52272] extDB3: SQL_CUSTOM: Error No Custom Call Not Found: Callname loadTerritoryVehicles

exile.ini

https://pastebin.com/8NiKHdnJ

this exile.ini logs are use by infistar territory magement? i dont have this addon.

Share this post


Link to post
Share on other sites

if dont use Infistar territory delete this:

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;;    Author: Chris(tian) "infiSTAR" Lorenzen
;;    Contact: infiSTAR23@gmail.com // www.infiSTAR.de
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;;    please add everything below this comment to the bottom of your exile.ini file
;;    to allow your exileserver/infiSTAR to communicate with your database!
;;    
;;    path where exile.ini should be:
;;    Arma 3\@ExileServer\extDB\sql_custom_v2
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;


;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; infiSTAR Territory Management
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

[setTerritoryName]
SQL1_1 = UPDATE territory SET name = ? WHERE id = ?
SQL1_INPUTS = 1,2

[setTerritoryFlagTexture]
SQL1_1 = UPDATE territory SET flag_texture = ? WHERE id = ?
SQL1_INPUTS = 1,2

[setTerritoryPos]
SQL1_1 = UPDATE territory SET position_x = ? , position_y = ? , position_z = ? WHERE id = ?
SQL1_INPUTS = 1,2,3,4

[getAccountName]
SQL1_1 = SELECT name FROM account WHERE uid = ?
SQL1_INPUTS = 1
OUTPUT = 1

[getFlagStolenBy]
SQL1_1 = SELECT flag_stolen_by_uid FROM territory WHERE id = ?
SQL1_INPUTS = 1
OUTPUT = 1

 

Share this post


Link to post
Share on other sites

But i dont had this, i had only this

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; infiSTAR Logs
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

[insert_infiSTARLog]
SQL1_1 = INSERT INTO infistar_logs SET servername = ?, logname = ?, logentry = ?
;; Number Of Inputs = 3
SQL1_INPUTS = 1,2,3

[getTotalConnections]
SQL1_1 = SELECT first_connect_at,last_connect_at,total_connections FROM account WHERE uid = ?
;; Number Of Inputs = 1
SQL1_INPUTS = 1
OUTPUT = 1

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; infiSTAR WhiteList
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

[getAccountWhitelisted]
SQL1_1 = SELECT whitelisted FROM account WHERE uid = ?
;; Number Of Inputs = 1
SQL1_INPUTS = 1
OUTPUT = 1


and problem still exist :/

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.