Cloud22

[Done] ExtDb3 Compatibility with Exile

835 posts in this topic

@Cloud22 Can't get it working. Fresh installed server, all working before switching to extdb3. Server freezes and I can't login to it.

Can you help me? I followed all steps 3 times, also dropped the schema and started again. The original RPT is too much longer, like 90mb, I reduced it because it's the same error again, and again, and again...

RPT: https://pastebin.com/KSUvcFbC

DB log:


extDB3: https://bitbucket.org/torndeco/extdb3/wiki/Home
extDB3: Version: 1.031
extDB3: Windows Version
Message: All development for extDB3 is done on a Linux Dedicated Server
Message: If you would like to Donate to extDB3 Development
Message: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=2SUEFTGABTAM2
Message: Also leave a message if there is any particular feature you would like to see added.
Message: Thanks for all the people that have donated.
Message: Torndeco: 18/05/15


extDB3: Found extdb3-conf.ini
extDB3: Detected 8 Cores, Setting up 6 Worker Threads
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...

DB version:

fTC_dfOYSTWD8Rxy_B-Vdg.png

Edited by kosako17

Share this post


Link to post
Share on other sites
Advertisement

 You have a few errors on other files, but also looks like the install of extdb3 is not correct too.  Or maybe a addon on that you might be using is still calling for extdb2

Spoiler

 9:54:22 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong."
 9:54:22 "ExileServer - MySQL Error: Unable to locate extDB2 extension!"
 9:54:22 "ExileServer - Server will shutdown now :("
 9:54:22 CallExtension 'extDB2' could not be found
 
  9:54:22 "<infiSTAR.de> 0 - infiSTAR_defines.hpp is not in your MPMission or you forgot to #include it within your description.ext   [21598x2 

9:54:17 Error context / 1 = enabled, 0 = disabled
 9:54:17 Warning Message: File mpmissions\__cur_mp.Malden\config.cpp, line 3154: '/CfgExileEnvironment/Altis/FireFlies.': '/' encountered instead of '='
 9:54:17 Warning Message: Config : some input after EndOfFile.

 

Edited by Razor77
  • Like 2

Share this post


Link to post
Share on other sites
32 minutes ago, Razor77 said:

 You have a few errors on other files, but also looks like the install of extdb3 is not correct too.  Or maybe a addon on that you might be using is still calling for extdb2

  Hide contents

 9:54:22 "ExileServer - Please have a look at @ExileServer/extDB/logs/ to find out what went wrong."
 9:54:22 "ExileServer - MySQL Error: Unable to locate extDB2 extension!"
 9:54:22 "ExileServer - Server will shutdown now :("
 9:54:22 CallExtension 'extDB2' could not be found
 
  9:54:22 "<infiSTAR.de> 0 - infiSTAR_defines.hpp is not in your MPMission or you forgot to #include it within your description.ext   [21598x2 

9:54:17 Error context / 1 = enabled, 0 = disabled
 9:54:17 Warning Message: File mpmissions\__cur_mp.Malden\config.cpp, line 3154: '/CfgExileEnvironment/Altis/FireFlies.': '/' encountered instead of '='
 9:54:17 Warning Message: Config : some input after EndOfFile.

 

I'm pretty sure that the extdb3 installation is correct, I checked it 3 times.

infiSTAR error; idk why the log says that, because infiSTAR is working fine, and I checked all files and are correct.

Error context and warning message; well, checked the error and I did not see the error that the log says, this is the Altis class:

class Altis 
	{
		class FireFlies
		{
			// 1 = enabled, 0 = disabled
			enable = 0;

			// At this hour fire flies begin to spawn
			startHour = 18;

			// At this hour fire flies stop spawning
			endHour = 4;
		};

The only option that makes sense is the "addon calling extdb2", but I tried to disable all addons and even infiSTAR, with the same result.

EDIT: I'm reinstalling the server from zero. I'll tell you if the issue remains after it.

Edited by kosako17
  • Like 1

Share this post


Link to post
Share on other sites
23 minutes ago, Razor77 said:

are you calling for the overrides in your config.cpp.   Still looks like something is trying to call extdb2

Nope, the mission file is untouched, but I solved the problem. 

I switched from Malden to Altis and... MAGIC! It works. Maybe the Malden mission file has any issue with extdb3.

Share this post


Link to post
Share on other sites
1 hour ago, kosako17 said:

Nope, the mission file is untouched, but I solved the problem. 

I switched from Malden to Altis and... MAGIC! It works. Maybe the Malden mission file has any issue with extdb3.

It shouldn't have any issues with extDB3; I wrote that mission file and used it on my personal Malden server with extDB3 up until very recently.

Share this post


Link to post
Share on other sites
32 minutes ago, kuplion said:

It shouldn't have any issues with extDB3; I wrote that mission file and used it on my personal Malden server with extDB3 up until very recently.

So what could be causing my issue? I used the stock Exile.Malden file, only added the overwrites for extdb3.

Share this post


Link to post
Share on other sites
1 hour ago, kosako17 said:

So what could be causing my issue? I used the stock Exile.Malden file, only added the overwrites for extdb3.

Without looking over all your server RPT files I honestly couldn't say. I just wanted to point out that it's not the Malden mission file as I (and hundreds of other people) use it absolutely fine.

Just to add to that, the one way a mission file would become incompatible is if you have a call in it to the wrong extension, which would only be added by the end user.

  • Like 1

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.