YOLOcakes

[SOLVED] [SOLVED] Infistar install issue

8 posts in this topic

Hello all. So I have what appears to be a common problem but I am unable to install InfiSTAR exile version without causing problems for myself. You should know that I am posting here since this is my last resort, I have searched the internet for hours looking for a solution and have found nothing. I am going to upload as much as I can here in hope that someone can identify and help me fix my issue. I have checked my error logs and it states that the AdminMenu.hpp is not being found or has not been included in the description file. Below you can see the error log and all of the screenshots of my server files etc. 

Huge thanks in advance to anyone who can help me solve this!

Error log:

Spoiler

17:14:41 "<infiSTAR.de> 0 - removing invalid admin uid UID3"
17:14:41 "<infiSTAR.de> 0 - removing invalid admin uid ..."
17:14:41 "<infiSTAR.de> 0 - TESTING IF serverCommandPassword IS SET PROPERLY"
17:14:41 "<infiSTAR.de> 0 - serverCommandPassword IS FINE"
17:14:41 "<infiSTAR.de> 0 - infiSTAR_AdminMenu.hpp is not in your MPMission or you forgot to #include it within your description.ext

Description File: 

Spoiler

 

///////////////////////////////////////////////////////////////////////////////
// Server Settings - Modify at will
///////////////////////////////////////////////////////////////////////////////
author = "Exile Mod Team";
onLoadName = "Exile Mod";
onLoadMission= "www.exilemod.com";
loadScreen = "exile_assets\texture\mod\logo.paa"; 
disableChannels[] = {0, 2};
OnLoadIntro = "";
OnLoadIntroTime = false;
OnLoadMissionTime = false;

class Header
{
    gameType = Survive; // Do NOT change this
    minPlayers = 1;
    maxPlayers = 100;
};

///////////////////////////////////////////////////////////////////////////////
// Exile Settings - Do not change these!
///////////////////////////////////////////////////////////////////////////////
forceRotorLibSimulation = 2;
skipLobby = 1;
joinUnassigned = 1;
respawn = "BASE";
respawnDelay = 120;
respawnDialog = 0;
respawnOnStart = 0;
respawnButton = 1; 
respawnTemplates[] = {"Exile"};
corpseManagerMode = 0;
corpseLimit = 20;
corpseRemovalMinTime = 1800;
corpseRemovalMaxTime = 3600;
wreckManagerMode = 0;
wreckLimit = 2;
wreckRemovalMinTime = 60;
wreckRemovalMaxTime = 360;
scriptedPlayer = 1;
disabledAI = 1;
enableItemsDropping = 0;
briefing = 0;
debriefing = 0;
allowFunctionsLog = 1;
enableDebugConsole = 0; 
allowFunctionsRecompile = 0;
showSquadRadar = 0;
showUAVFeed = 0;
reviveDelay = 6;
reviveForceRespawnDelay = 3;
reviveBleedOutDelay = 120;

showHUD[] = 
{
    true,   // Scripted HUD (same as showHUD command)
    true,   // Vehicle + soldier info
    true,   // Vehicle radar 
    true,   // Vehicle compass
    true,   // Tank direction indicator
    false,  // Commanding menu
    false,  // Group Bar
    true,   // HUD Weapon Cursors
    false   // Squad Radar
};

#include "config.cpp"
#include "CfgRemoteExec.hpp"
#include "infiSTAR_AdminMenu.hpp"

 

Server Files Image's

 

Again, huge thanks to whoever can help me!

Edited by YOLOcakes

Share this post


Link to post
Share on other sites

Hey

 remove the backup file of your mpmission (that might already solve the issue)
do not keep backup files in your arma folder on the server :P

even if you name it .backup or something, it is probably loaded from Arma and doesn't contain the #include for the .hpp file which is why it tells you it is not included :)

Share this post


Link to post
Share on other sites
Advertisement

HI, so I have done as you said and it worked-sorta. That specific error has gone but when I check the logs now I have no information related to Infistar at all. Not 100% but shouldn't it still show up even if it works? Also thanks for the quick reply!

UPDATE: So I have managed to find infistar in the log but this is what it states, this is the only thing it states with no errors showing at all but when I am in-game it still does not seem to allow me to access the menu or give any notification that infiSTAR is working.

Spoiler

17:37:09                                               name |               modDir |    default |               origin |                                     hash | hashShort | fullPath
17:37:09 ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
17:37:09                                    @infiSTAR_Exile |      @infiSTAR_Exile |      false |             GAME DIR |                                          |           | C:\SERVICES\ni1193683_1_SHARE\ftproot\arma3\@infiSTAR_Exile

 

Edited by YOLOcakes

Share this post


Link to post
Share on other sites

Another Update: So after reading through readme file again I have removed the @infiSTAR_Exile folder and put the PBO inside of the Exile gamemode directly. After checking the rpt file I have once again had the same error that the AdminMenu is not in my MPMission. I have not changed anything since the last screenshots other than the file being moved. 

New Location:

https://gyazo.com/a6de64fa68ef1e523abe659a74113008

The error is the exact same as before :P

Share this post


Link to post
Share on other sites

lol that's so confusing 

for the server side mod you can really do what ever you want e.g. putting it in it's own folder and start it as -serverMod or move the pbo into the exile server folder like you did now. That's just what you prefer :)

You only have one Exile.Altis.pbo in your mpmission folder? No folder named "Exile.Altis" or some kind of "Exile.Altis.bak" ? :D

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.