clarkycalLad

[Release] DMS Chernarus Static AI Base Mission

32 posts in this topic

keep getting this error:   

"Warning Message: Script \x\addons\DMS\missions\static\aibase_nwaf.sqf not found"

i think it is supposed to use "a3_DMS" and not "DMS" in the path... however i cannot seem to find where it is being called from...

Share this post


Link to post
Share on other sites

also noticed that the mission is named "AIStaticBase" in "DMS_StaticMissionTypes" and named "aibase_nwaf" in "DMS_StaticMissionsOnServerStart" and in the missions\static folder the mission is named "AIStaticBase" ....

 

image.thumb.png.4bd65834624fb6c3118109d7b25c80a2.png

Share this post


Link to post
Share on other sites
Advertisement

i changed the names... and now the mission *ai and loot crates* spawn.... however none of the buildings or obstacles are loading...  and the mission is north of the airfield, im not sure how its supposed to look though so maybe this is where its supposed to be... 

 

image.thumb.png.6470506699ed20cc083167dab02ced2c.png

 

Edited by looonytoonz

Share this post


Link to post
Share on other sites

sorry my bad
add "aibase_nwaf" to DMS_BasesToImportOnServerStart , not to DMS_StaticMissionsOnServerStart to load objects on server start
this is where it should be

Edited by Chernaruski
  • Like 1

Share this post


Link to post
Share on other sites

none of the doors open for any of these buildings , any ideas ?   this is also true for all other missions... the buildings in zcp work so this must be something to do with DMS im guessing..

 

ps.... loot does seem to spawn inside a few of these buildings, but the doors dont work so it kinda taunts you 

Edited by looonytoonz

Share this post


Link to post
Share on other sites

Go to aibase_nwaf.sqf and change  [false,false] to [true,false] , to all buildings classnames you want to be able to open.
for example:

["Land_Mil_ControlTower_EP1",[4121.652344,10920.859375,339.0680542],[[0.732248,-0.681039,0],[0,0,1]],[true,false]],

When I was placing the objects I forgot about the buildings that require enableSimulationGlobal to be on to be able to open doors.
PS: same thing for other missions, if it have the enableSimulationGlobal parameter = false , you wont be able to open doors.

Edited by Chernaruski
  • Like 1

Share this post


Link to post
Share on other sites

I need some help with this, for some reason, i edited all the AI vics and the  vics that spawn in will not change still the same 2 off road armed. Also i changed the name of the mission in the sqf and it doesnt change. i enabled the CUP vics for the AI and the arma vics, both lists are about 15 vics long and still the only the 2 that spawn are the 2 off road. there is no where else to edit the vic types correct? its only the 1 sqf. do you have a solution for this?

Edited by SILENTHERO
problem changed

Share this post


Link to post
Share on other sites
On 1/27/2019 at 11:30 PM, Chernaruski said:

Any DMS Static Mission can be ported to a different map , all you need to do is :

1) In your static objects sqf file (probably located @ dmsfolder/objects/static) change 
 


private _vehicle = (_x select 0) createVehicle (_x select 1);

to


 private _vehicle =  create3DENEntity ["Object",(_x select 0),(_x select 1),true]; 

and just run the whole sqf in Debug Console. This will import static mission object to eden editor , so you can move , tweak and place the objects wherever you want and export back to sqf with Exile 3DEN plugin.

2) As for AI , static guns , vehicles and crates... you will have to place them manually and copy paste the selected positions to a static mission sqf
in a correct array 

 


_AISoldierSpawnLocations =   for AI infantry
_staticGuns = for static guns 
_veh = for vehicles
_veh2 =
.
.
.

etc.


If you guys interested , I can port this to ChernarusRedux map. Already placed it around @ NWAF area.
jBnNihQ.jpg

is not working...

all stuff spawns in sky and all objekts has the wrong angle/vector  all has 0°

 

I have tested this one

 

collect3DENHistory
{
    {
        private[ "_obj" ];
        _x params[ "_type", "_pos", "_rot" ];

        _obj = create3DENEntity [ "Object", _type, _pos, true ]; 			
        _obj set3DENAttribute [ "rotation",[ 0,0,_rot ] ];

    }forEach

	[
	
    ["Land_ConcreteWall_01_l_gate_F",[22185.8,14547.4,3.01404],[[0.90137,0.433051,0],[0,0,1]],[true,false]],
	["Land_ConcreteWall_01_l_8m_F",[22188.5,14538.8,3.125],[[-0.993572,-0.113204,0],[0,0,1]],[false,false]]
	
    ];
};

 

and your one

collect3DENHistory
{

	{
		private [ "_vehicle" ];
		_vehicle =  create3DENEntity ["Object",(_x select 0),(_x select 1),true]; 		//aus dem forum
		
	}foreach
	
	[
	
["TK_GUE_WarfareBBarrier10xTall_EP1", [6367.03, 14079.2, 331.783], [0, 0.9994, -0.0346456], [-0.0093285, 0.0346441, 0.999356], true],
["TK_GUE_WarfareBBarrier10xTall_EP1", [6382.62, 14079.2, 331.892], [0, 0.999304, -0.0373063], [-0.00399675, 0.037306, 0.999296], true],
["TK_GUE_WarfareBBarrier10xTall_EP1", [6413.77, 14079.3, 331.9], [0, 0.999253, -0.038638], [0.00533751, 0.0386375, 0.999239], true]

	]
};

 

but all time the same. High of objekts wrong and vector is wrong ,too

and if i only replace that stuff in the orginal dms mission file there will spawn nothing

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.