• 0
Lenzh | 11thAMB

Bloodlust

Question

My post got removed, Bloodlust isnt working on my server and there is no installation guide or anything...

please help

Share this post


Link to post
Share on other sites

19 answers to this question

  • 0

Look for blood lust lite on biforum. There is a script u need to add to your mission and your cfg remote exec to make work.  if u cannot find it lmk and I will post it in the AM when at my pc

Share this post


Link to post
Share on other sites
  • 0

i cant find a installation part

17 hours ago, tinboye said:

Look for blood lust lite on biforum. There is a script u need to add to your mission and your cfg remote exec to make work.  if u cannot find it lmk and I will post it in the AM when at my pc

 

Share this post


Link to post
Share on other sites
Advertisement
  • 0
6 minutes ago, Lenzh | 11thAMB said:

i cant find a installation part

 

i can only find the init part
 

Spoiler

BloodLust_InitUnit =
{
   _unit = _this select 0;
   [_unit] call BloodLust_AddUnitEventHandlers;
};
 
BloodLust_OnUnitRespawn =
{
   _unit = _this select 0;
   _corpse = _this select 1;
   [_unit] remoteExec ["BloodLust_AddUnitEventHandlers"];
};
 
BloodLust_AddUnitEventHandlers =
{
   _unit = _this select 0;
   _unit addEventHandler ["Fired",
   {
       _this call BloodLust_OnUnitFired;
   }];
   _unit addEventHandler ["HitPart",
   {
       _this remoteExec ["BloodLust_OnUnitHitPart"];
   }];
   _unit addEventHandler ["Explosion",
   {
       _this remoteExec ["BloodLust_OnUnitExplosion"];
 
   }];
};

 

Share this post


Link to post
Share on other sites
  • 0

yes create a file calling it bloodlust.sqf, place in your mission folder

add

Spoiler

BloodLust_InitUnit =
{
   _unit = _this select 0;
   [_unit] call BloodLust_AddUnitEventHandlers;
};
 
BloodLust_OnUnitRespawn =
{
   _unit = _this select 0;
   _corpse = _this select 1;
   [_unit] remoteExec ["BloodLust_AddUnitEventHandlers"];
};
 
BloodLust_AddUnitEventHandlers =
{
   _unit = _this select 0;
   _unit addEventHandler ["Fired",
   {
       _this call BloodLust_OnUnitFired;
   }];
   _unit addEventHandler ["HitPart",
   {
       _this remoteExec ["BloodLust_OnUnitHitPart"];
   }];
   _unit addEventHandler ["Explosion",
   {
       _this remoteExec ["BloodLust_OnUnitExplosion"];
 
   }];
};

bloodlustLITE_bloodmultiplier = 4; 

 

add to your inti.sqf

[] execVM "bloodlust.sqf"

in your

class CfgRemoteExec add

class bloodlust_onunithitpart { allowedTargets=2; };

look at https://community.bistudio.com/wiki/CfgRemoteExec

fore more info on that file

Edited by tinboye
1 person likes this

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, tinboye said:

yes create a file calling it bloodlust.sqf, place in your mission folder

add

  Reveal hidden contents


BloodLust_InitUnit =
{
   _unit = _this select 0;
   [_unit] call BloodLust_AddUnitEventHandlers;
};
 
BloodLust_OnUnitRespawn =
{
   _unit = _this select 0;
   _corpse = _this select 1;
   [_unit] remoteExec ["BloodLust_AddUnitEventHandlers"];
};
 
BloodLust_AddUnitEventHandlers =
{
   _unit = _this select 0;
   _unit addEventHandler ["Fired",
   {
       _this call BloodLust_OnUnitFired;
   }];
   _unit addEventHandler ["HitPart",
   {
       _this remoteExec ["BloodLust_OnUnitHitPart"];
   }];
   _unit addEventHandler ["Explosion",
   {
       _this remoteExec ["BloodLust_OnUnitExplosion"];
 
   }];
};

bloodlustLITE_bloodmultiplier = 4; 

 

add to your inti.sqf

[] execVM "bloodlust.sqf"

in your

class CfgRemoteExec add

class bloodlust_onunithitpart { allowedTargets=2; };

look at https://community.bistudio.com/wiki/CfgRemoteExec

fore more info on that file

<3

Share this post


Link to post
Share on other sites
  • 0

i have not played with it that much, the current settings i showed, would show blood spatter when you get shot, but i didnt see any on AI, i think that has to do with the class bloodlust_onunithitpart { allowedTargets=2; };  and what targets are allowed to use it.  maybe try

 allowedTargets=0;

and see if blood shows for zombies/AI

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, tinboye said:

i have not played with it that much, the current settings i showed, would show blood spatter when you get shot, but i didnt see any on AI, i think that has to do with the class bloodlust_onunithitpart { allowedTargets=2; };  and what targets are allowed to use it.  maybe try


 allowedTargets=0;

and see if blood shows for zombies/AI

ill try it thanks for your help

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.