• 0
joew00

[SOLVED] Hotfix Doors Don't Works

Question

Hi!

I'm having trouble with the doors at traders. I tried it at NE trader, and the doors don't open.

Map: Altis
Exile version: 1.0.2
Server OS: Win 2008 Server
Arma 3 Dedicated Server 32 bits with extDB2
Arma 3 Client 64 bits

So i did:
1- Copy and paste the EBM folder into mission pbo.
2- Replaced mission.pbo EBM\exileServer_object_construction_database_load.sqf to the @Eichi temp fix:

3- Added in mission pbo config.cpp, inside class CfgExileCustomCode the code:

exileServer_object_construction_database_load = "EBM\exileServer_object_construction_database_load.sqf"; //Original fix by Eichi

4- Repack the pbo and start server again.
5- Deleted the mission pbo on client.


But the doors at NE trader (the one that i've tested yet) still don't open.

Could anyone help me, please?

Thank you!

SOLVED!!!

You need to change the first false to true on all building's names in the file: initServer.sqf that are on trader's zone.
You can get the names ids with infiStar.

I don't have infiStar, so i thank to:

- ☢klingiii☢ for list me all buildings :D

Spoiler

 

On 28/03/2017 at 7:53 PM, ☢klinGiii☢ said:

West Trader City : 

Land_i_Shed_Ind_F

 

East : 

Land_CarService_F

Land_City_Gate_F   (2x!!!)

Land_i_Shop_01_V1_F

Land_Kiosk_redburger_F

Land_GH_House_2_F

Land_i_Shop_01_V1_F

 

- @Dubius for share all your initServer.sqf:

Thank you so much all others too that helped me on the way to fix this bug ;)
- @lapulapu , @GamersRoost and @Bombstock !!!

Edited by joew00

Share this post


Link to post
Share on other sites

9 answers to this question

  • 1

Havent used Altis in awhile, but took a quick look in the default Exile.Altis.pbo

Check out the initServer.sqf

Looks like for all spawned objects enableSimulationGlobal is set to false.

eg:

["Land_CarService_F", [14618.7,16877.4,18.7724], [[0.750538,-0.660827,0],[0,0,1]], [false, false]],

That 1st false would need to be changed to true for any structures you would wants doors to work on.

So find the classnames of all the buildings you want to work in that file, and update that false to true.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, joew00 said:

Hi!

I'm having trouble with the doors at traders. I tried it at NE trader, and the doors don't open.

Map: Altis
Exile version: 1.0.2
Server OS: Win 2008 Server
Arma 3 Dedicated Server 32 bits with extDB2
Arma 3 Client 64 bits

So i did:
1- Copy and paste the EBM folder into mission pbo.
2- Replaced mission.pbo EBM\exileServer_object_construction_database_load.sqf to the @Eichi temp fix:

3- Added in mission pbo config.cpp, inside class CfgExileCustomCode the code:


exileServer_object_construction_database_load = "EBM\exileServer_object_construction_database_load.sqf"; //Original fix by Eichi

4- Repack the pbo and start server again.
5- Deleted the mission pbo on client.


But the doors at NE trader (the one that i've tested yet) still don't open.

Could anyone help me, please?

Thank you!

Plain and simple, based off of your information here, I will help you.

This will resolve your issue if you follow it to the letter.

Navigate to your MPmissions folder:

MPmissions\exile.altis

Create an  "Overwrites" folder in that directory.

Open a text editor like Notepad++.

Copy this text into it:

Spoiler

/**
 * ExileServer_object_construction_database_load
 *
 * Exile Mod
 * www.exilemod.com
 * © 2015 Exile Mod Team
 *
 * This work is licensed under the Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License. 
 * To view a copy of this license, visit http://creativecommons.org/licenses/by-nc-nd/4.0/.
 */
 
private["_constructionID","_data","_position","_vectorDirection","_vectorUp","_constructionObject","_damageLevel","_public","_pinCode"];
_constructionID = _this;
_data = format ["loadConstruction:%1", _constructionID] call ExileServer_system_database_query_selectSingle;
_position = [_data select 4, _data select 5, _data select 6];
_vectorDirection = [_data select 7, _data select 8, _data select 9];
_vectorUp = [_data select 10, _data select 11, _data select 12];
_constructionObject = createVehicle [(_data select 1), _position, [], 0, "CAN_COLLIDE"];
_constructionObject setPosATL _position;
_constructionObject setVectorDirAndUp [_vectorDirection, _vectorUp];
_constructionObject setVariable ["ExileDatabaseID", _data select 0];
_constructionObject setVariable ["ExileOwnerUID", (_data select 2)];
_constructionObject setVariable ["ExileIsPersistent", true];
_constructionObject setVariable ["ExileTerritoryID", (_data select 15)];
_damageLevel = (_data select 17);
_public = _damageLevel > 0;
_constructionObject setVariable ["ExileConstructionDamage",_damageLevel,_public];
if(_public)then
{
    _constructionObject call ExileServer_util_setDamageTexture;
};
_pinCode = _data select 14;
if !(_pinCode isEqualTo "000000") then
{
    _constructionObject setVariable ["ExileAccessCode", _pinCode];
    _constructionObject setVariable ["ExileIsLocked", (_data select 13), true];
};

// 2017-03-16 + TEMPORARY WORKAROUND UNTIL EXILE UPDATE
//if (getNumber(configFile >> "CfgVehicles" >> (_data select 1) >> "exileRequiresSimulation") isEqualTo 1) then
//{
//    _constructionObject enableSimulationGlobal true;
//    _constructionObject call ExileServer_system_simulationMonitor_addVehicle;
//}
//else 
//{
//    _constructionObject enableSimulationGlobal false;
//};

if (typeOf _constructionObject in ["Exile_Construction_ConcreteDoor_Static", "Exile_Construction_ConcreteGate_Static", "Exile_Construction_WoodGate_Static", "Exile_Construction_WoodDoor_Static", "Exile_Construction_ConcreteWindowHatch_Static", "Exile_Construction_WoodGate_Reinforced_Static", "Exile_Construction_WoodDoor_Reinforced_Static", "Exile_Construction_ConcreteFloorHatch_Static","Land_Stone_Gate_F","Land_City_Gate_F","Land_BarGate_F","Land_Cargo_Patrol_V2_F","Land_Cargo_Tower_V2_F","Land_FuelStation_Feed_F","Land_Cargo_House_V2_F","Land_i_Garage_V2_F","Land_ToiletBox_F","Land_Dome_Big_F","Land_spp_Tower_F","Land_Airport_Tower_F","Land_i_Barracks_V1_F","Land_TTowerSmall_1_F","Land_i_House_Small_03_V1_F","Land_i_House_Big_01_V2_F","Land_PlasticCase_01_medium_F","Land_Research_HQ_F","Land_Research_house_V1_F"]) then
{
    _constructionObject enableSimulationGlobal true;
    _constructionObject call ExileServer_system_simulationMonitor_addVehicle;
}
else 
{
    _constructionObject enableSimulationGlobal false;
};

// 2017-03-16 - TEMPORARY WORKAROUND UNTIL EXILE UPDATE

_constructionObject setVelocity [0, 0, 0];
_constructionObject setPosATL _position;
_constructionObject setVelocity [0, 0, 0];
_constructionObject setVectorDirAndUp [_vectorDirection, _vectorUp];
_constructionObject setVelocity [0, 0, 0];
_constructionObject

 

At the top click the FILE menu and then click "saveAs".

1.png

A window will open asking where to save it

2.png

In that window open the location  of your MPmissions\exile.Altis\Overwrites folder.

3.png

In the File name: box paste this filename EXACTLY as shown... ExileServer_object_construction_database_load.sqf

4.png

Click "Save" button.

5.png

Now open your Config.cpp from your mission folder.

6.png

Once opened on your keyboard press CTRL+F For the Find window dialog.

Paste in this text...   class CfgExileCustomCode      to the Find What box at near the top of the open dialog under the word "Mark".

 

Click Find Next.

7.png

It will locate that test that exists in only ONE PLACE in the Config (it's a class it can only show up once).

8.png

BELOW the */ and  ABOVE the }; near the bottom of the green text in the picture, paste this EXACTLY 

ExileServer_object_construction_database_load =    "Overwrites\ExileServer_object_construction_database_load.sqf";

 

It should look like this (or close to it if you have no other overrides as you mentioned at the start of this post).

9.png

Repack your mission PBO and start your server.

Hope this helps.

Josh

 

*** CREDITS GO TO THIS POST BELOW I ASSUME NO SKILL AT WRITING THIS SHIT ***

 

Edited by GamersRoost
WTF Pictures!!!!!

Share this post


Link to post
Share on other sites
Advertisement
  • 0
1 hour ago, GamersRoost said:
Spoiler

Plain and simple, based off of your information here, I will help you.

This will resolve your issue if you follow it to the letter.

Navigate to your MPmissions folder:

MPmissions\exile.altis

Create an  "Overwrites" folder in that directory.

Open a text editor like Notepad++.

Copy this text into it:

  Hide contents

/**
 * ExileServer_object_construction_database_load
 *
 * Exile Mod
 * www.exilemod.com
 * © 2015 Exile Mod Team
 *
 * This work is licensed under the Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License. 
 * To view a copy of this license, visit http://creativecommons.org/licenses/by-nc-nd/4.0/.
 */
 
private["_constructionID","_data","_position","_vectorDirection","_vectorUp","_constructionObject","_damageLevel","_public","_pinCode"];
_constructionID = _this;
_data = format ["loadConstruction:%1", _constructionID] call ExileServer_system_database_query_selectSingle;
_position = [_data select 4, _data select 5, _data select 6];
_vectorDirection = [_data select 7, _data select 8, _data select 9];
_vectorUp = [_data select 10, _data select 11, _data select 12];
_constructionObject = createVehicle [(_data select 1), _position, [], 0, "CAN_COLLIDE"];
_constructionObject setPosATL _position;
_constructionObject setVectorDirAndUp [_vectorDirection, _vectorUp];
_constructionObject setVariable ["ExileDatabaseID", _data select 0];
_constructionObject setVariable ["ExileOwnerUID", (_data select 2)];
_constructionObject setVariable ["ExileIsPersistent", true];
_constructionObject setVariable ["ExileTerritoryID", (_data select 15)];
_damageLevel = (_data select 17);
_public = _damageLevel > 0;
_constructionObject setVariable ["ExileConstructionDamage",_damageLevel,_public];
if(_public)then
{
    _constructionObject call ExileServer_util_setDamageTexture;
};
_pinCode = _data select 14;
if !(_pinCode isEqualTo "000000") then
{
    _constructionObject setVariable ["ExileAccessCode", _pinCode];
    _constructionObject setVariable ["ExileIsLocked", (_data select 13), true];
};

// 2017-03-16 + TEMPORARY WORKAROUND UNTIL EXILE UPDATE
//if (getNumber(configFile >> "CfgVehicles" >> (_data select 1) >> "exileRequiresSimulation") isEqualTo 1) then
//{
//    _constructionObject enableSimulationGlobal true;
//    _constructionObject call ExileServer_system_simulationMonitor_addVehicle;
//}
//else 
//{
//    _constructionObject enableSimulationGlobal false;
//};

if (typeOf _constructionObject in ["Exile_Construction_ConcreteDoor_Static", "Exile_Construction_ConcreteGate_Static", "Exile_Construction_WoodGate_Static", "Exile_Construction_WoodDoor_Static", "Exile_Construction_ConcreteWindowHatch_Static", "Exile_Construction_WoodGate_Reinforced_Static", "Exile_Construction_WoodDoor_Reinforced_Static", "Exile_Construction_ConcreteFloorHatch_Static","Land_Stone_Gate_F","Land_City_Gate_F","Land_BarGate_F","Land_Cargo_Patrol_V2_F","Land_Cargo_Tower_V2_F","Land_FuelStation_Feed_F","Land_Cargo_House_V2_F","Land_i_Garage_V2_F","Land_ToiletBox_F","Land_Dome_Big_F","Land_spp_Tower_F","Land_Airport_Tower_F","Land_i_Barracks_V1_F","Land_TTowerSmall_1_F","Land_i_House_Small_03_V1_F","Land_i_House_Big_01_V2_F","Land_PlasticCase_01_medium_F","Land_Research_HQ_F","Land_Research_house_V1_F"]) then
{
    _constructionObject enableSimulationGlobal true;
    _constructionObject call ExileServer_system_simulationMonitor_addVehicle;
}
else 
{
    _constructionObject enableSimulationGlobal false;
};

// 2017-03-16 - TEMPORARY WORKAROUND UNTIL EXILE UPDATE

_constructionObject setVelocity [0, 0, 0];
_constructionObject setPosATL _position;
_constructionObject setVelocity [0, 0, 0];
_constructionObject setVectorDirAndUp [_vectorDirection, _vectorUp];
_constructionObject setVelocity [0, 0, 0];
_constructionObject

 

At the top click the FILE menu and then click "saveAs".

1.png

A window will open asking where to save it

2.png

In that window open the location  of your MPmissions\exile.Altis\Overwrites folder.

3.png

In the File name: box paste this filename EXACTLY as shown... ExileServer_object_construction_database_load.sqf

4.png

Click "Save" button.

5.png

Now open your Config.cpp from your mission folder.

6.png

Once opened on your keyboard press CTRL+F For the Find window dialog.

Paste in this text...   class CfgExileCustomCode      to the Find What box at near the top of the open dialog under the word "Mark".

 

Click Find Next.

7.png

It will locate that test that exists in only ONE PLACE in the Config (it's a class it can only show up once).

8.png

BELOW the */ and  ABOVE the }; near the bottom of the green text in the picture, paste this EXACTLY 

ExileServer_object_construction_database_load =    "Overwrites\ExileServer_object_construction_database_load.sqf";

 

It should look like this (or close to it if you have no other overrides as you mentioned at the start of this post).

9.png

Repack your mission PBO and start your server.

Hope this helps.

Josh

 

*** CREDITS GO TO THIS POST BELOW I ASSUME NO SKILL AT WRITING THIS SHIT ***

 

 

Thank you very much for your reply but unfortunately it doesn't works.

I did now exactly the same as your post, but still doors at Altis NE Trader Zone don't opens =(

 Exile5c6b.jpg

ExileServer_object_construction_database_load.sqf : https://pastebin.com/pLHN3NzY
 

Any idea? I don't knew but it isn't working =(

Thank you!

Share this post


Link to post
Share on other sites
  • 0
16 minutes ago, lapulapu said:

ck out the initServer.sqf

Looks like for all spawned objects enableSimulationGlobal is set to false.

Nailed it.

You rock, that will fix him. Sure of it.

I do not use Altis at all. I also never thought about opening the initserver.sqf. I was distracted (by my self)by all the posts about the databaseload. i.e. " exileServer_object_construction_database_load = "EBM\exileServer_object_construction_database_load.sqf"; //Original fix by Eichi

Well done man, I'm sure this will fix it!

Josh

Edited by GamersRoost

Share this post


Link to post
Share on other sites
  • 0

Thank you again for your help!

36 minutes ago, GamersRoost said:

Let's make sure the building is in that array. Using infistar look at the door and press shift I. And get the classname of the door.

let me know.

I don't have infistar. Do you knew another way to get the ids, please?
Anyway, im using oficial SQM, i didn't changed nothing on it ^^

 

20 minutes ago, GamersRoost said:

Nailed it.

You rock, that will fix him. Sure of it.

I do not use Altis at all. I also never thought about opening the initserver.sqf. I was distracted (by my self)by all the posts about the databaseload. i.e. " exileServer_object_construction_database_load = "EBM\exileServer_object_construction_database_load.sqf"; //Original fix by Eichi

Well done man, I'm sure this will fix it!

Josh

I think its all false, right?
Look my initServer.sqf: https://pastebin.com/qKn4RzRy

 

Thank you!

Share this post


Link to post
Share on other sites
  • 0

I compared your file posted with the default ALTIS initserver.sqf.

I see no changes. Try to download another @ExileServer and copy over the Initserver.sqf replacing the one that exists.

I'm at a total loss.

Josh

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, lapulapu said:
Spoiler

Havent used Altis in awhile, but took a quick look in the default Exile.Altis.pbo

Check out the initServer.sqf

Looks like for all spawned objects enableSimulationGlobal is set to false.

eg:



["Land_CarService_F", [14618.7,16877.4,18.7724], [[0.750538,-0.660827,0],[0,0,1]], [false, false]],

That 1st false would need to be changed to true for any structures you would wants doors to work on.

So find the classnames of all the buildings you want to work in that file, and update that false to true.

Thank you @lapulapu, its close but...

Well, I replaced all [false, false] in initServer.sqf to  [true,false] but all structures are gone now =(

Do u knew a way to get only the door's id to test it?

No one have Altis Map and already fixed it?

I don't have infistar, so i can't find ids by it...

3 hours ago, GamersRoost said:

I compared your file posted with the default ALTIS initserver.sqf.

I see no changes. Try to download another @ExileServer and copy over the Initserver.sqf replacing the one that exists.

I'm at a total loss.

Josh

I downloaded again, but its the same file lol.
I changed all [false,false] to [true,false] but now all structures gone.
Do u knew a way to get only the door's id?

Thank you!!!!

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.