• 0
Convieo

Server Crashes

Question

This has been plaguing me and my server for some time now. I'm not sure what's causing it at all, although I'm most certainly not an expert.

The server seems to crash at completely random times, sometimes even going a couple of days without it. I had a friend check the minidump file (way beyond my understanding) and he said it was the physx.dll that was causing the issue, but I'm not so sure.

This is the information the RPT spat out before the server crashed, and seems to be the same every time. From what I can tell there's not a lot of information here.

Spoiler

Mods: @ExileServer;@a3_dms;@A3XAI;@Enigma;@infiSTAR_Exile;A3;curator;kart;heli;mark;expansion;dlcbundle;@Exile;@CBA_A3;@CUP_Units;@CUP_Vehicles;@CUP_Weapons;@Extended_Base_Mod
ServerMods: @infiSTAR_Exile;@Enigma;@A3XAI;@a3_dms;@ExileServer
Extensions:
  armalog (.\armalog.dll) [1.0.0.0] [1.0.0.0]
  extDB2 (C:\TCAFiles\Users\RobertL4\33146\@ExileServer\extDB2.dll) [70.0.0.0] [70.0.0.0]
Distribution: 0
Version 1.68.140908
Fault time: 2017/03/28 23:35:19
Fault address:  00CB5BE0 01:00A54BE0 C:\TCAFiles\Users\RobertL4\33146\arma3server.exe
file:     Exile (__cur_mp)
world:    Altis
Prev. code bytes: 8B 99 C4 00 00 00 8B 7C 24 14 8D 9B 00 00 00 00
Fault code bytes: 8B 03 33 C9 8B 90 A8 03 00 00 85 D2 7E 12 8B 80

Registers:
EAX:0246EA20 EBX:00000000
ECX:B5E1E1C0 EDX:00000005
ESI:00000000 EDI:7F5E9520
CS:EIP:0023:00CB5BE0
SS:ESP:002B:0246E9E0  EBP:014A6B8C
DS:002B  ES:002B  FS:0053  GS:002B
Flags:00210202
=======================================================
note: Minidump has been generated into the file A3DS\arma3server_2017-03-28_22-00-10.mdmp

I do have the minidump if anyone is interested.

Thanks in advance for any help given.

Share this post


Link to post
Share on other sites

10 answers to this question

Advertisement
  • 0

It's PvP but has PvE elements. The server forces all players to loose connection, and no one can connect again until the server is restarted.

If I stop answering at some point it may mean I've fallen asleep haha.

Share this post


Link to post
Share on other sites
  • 0

You could try and remove some of your custom Occupation missions and lower or remove your roaming AI. If the crashes stop than you can slowly add custom AI in again. The only thing I get from your RPT is a large amount of AI being called, custom missions spawns, and then the crash code (Exception code: C0000005 ACCESS_VIOLATION at 00CB5BE0).

Edited by Beowulfv

Share this post


Link to post
Share on other sites
  • 0

It's true there are a large amount of AI on the server. But I don't think many more than I've seen on a few other servers. I only use occupation for the gear crates, dms for missions and then a3xai for roaming ai. AI are frozen when no one is around and they are offloaded to clients when they are near. Still, I'll give it a shot over the next few days though, see if it helps.

Thanks!

Share this post


Link to post
Share on other sites
  • 0

Since the Arma update things have become unstable when running Exile. I've had to remove missions and other features from Servers that I work on to combat a never ending list of issues. Stability is the name of the game for now. It's only temporary. Every box is different, and so is every server. 

  • Like 1

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.