duda

Advanced Train Simulator (ATS)

24 posts in this topic

Lots of updates to ATS in the past two weeks! Try out the latest if you haven't already. You can find it on steam.

 Highlights:

 - Includes support for large gauge Arma 2 tracks

 - Added destruction effects for all trains (see below - we've added a new TNT car!)

 - Players will be killed if on board a train car that explodes

 

Share this post


Link to post
Share on other sites

Hi all and thx for the addon !

I just want to try to put some rails on a map but I don't know how to join them... Can I just draw a line on the map and set it to be rails?

Share this post


Link to post
Share on other sites
Advertisement

Great mod! works awesome! Just one issue that i found. Some trains explode on server load. When you get in and ATS is loaded it just spawns back as intact and works fine. Minor thing but bit annoying. Removed the one's that exploded on server load and its all good now.

Second thing, if someone uses a train and sets it to cruise control it will just keep going when they jump out. Now when that train reaches a station or other cart and cant go no further it will lag up the client and server FPS big time. (Went down to 15 FPS when within 1500m of the station the train crashed into).
It will just keep throtteling into the barrier/traincart and crash the whole lot. (No issues as soon as you move away tho).

Perhaps an option that disables the CC when no player is inside the locomotive? Or a disable CC when a certain type of track has been passed/station has been reached.

Share this post


Link to post
Share on other sites

EDIT: Nevermind, solved it. A rather dumb mistake by myself :@

I have a problem with riding the trains on my exile server. The trains are there and I even can take place as a driver. But I'm not able to drive it. Only the exit button (delete) works. So the only thing I can do is seat as driver and exit again. I noticed following errors in the rpt:
 

/10:32:07 "ExileServer - Network message dispatch failed: Forbidden message name! Payload: [""wnenkvpe"",""AdvancedTrainSimulatorRemoteExecServer"",[[488178: locomotive_01_v3_f.p3d,true,true],""ATRAIN_fnc_hideTrainObjectGlobal"",false]]"
10:32:07 "ExileServer - Network message dispatch failed: Forbidden message name! Payload: [""wnenkvpe"",""AdvancedTrainSimulatorRemoteExecServer"",[[<NULL-object>,R Alpha 1-2:1 (BuzZoiD) REMOTE],""ATRAIN_fnc_registerTrainAndDriver"",false]]"
10:32:07 "ExileServer - Network message dispatch failed: Forbidden message name! Payload: [""wnenkvpe"",""AdvancedTrainSimulatorRemoteExecServer"",[[R Alpha 1-2:1 (BuzZoiD) REMOTE,true],""ATRAIN_fnc_hidePlayerObjectGlobal"",false]]"


The mod is declared as -servermod (clients have it installed too for the sounds etc, as described on the workshop page) and I added following lines in the missions' description.ext:

class CfgRemoteExec
{
    class Functions
    {
        class ATRAIN_fnc_unregisterTrainAndDriver         { allowedTargets=2; }; 
        class ATRAIN_fnc_registerTrainAndDriver            { allowedTargets=2; }; 
        class ATRAIN_fnc_updateTrackMap                 { allowedTargets=2; }; 
        class ATRAIN_fnc_hideTrainObjectGlobal             { allowedTargets=2; }; 
        class ATRAIN_fnc_hidePlayerObjectGlobal         { allowedTargets=2; };
        class ATRAIN_fnc_requestATSInstall                 { allowedTargets=2; };
	 };


I would appreciate any feedback and thanks in advance! :)

Edited by BuzZoiD

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.