Question

Anyone use Xeno's Taru Pod mod?
I just downloaded it and installed it.
I now get the Attach Pod option when I have hooked or sling loaded a pod to a taru.
But the Attach Pod men option does nothing when I select it. Actually reads "Attach Pod (0)m".
Wondering if it has something to do with infiSTAR or with the Advanced Sling Loading and/or Advanced Towing mods I'm also running.

 

1 person likes this

Share this post


Link to post
Share on other sites

10 answers to this question

  • 0

Yep I have the same issue on our exile server, everything is there in the menu but nothing happens when selected, also running infistar and advanced sling loading, would love to get this working, as it would be a great replacement for the broken exile script

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

cba_a3 has taru pods, I was not aware of this until i was playing with eden editor yesterday, and chose to load objects from cba_a3, and low and behold, they showed up.

In infistar did you disable the options:

attach_to_check = "true";				/* logs and detaches attached vehicles that are close.. basically completely disallow attaching of vehicles! */
slingload_check = "true";				/* forbid sling loading / rope attaching a vehicle with a crew */

 

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement
  • 0
Quote

In infistar did you disable the options:

Yes that's already done in infistar as we need to do that for advanced sling loading and advanced towing.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

@wilderness I think you may have accidentally solved this. :D

Because also, for Advanced Towing and Advances Sling Loading,
we had to include these in infiSTAR:

Spoiler

KCM = "true";        /* Just close ALL CommandingMenus */
CMC = "false";        /* Check for CommandingMenus that are not in the allowedCommandingMenus array */
allowedCommandingMenus[] = {"#USER:ASL_Deploy_Ropes_Count_Menu","#USER:ASL_Show_Select_Ropes_Menu_Array"};

So, I wonder if there's something we need in here, for that to work. o.O

Share this post


Link to post
Share on other sites
  • 0
Quote

So, I wonder if there's something we need in here, for that to work

Well that's kind of what I was thinking but I have no idea what we need to put in there? :(

We basically need to find out what the commanding menus are for this mod :|

I'll have a poke around inside the mod to see what I can find, but not being a coder it going to be a bit hit and miss

well I found this in the SelfActions:

Quote

ace_xeno_taru_pod_mod_menu_molette

Which I think means = ace_xeno_taru_pod_mod_menu_Array 

(Actually just did a google translate, it's French and "molette" means "scrollwheel" so it means: "ace_xeno_taru_pod_mod_menu_scrollwheel")

so maybe:

Quote

"#USER:ace_xeno_taru_pod_mod_menu_molette"

in infistar, can someone verify that I'm barking up the right tree please, not going to get chance to test this until tomorrow as I'm nowhere near my test server at the moment.

Edited by wilderness

Share this post


Link to post
Share on other sites
  • 0

Ok I think we may need to add something to our "remoteExec" files as well because I found a reference to it inside the mod:

Quote

[_helico,_objet_Accrocher] remoteExec ["setslingload",_helico];
["Accrochage",_helico] remoteExec ["XENO_Taru_fnc_Transmission_Sons",0];

Ideas?

Possibly:

Quote

class XENO_Taru_fnc_Transmission_Sons        { allowedTargets=0; };

class XENO_Taru_fnc_Transmission_Messages        { allowedTargets=0; };

Really not sure about this, getting out of my comfort zone now :(

Some info on the remoteExec from bohemia: https://community.bistudio.com/wiki/Arma_3_Remote_Execution

Edited by wilderness

Share this post


Link to post
Share on other sites
  • 0

Funny, I was using Google Translate on this too. :D
Xeno posted in Workshop that he'll look into this (Exile fix)

 

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Ha ha google translate is our friend, I don't think this is an infistar issue though, I have a sneaky feeling it's a remoteExec issue, just a hunch, I may be wrong though.

Logic is telling me if it's infistar we would be seeing it in the infi logs?

Edited by wilderness

Share this post


Link to post
Share on other sites
  • 0

Here's what I got in the rpt, after rebooting server, and buying a taru transport, and a taru cargo pod.
Hooking the pod, and trying to attach it:

Spoiler

 2:40:30 Updating base class ->UserActions, by XENO_Taru_Pod_Mod\config.bin/CfgVehicles/Heli_Transport_04_base_F/UserActions/ (original a3\air_f_heli\heli_transport_04\config.bin)
 2:40:31 C:\TCAFiles\Users\RafaelM\599\@XENOpods\addons\xeno_taru_pod_mod.pbo - unknown
 2:40:31 C:\TCAFiles\Users\RafaelM\599\@XENOpods\addons\xeno_taru_pod_mod.pbo - unknown
 2:40:31                                XENO - Taru Pod Mod |            @XENOpods |      false |             GAME DIR | da39a3ee5e6b4b0d3255bfef95601890afd80709 |  11fdd19c | C:\TCAFiles\Users\RafaelM\599\@XENOpods
 2:40:31                                XENO - Taru Pod Mod |            @XENOpods |      false |             GAME DIR | da39a3ee5e6b4b0d3255bfef95601890afd80709 |  11fdd19c | C:\TCAFiles\Users\RafaelM\599\@XENOpods
 2:40:31                                XENO - Taru Pod Mod |            @XENOpods |      false |             GAME DIR | da39a3ee5e6b4b0d3255bfef95601890afd80709 |  11fdd19c | C:\TCAFiles\Users\RafaelM\599\@XENOpods
 2:40:48 "TCAGame/BIS_fnc_log: [postInit] XENO_Taru_fnc_Configuration_Raccourcis_CBA (0 ms)"
 2:48:52 Scripting function 'xeno_taru_fnc_action_arrimage' is not allowed to be remotely executed
 2:49:01 Scripting function 'xeno_taru_fnc_action_arrimage' is not allowed to be remotely executed

I wonder if we have to make a change to the infiSTAR CfgRemoteExec.hpp

Edited by 5niper

Share this post


Link to post
Share on other sites
  • 0

Over a year ago now, the last post here, but I'm wondering if anyone got this working? I have exactly this issue, it shows up, but nothing happens.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.