• 1
Sign in to follow this  
__Nairic~.

Can't open base doors after restart

Question

Hi,

Since installation, we all have the same problem : after restart we can't open our base doors, they don't have code lock at all.

To enter base we must move the door wall, and after it can be opened and close...

I have installed statusbar, advanced towing and dms. But without these mods, the issue is the same

Can you help me?

Share this post


Link to post
Share on other sites

22 answers to this question

  • 2

Use this workaround until we release a patch that fixes the cause of this issue.

Overwrite function ExileServer_object_construction_database_load with this:

/**
 * ExileServer_object_construction_database_load
 *
 * Exile Mod
 * www.exilemod.com
 * © 2015 Exile Mod Team
 *
 * This work is licensed under the Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License. 
 * To view a copy of this license, visit http://creativecommons.org/licenses/by-nc-nd/4.0/.
 */
 
private["_constructionID","_data","_position","_vectorDirection","_vectorUp","_constructionObject","_damageLevel","_public","_pinCode"];
_constructionID = _this;
_data = format ["loadConstruction:%1", _constructionID] call ExileServer_system_database_query_selectSingle;
_position = [_data select 4, _data select 5, _data select 6];
_vectorDirection = [_data select 7, _data select 8, _data select 9];
_vectorUp = [_data select 10, _data select 11, _data select 12];
_constructionObject = createVehicle [(_data select 1), _position, [], 0, "CAN_COLLIDE"];
_constructionObject setPosATL _position;
_constructionObject setVectorDirAndUp [_vectorDirection, _vectorUp];
_constructionObject setVariable ["ExileDatabaseID", _data select 0];
_constructionObject setVariable ["ExileOwnerUID", (_data select 2)];
_constructionObject setVariable ["ExileIsPersistent", true];
_constructionObject setVariable ["ExileTerritoryID", (_data select 15)];
_damageLevel = (_data select 17);
_public = _damageLevel > 0;
_constructionObject setVariable ["ExileConstructionDamage",_damageLevel,_public];
if(_public)then
{
	_constructionObject call ExileServer_util_setDamageTexture;
};
_pinCode = _data select 14;
if !(_pinCode isEqualTo "000000") then
{
	_constructionObject setVariable ["ExileAccessCode", _pinCode];
	_constructionObject setVariable ["ExileIsLocked", (_data select 13), true];
};

// 2017-03-16 + TEMPORARY WORKAROUND UNTIL EXILE UPDATE
//if (getNumber(configFile >> "CfgVehicles" >> (_data select 1) >> "exileRequiresSimulation") isEqualTo 1) then
//{
//	_constructionObject enableSimulationGlobal true;
//	_constructionObject call ExileServer_system_simulationMonitor_addVehicle;
//}
//else 
//{
//	_constructionObject enableSimulationGlobal false;
//};

if (typeOf _constructionObject in ["Exile_Construction_ConcreteDoor_Static", "Exile_Construction_ConcreteGate_Static", "Exile_Construction_WoodGate_Static", "Exile_Construction_WoodDoor_Static", "Exile_Construction_ConcreteWindowHatch_Static", "Exile_Construction_WoodGate_Reinforced_Static", "Exile_Construction_WoodDoor_Reinforced_Static", "Exile_Construction_ConcreteFloorHatch_Static"]) then
{
    _constructionObject enableSimulationGlobal true;
    _constructionObject call ExileServer_system_simulationMonitor_addVehicle;
}
else 
{
	_constructionObject enableSimulationGlobal false;
};
// 2017-03-16 - TEMPORARY WORKAROUND UNTIL EXILE UPDATE

_constructionObject setVelocity [0, 0, 0];
_constructionObject setPosATL _position;
_constructionObject setVelocity [0, 0, 0];
_constructionObject setVectorDirAndUp [_vectorDirection, _vectorUp];
_constructionObject setVelocity [0, 0, 0];
_constructionObject

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 1
9 hours ago, cybermiliko said:

where i find it? o located?

1- Create a new folder: Overrides inside your mpmission mission folder.
Inside this folder, create the file: ExileServer_object_construction_database_load.sqf
Paste the code above:

Save it.
Open the file config.ccp  inside your mpmission folder.
Find: class CfgExileCustomCode and paste below it:

ExileServer_object_construction_database_load = Overrides\ExileServer_object_construction_database_load.sqf


Repack pbo, save and done.
 

Share this post


Link to post
Share on other sites
Advertisement
  • 0
24 minutes ago, Beowulfv said:

Your answer can be found here

 

Thanks, but i don't find the right answer... i'm noob and not a great english spoken men... sorry ;-)

Share this post


Link to post
Share on other sites
  • 0

After Attempting this fix, my server just loads and once it does the "kicks" instead of "Ready" it just keeps restarting over and over

 

EDIT**Fixed. Just made an SQF but didnt put it in a new folder called Overrides

 

Edited by MickScandalous

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.