• 0
blk_zoms_matr

_vehicleObject Errors

Question

_vehicleObject = [_className, _position, _direction, _useP>
15:58:26   Error position: <_className, _position, _direction, _useP>
15:58:26   Error Undefined variable in expression: _classname
15:58:26 File exile_server\code\ExileServer_object_vehicle_createNonPersistentVehicle.sqf, line 17
15:58:26 Error in expression <ount _vehicleClassNames)));
_vehicle = [_vehicleClassName, _positionReal, random>
15:58:26   Error position: <_vehicleClassName, _positionReal, random>
15:58:26   Error Undefined variable in expression: _vehicleclassname
15:58:26 File exile_server\code\ExileServer_world_spawnVehicles.sqf, line 41
15:58:27 Error in expression <000)
];
_vehicleObject = createVehicle [_vehicleClassName, _temporaryPositionInO>
15:58:27   Error position: <_vehicleClassName, _temporaryPositionInO>
15:58:27   Error Undefined variable in expression: _vehicleclassname
15:58:27 File exile_server\code\ExileServer_object_vehicle_carefulCreateVehicle.sqf, line 23
15:58:27 Error in expression <ATL = _this select 3;
_vehicleObject = [_className, _position, _direction, _useP>
15:58:27   Error position: <_className, _position, _direction, _useP>
15:58:27   Error Undefined variable in expression: _classname
15:58:27 File exile_server\code\ExileServer_object_vehicle_createNonPersistentVehicle.sqf, line 17
15:58:27 Error in expression <ount _vehicleClassNames)));
_vehicle = [_vehicleClassName, _positionReal, random>
15:58:27   Error position: <_vehicleClassName, _positionReal, random>
15:58:27   Error Undefined variable in expression: _vehicleclassname
15:58:27 File exile_server\code\ExileServer_world_spawnVehicles.sqf, line 41
15:58:27 Error in expression <000)

Not sure when this started happening but, I'm getting tired of having to spawn my own vehicles in. I was using AVS however I have since removed it and uninstalled its database .ini 

Unfortunately I cant remember when I started noticing these errors.

The vehicles that do spawn around the map:

1. Spawn a few feet off the ground

2. Takes almost 45 seconds to enter vehivle after selecting to get in

3. Sometimes players are kicked out of the vehicle after entry and vehicle explodes

4. Sometimes vehicle explodes on its own when player is within the vicinity of it

 

I have not tried to edit any @Exile files however just in case the .sqf's referenced in the log above were corrupt I removed them and replaced with new. -no change

Vehicles that I manually spawn in are fine and players can get in, drive them, claim them.. This only occurs to vehicles spawned in by the server.

I'm not sure but the symptoms with the vehicles and this error look closely related. Hoping maybe someone can help me clear this up. 

Thanks

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

I have this problem as well. I have had a high chance of helicopters exploding upon landing lightly on the ground or simply on take off. I have also had mission vehicles explode instantly if I slighly tap them with a vehicle I plan to tow with. At first I just chalked it up to arma but then began to see more highly random explosions even when players would walk close to vehicles.

 

I just wanted to provide my experience and bump this post. Thanks for any future advice. 

Share this post


Link to post
Share on other sites
  • 0

Did you guys find a solution to this?  I've been having similar issues with simulation not kicking in, getting stuck, etc.   I was having a ton of erratic errors and started culling the database of certain vehicle classes to see it it was a problem with certain vics.  After removing persistent bicycles (really) the errors cleaned up significantly.  Now they're consistent.

I get 60+ instances of this:

Spoiler

20:16:14 Error in expression <000)
];
_vehicleObject = createVehicle [_vehicleClassName, _temporaryPositionInO>
20:16:14   Error position: <_vehicleClassName, _temporaryPositionInO>
20:16:14   Error Undefined variable in expression: _vehicleclassname
20:16:14 File exile_server\code\ExileServer_object_vehicle_carefulCreateVehicle.sqf, line 23
20:16:14 Error in expression <ATL = _this select 3;
_vehicleObject = [_className, _position, _direction, _useP>
20:16:14   Error position: <_className, _position, _direction, _useP>
20:16:14   Error Undefined variable in expression: _classname
20:16:14 File exile_server\code\ExileServer_object_vehicle_createNonPersistentVehicle.sqf, line 17
20:16:14 Error in expression <tRandom _vehicleClassNames;
_vehicle = [_vehicleClassName, _positionReal, random>
20:16:14   Error position: <_vehicleClassName, _positionReal, random>
20:16:14   Error Undefined variable in expression: _vehicleclassname
20:16:14 File exile_server\code\ExileServer_world_spawnVehicles.sqf, line 45

 

Driving me crazy

1 person likes this

Share this post


Link to post
Share on other sites
Advertisement
  • 0
On 03.07.2017 at 9:32 AM, TroyT said:

Did you guys find a solution to this?  I've been having similar issues with simulation not kicking in, getting stuck, etc.   I was having a ton of erratic errors and started culling the database of certain vehicle classes to see it it was a problem with certain vics.  After removing persistent bicycles (really) the errors cleaned up significantly.  Now they're consistent.

I get 60+ instances of this:

  Hide contents

20:16:14 Error in expression <000)
];
_vehicleObject = createVehicle [_vehicleClassName, _temporaryPositionInO>
20:16:14   Error position: <_vehicleClassName, _temporaryPositionInO>
20:16:14   Error Undefined variable in expression: _vehicleclassname
20:16:14 File exile_server\code\ExileServer_object_vehicle_carefulCreateVehicle.sqf, line 23
20:16:14 Error in expression <ATL = _this select 3;
_vehicleObject = [_className, _position, _direction, _useP>
20:16:14   Error position: <_className, _position, _direction, _useP>
20:16:14   Error Undefined variable in expression: _classname
20:16:14 File exile_server\code\ExileServer_object_vehicle_createNonPersistentVehicle.sqf, line 17
20:16:14 Error in expression <tRandom _vehicleClassNames;
_vehicle = [_vehicleClassName, _positionReal, random>
20:16:14   Error position: <_vehicleClassName, _positionReal, random>
20:16:14   Error Undefined variable in expression: _vehicleclassname
20:16:14 File exile_server\code\ExileServer_world_spawnVehicles.sqf, line 45

 

Driving me crazy

Hi, how you remove persistent bicycles? From where

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.