• 0
DavieReid88

How to update server

Question

This isnt a bug related to 1.70 update so i thought id post this separate, this may sound stupid to some but how do i update my server to the new arma update? I tried this with the branch code 141764

  Hide contents

@echo off
@rem http://media.steampowered.com/installer/steamcmd.zip
SETLOCAL ENABLEDELAYEDEXPANSION

       :: DEFINE the following variables where applicable to your install

    SET STEAMLOGIN=***********
    SET A3serverBRANCH=141764 -beta
        :: For stable use 233780 -beta
        :: For Dev use 233780 -beta development
                :: Note, the missing qotation marks, these need to be wrapped around the entire "+app_data......"
                :: There is no DEV branch data yet for Arma 3 Dedicated Server package !!!

    SET A3serverPath=C:\destination
        SET STEAMPATH=C:\destination


:: _________________________________________________________

echo.
echo     You are about to update ArmA 3 server
echo        Dir: %A3serverPath%
echo        Branch: %A3serverBRANCH%
echo.
echo     Key "ENTER" to proceed
pause
%STEAMPATH%\steamcmd.exe +login %STEAMLOGIN% +force_install_dir %A3serverPath% +"app_update %A3serverBRANCH%" validate +quit
echo .
echo     Your ArmA 3 server is now up to date
echo     key "ENTER" to exit
pause

I thought thats how you updated? Nothing happens so i tried to install a new version using that .bat  file and i get a error saying failed to install app (no subscription)

Thanks

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

For me This:
 

./steamcmd.exe +login "${steamuser}" "${steampass}" +force_install_dir "/Your/Serverfolder/" +app_update "233780"

 

Share this post


Link to post
Share on other sites
  • 0
26 minutes ago, HellBz said:

For me This:
 


./steamcmd.exe +login "${steamuser}" "${steampass}" +force_install_dir "/Your/Serverfolder/" +app_update "233780"

 

i set this is a .bat file when i double click nothing happens?

Share this post


Link to post
Share on other sites
Advertisement
  • 0
4 minutes ago, DavieReid88 said:

@kuplion I got it working I moved my steamcmd folder from the desktop and forgot to change the path to where it is..silly!

Glad it's sorted. Sometimes all it takes is a bit of time to figure out how we confused ourselves, eh? xD

  • Like 1

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.