• 0
fifthmanstanding

Issue with editor placed jets/heli's and players getting trapped

Question

Here's a new one for me: placing a vehicle as simulation disabled and/or as a simple object (using the checkbox in the attributes menu, not using the 3den soup can method) and set to "lock" as the lock state seems to allow the player to enter the vehicle but not exit. 

To clarify: I've placed 4 ghost hawk heli's on the top of my aircraft carrier. They were set to locked, no ammo, no fuel, and set as simple objects. The code was copied using the 3den mod export function initserver.sqf from the menu and placed into an a3_custom pbo that is called from @Exileserver\addons. 

Result: The player can walk up to them and see that "rotate left" and "rotate right" are present in the contextual menu. Once rotated, the option to get in as copilot or pilot is now present in the contextual menu. Once you enter the heli you cannot exit and must be force ejected through the infistar menu. I initially made them simple objects (through the attributes menu) and when that didn't alleviate the problem I changed them to empty objects with simulation disabled and it still happens. 

I have a similar issue with the 3 wasp jets that I've placed on the same carrier. Rotate option is also available but you can simply walk to them, select "get in wasp as pilot" (or whatever the menu text is) and it begins the getting in animation, pauses at the point when the model is about to sit down and then will not allow you to get out. Infistar's eject option is necessary to return the player to the ground. I tried the same simple object/non-simple object but with simulation disabled and it persists. 

Is there any way to fix this? Is there any way to remove "rotate left" and "rotate right" from the context menu also?

Thanks in advanced for any insight. 

 

  • Like 1

Share this post


Link to post
Share on other sites

10 answers to this question

  • 1

There's no need to both add it in the editor AND the mission.sqm file. The editor allows you to graphically edit the mission.sqm file. Anything added with the editor is reflected in the code of the mission.sqm. 

Unless, and you may have done this, you built this jet and other items in the editor in a separate mission file. The easiest way is to just unpack your server mission .pbo , add it to the mpmission folder that the editor reads from, open the mission file in the editor and add your jets and other items that way. Doing so will add them to the code of the mission on its own. 

  • Like 2

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Hello,

Find the section of the script that handles the menu action (rotate left/right).  At the top of this script, if this vehicle is a jet, go to exit.  Problem will be if you add these vehicles in as usable objects.  BUT, if they will ALWAYS be static, this is a simple and 'quick fix' for this.

:)

 

Share this post


Link to post
Share on other sites
  • 0

i have some jets/cars etc as decoration on my map aaaaaaand it works when i leave the jets/cars etc. as simple object + not useable on my map. DONT export them within the initServer.sqf. Leave them inside the mission.sqf and all should work as expected :)

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, towatai said:

i have some jets/cars etc as decoration on my map aaaaaaand it works when i leave the jets/cars etc. as simple object + not useable on my map. DONT export them within the initServer.sqf. Leave them inside the mission.sqf and all should work as expected :)

yeah it looks like calling them in the through initserver was the culprit. Thanks.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

You can add items via the editor and then save the file and that will add it to the mission .sqm file or you can unbinarize the mission.sqm through the editor save as function and then manually edit the mission.sqm file's code yourself. But the latter is kind of more of a pain in the ass unless you know the exact coords, rotation etc of the piece(s) you're placing. \

Just make sure you're removing the duplicate items from the  initserver file so it's not placing two items on top of each other. 

Edited by fifthmanstanding

Share this post


Link to post
Share on other sites
  • 0

Okay I´ve placed a Jet in Editor, locked the Jet and saved the Mission as unbinarized. Now I have this File:

Desktop 05.31.2017 - 17.51.55.03.pngDesktop 05.31.2017 - 17.52.04.04.png

 

I have copied this whole Lines and add it to my Exile.Altis\mission.sqf, but there is no Jet on this Coordination where I placed it ?

Edited by Admiral EliteSuicide

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.