Ghostrider-DBD

Class Extraction Tool Updated v0.42

12 posts in this topic

On 9/9/2018 at 1:04 PM, Bob_the_K said:

So I must be missing something obvious.... 

1. I edited description.ext and uncommented the Exile line and commented out the Epoch line

2. I edited init.sqf.  I'm extracting from the WW2_Objects mod and so used the three characters WW2 

3. I put mymission config.cpp in the ...\documents\...\missions folder (not the mpmissions folder)

4. I started A3 and the editor.   Although I'm doing this for the Chernarus 2035 map, I selected Altis as the editor map since its an Altis-based mission file

5. Everything starts fine.  I go to the map - but no blue box on the map!  So I added a character and then went to "play as character".  But nothing comes up with the scroll wheel to export anything.

Since I'm using the Cheranrus 2035 map, I also tried it selecting that map in the editor.  Still no luck.  What did I miss or do wrong?

#3 in your above notes. You need to copy the entire testConfig.Altis folder, not just the config. This tool requires a lot of scripts to function, and copying only the config will do nothing.

You shouldn't need to do all that about moving the camera to the blue box, etc. Just click the play/preview button on the bottom-right. You'll load in as a character standing on the runway of the main airport, and you'll have several options on the scroll wheel. Choose the option for the classnames you want to extract, wait until the message says it has completed, then tab out and paste into a text file.

As you have noticed, this is an Altis mission file, so you need to load the editor with the Altis map. You don't do ANYTHING else. Don't move the camera, don't click on shit, etc. Load the mission, click on play/preview, and access your character's scroll menu for the type of classnames you need.

Share this post


Link to post
Share on other sites

I am seeing some problems with this tool not extracting all items. My latest attempt to extract the weapons from NIA is only extracting 2 optics, no suppressors, etc. It looks like most of the weapons are extracting, but almost none of the attachments. All items from this mod share the "hlc" prefix, and those items are visible in the virtual arsenal. Any ideas?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.