• 0
Sign in to follow this  
Nekuan

Everything called from init.sqf is displayed twice

Question

At least I think it is (it's weird).

Currently I'm calling 4 scripts from my init.sqf:

- Briefing

- R3F

- Enigma Revive

- acidy Tanoa Bridges (those seem to be fine)

The issue is that upon the first login the Entries in my Briefing.sqf are being shown twice, the R3f Scrolloptions are displayed twice and the "Loading: Enigma Exile" message is displayed twice. 

After a relog all of them behave normal again. 

I'm at a complete loss as to why this happens so any help is much appreciated 

Edited by Nekuan

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

@Nekuan the Init.sqf is called by the server and by clients. if you want something server-side only, then you would put it in the initServer, or in a custom server-side pbo. if you want something client only then put it in the initPlayerLocal.

inside of the initPlayerLocal is there a line that says:

#include "initServer.sqf"

because iirc, in default exile there is a commented #include "initServer.sqf" i'm not sure if you uncommented it, but it would be good to make sure that it's not in there, or uncommented. 

Edited by StokesMagee

Share this post


Link to post
Share on other sites
  • 0

@StokesMagee  No I don't have a line like that in my initPlayerLocal.sqf at all.

I just don't understand how I seem to be the only one having this issues as the mod authors clearly state to place the calls inside the init.sqf and I can't move them to initPlayerLocal.sqf. without breaking the mods (at least not R3F and Enigma Revive)

Edited by Nekuan

Share this post


Link to post
Share on other sites
Advertisement
  • 0
1 hour ago, Nekuan said:

@StokesMagee  No I don't have a line like that in my initPlayerLocal.sqf at all.

I just don't understand how I seem to be the only one having this issues as the mod authors clearly state to place the calls inside the init.sqf and I can't move them to initPlayerLocal.sqf. without breaking the mods (at least not R3F and Enigma Revive)

Yeah, just because the mod says it should be in the init.sqf does  not mean that it should be there. 

Have you added those things to your initPlayerLocal aswell?

Share this post


Link to post
Share on other sites
  • 0
18 hours ago, StokesMagee said:

Yeah, just because the mod says it should be in the init.sqf does  not mean that it should be there. 

Have you added those things to your initPlayerLocal aswell?

As well? As in having them in both at the same time? No. They are exclusively in the init.sqf except for when I tested them in initPlayerLocal and removed them from init.sqf

Edit: Fixed it.. Moved the calls from init.sqf to both initPlayerLocal.sqf and initServer.sqf instead of just init.sqf

I don't know why this works but it does so thanks for pointing me towards this

Edited by Nekuan

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.