No loot spawning due to missing object ids?

7 posts in this topic

Hi. First off I apologize for the question, I know the whole "no loot spawn" thing is a noob question. I've been trying for the last few days to get it working though and I don't know what to do anymore.

So I'm trying to set up exile on xCam_Taunus. Everything works fine apart from the loot. There is none whatsoever, not even in standard A3 buildings. Yes, I have the loot positions for the buildings on Taunus and yeah, they are included in the config. I've tracked this error back to the actual loot spawner in Exile where I've put in some debug messages.

Turns out on this part:


_sessionID = _this select 0;
_parameters = _this select 1;
_buildingNetIDs = _parameters select 0;
	_building = objectFromNetId _x;
		if (isNull _building) throw false;
		if (isObjectHidden _building) throw false;
		if !(isClass(configFile >> "CfgBuildings" >> typeOf _building)) throw false;
		if (_building getVariable ["ExileHasLoot", false]) throw false;
		_building call ExileServer_system_lootManager_spawnLootInBuilding;
forEach _buildingNetIDs;

(found in exile_server/code/ExileServer_system_lootManager_network_spawnLootRequest.sqf)

the netIDs from the buildings get converted to object ids and then compared against CfgBuildings. Problem is that my NetIDs are just fine but when the server tries to convert them to objectIDs, they become null.

Here's a list of things I tried so far:

  • Using different versions of CUP Terrains Core & Maps
  • Different load orders of mods on the server
  • removing everything apart from the map, its dependencies and exile
  • using different loot tables
  • Increasing loot spawns, just for the hell of it (and yes, I've waited around for almost 30 minutes, no change)
  • respawning, restarting, reinstalling everything
  • checking that exile and everything else is up to date
  • using a config from someone who says it works for him


My startup parameters are as follows:

./arma3server -config=@ExileServer/config.cfg -mod=@CUPTerrainsCore\;@CUPTerrainsMaps\;@xCam_Taunus\;@ryanzombies\;@Exile\;@ExileServer\;


Server log can be found here: Note that everything starting in "LOOT DEBUG:" is just the debug messages I've implemented to find the error.
//Oh and I get a lot of this:
18:01:45 Link cannot be resolved
18:01:45 In last 3000 miliseconds was lost another 13 these messages.
My google search says that's a harmless message, then again it's A LOT of harmless messages. Maybe it'll help someone make sense of this.


Any help would be much appreciated. Thanks in advance.


//Oh and also, if I may highjack my own thread here, my debug console won't show up for some reason even if I have the setting for it set to 1, any ideas?

Edited by Shelby

Share this post

Link to post
Share on other sites
9 hours ago, Agony said:

Ever resolve this?

Dude, this post is almost a year old :D

No, I never found a fix for this sadly and, believe it or not, the problem still persists. Sorry.

Edited by Shelby

Share this post

Link to post
Share on other sites
2 hours ago, MetalHead said:

You have @ExileServer in -mod and -servermod and what's the deal with all the backslashes in the startup parameters ?

Thanks for your help. I put ExileServer both in the server mod and mod lines because I was testing pretty much everything I could think of. I tried them both seperately as well. As for the backslashes: A semicolon denotes an "End of Line" on Linux based systems, which is why you need the backslashes to escape them. 

Edited by Shelby

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.