• 0
4amMadman

Issues switching from Tanoa to Cherno

Question

Hi. I currently have a Tanoa Exile server. I want to make this into a cherno server. 

I have a test server that I am running to do this. 

I obtained the mission file from here:

I added exile.chernarus (located in the linked post at Exile-Chernarus-master.zip\Exile-Chernarus-master\CUP\)  to the mpmission folder on the test server. 

I've added @CUP_Terrains and @CUP_Core at root of the server. Here is the rpt:

https://pastebin.com/BVw3MZ8y

By the looks of it, it's reading both mods fine I think?

Spoiler

 hashShort = '5645c9f2'
13:59:32   name |                                                         modDir |    default |               origin |      hash | hashShort | fullPath
13:59:32 ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
13:59:32   Ryan's Zombies & Demons |           @analzombs |      false |             GAME DIR | a8e40ba92bbdc0eed3beaad1536a841396a2083d |  62057cac | C:\Games\ArmA3\Exile\arma3test\arma3a3master\@analzombs
13:59:32   Extended Base Mod |   @Extended_Base_Mod |      false |             GAME DIR | 7322eb99438b74010459c40f2f8c01aefef5a54a |  78fb4d5a | C:\Games\ArmA3\Exile\arma3test\arma3a3master\@Extended_Base_Mod
13:59:32  CUP Terrains - Core 1.3.0 |            @CUP_Core |      false |             GAME DIR | ca3d60bae5866bda3a7a96855e78e75596958ec2 |  b16873f1 | C:\Games\ArmA3\Exile\arma3test\arma3a3master\@CUP_Core
13:59:32   CUP Terrains - Maps 1.3.0 |        @CUP_Terrains |      false |             GAME DIR | 86e1917c44863c25b6c5209aa489989bb47f3bcf |  917b8b3a | C:\Games\ArmA3\Exile\arma3test\arma3a3master\@CUP_Terrains

After this I modified the config located at @ExileServer\config.cfg to this:

Spoiler

hostname                            = "exilemod.com (1.0.3|1.70)";
password                             = "";
passwordAdmin                          = "";
serverCommandPassword                = "";
logFile                                = "server.log";
verifySignatures                       = 1; // Do NOT use verifySignatures=2! It costs too many FPS
BattlEye                            = 1;
requiredBuild                         = 141764; // 1.70 stable
allowedLoadFileExtensions[]         = {:};
allowedPreprocessFileExtensions[]     = {"sqf"};
allowedHTMLLoadExtensions[]         = {"html"};
motdInterval                         = 5;               
maxPlayers                             = 100;        
voteMissionPlayers                     = 200;   
voteThreshold                         = 200;
allowedVoteCmds[]                     = {};
allowedVotedAdminCmds[]                = {};
disableVoN                            = 0;        
vonCodecQuality                     = 30;   
persistent                            = 1;       
kickDuplicate                         = 1;
equalModRequired                     = 0;
kickClientsOnSlowNetwork            = 0;
timeStampFormat                     = "short";
onUserConnected                     = "";
onUserDisconnected                     = "";
doubleIdDetected                     = "";
onUnsignedData                         = "kick (_this select 0)";    
onHackedData                         = "kick (_this select 0)";
onDifferentData                     = "kick (_this select 0)";
motd[]                                 = {"Welcome to Arma 3 Exile Mod!", "www.exilemod.com", "Enjoy your stay!" };

class Missions
{
    class Exile
    {
        template = Exile.Chernarus;  // Exile.Namalsk, Exile.Altis

        // do NOT use custom difficulties!
        // Use either ExileRegular or ExileHardcore
        // or you will break Exile!
        difficulty = "ExileRegular";
    }; 
};

^ where it clearly says:

 class Exile
    {
        template = Exile.Chernarus;  // Exile.Namalsk, Exile.Altis

I then overwrote the exile_server_config.pbo located at @ExileServer/addons/exile_server_config.pbo with the .pbo that was located inside of Kuplion's master zip file that I dowloaded from the afformentioned link above. 

So I would assume, at this point, that the config is pointing Class Exile to the exile.chernarus pbo in the mp mission file and then it would boot the cherno pbo and bam, map change right?

When I start the server this is what I see:

 

Untitled.png

And I can load into game just fine....but it loads tanoa. No doubt about it. 

So what am I missing? Clearly I've screwed up somewhere. 

Thanks in advance for any help and insight. 

Edited by 4amMadman

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

Update: Figured it out. Apparently the test server was running TADST which was installed by our network guy. Tadst runs it's own TADST_config.cfg which seems to overwrite @ExileServer\config.cfg. 

Share this post


Link to post
Share on other sites
  • 1

TADST is a cancer and needs to be removed. It was only developed for people who wanted to host quick easy missions. Back in the old days when Arma 3 still used Gamespy. You're better off creating a .bat file to launch your server. You'll have more control and an easier time configuring your server.

  • Like 1

Share this post


Link to post
Share on other sites
Advertisement
  • 0

Anyone?

Things I've tried:

  • Changing the startup param to : -mod=@Exile;@CUP_Terrains_Core;@CUP_Terrains_Maps;@zombies" -autoInit "-servermod=@ExileServer;@infiSTAR_Exile"  and having the CUP folders named the same as they are in the the parameters line. Core is in the order before Maps as I understand it should be. 
  • Ensuring @ExileServer\config.cfg specifies "Exile.Chernarus" in the "Class Exile template =" segment. 
  • Originally the CUP folders were downloaded using steamcmd. I deleted the folders and downloaded them directly from CUP's website and then uploaded them from my local machine to the test server.
  • Changing the mission.sqm arrays to the following:
Spoiler

version=12;
class Mission
{
    addOns[]=
    {
        "exile_client",
        "CUP_Core",
        "CUP_Chernarus_Config",
    };
    addOnsAuto[]=
    {
        "exile_client",
        "CUP_Core",
        "CUP_Chernarus_Config",
    };

 

At this point I'm at a loss. I've ran extensive searches on google and this forum regarding CUP terrains, chernarus etc and have gotten nowhere. It still loads Tanoa as though it's not recognizing any changes I've made. I dunno if it's because it's a test server and there's something screwy with how its setup. I'm just generally at a loss. 

Untitled.png

Edited by 4amMadman

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Beowulfv said:

Go into your mission folder, look for a file called $PREFIX$ and edit it.

prefix in the cherno mission pbo contains "Exile.Chernarus" and nothing else. Not sure what it should be edited to. 

I made another hail mary and deleted the tanao pbo to see what would happen. The cherno pbo is there. The startup params are unchanged from my last post. the exileserver\config.cfg still reads as it does in my last post. 

I started the server up and the rpt displays the following line at the bottom:

ErrorMessage: Include file mpmissions\Exile.Tanoa\CfgRemoteExec.hpp not found.

So somewhere, somehow, it's always looking for the tanoa pbo. 

Edited by 4amMadman

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Beowulfv said:

TADST is a cancer and needs to be removed. It was only developed for people who wanted to host quick easy missions. Back in the old days when Arma 3 still used Gamespy. You're better off creating a .bat file to launch your server. You'll have more control and an easier time configuring your server.

Yeah I talked to the guys and it looks like it was a hold over from earlier in the server's history. The test server was just a copy of the live server and that was sitting there. They opted for Arma Remote Admin shortly after I joined the team. Hence why I was so confused about why config.cfg wasn't doing its job. 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.