• 0
Blake2394

Contaminated Zones

Question

Hi,

I am having a issue with contaminated zones. The first position in the code below works but the second one dose not. I must be missing something here lol.

class Radiation 
{
// 1 = enabled, 0 = disabled
enable = 1;

/*
Defines contaminated zones in a specific map. 
You can define multiple zones per map. The format
of the zones is:

[Position ASL(!), Full Radiation Radius, Maximum Radius]

The radius works as follows:

|-------------------------------------------------------|
Maximum Radius

|------------------------|
Full Radiation Radius   

Within the full radiation radius, radiation factor is
always at a maximum. Outside of this, it lowers down
to no radiation smoothly.

Radiation:

|------------------------|------------------------------|
1        1      1        1     0.75    0.5     0.25    0
*/
contaminatedZones[] =
{
{{2383.58,0.00152588,14375.3},150,250},
{{7259.98,0.00135422,3017},150,250}
};
};

I am not sure if its because i used { and not [ ?

Thanks in advance!

Share this post


Link to post
Share on other sites

5 answers to this question

  • 0

Use the enable switch in that file as you have already done but, the coords and size of the zone moved to mission.sqm a few versions back. 

Look in your mission.sqm and use the existing, working zone as a template to add another zone. 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, BaroN said:

Use the enable switch in that file as you have already done but, the coords and size of the zone moved to mission.sqm a few versions back. 

Look in your mission.sqm and use the existing, working zone as a template to add another zone. 

So like this? Because this was already in there. Do I need to delete the pos from the config.cpp?

		class Item24
		{
			position[] = {2383.57, 0, 14375.3};
			name = "ExileMarker25";
			text = "Contaminated Zone";
			markerType = "ELLIPSE";
			type = "ExileContaminatedZone";
			colorName = "ColorBlack";
			fillName = "Border";
			a = 500;
			b = 500;
			drawBorder = 1;
		};
		class Item25
		{
			position[] = {2383.57, 0, 14375.3};
			name = "ExileMarker26";
			text = "";
			type = "ExileContaminatedZoneIcon";
		};
		class Item26
		{
			position[] = {7260.04, 0, 3017.12};
			name = "ExileMarker27";
			text = "Contaminated Zone";
			markerType = "ELLIPSE";
			type = "ExileContaminatedZone";
			colorName = "ColorBlack";
			fillName = "Border";
			a = 500;
			b = 500;
			drawBorder = 1;
		};
		class Item27
		{
			position[] = {7260.04, 0, 3017.12};
			name = "ExileMarker28";
			text = "";
			type = "ExileContaminatedZoneIcon";
		};

 

Share this post


Link to post
Share on other sites
Advertisement
  • 0

those should work. make sure to keep tabs of the total number of items at the top and increase/decrease the number as necessary and taking into account that the first item is Item0.

Also is that 

class Radiation 

the correct one for whichever map you're using. The next time up from the code block you posted should tell you the case.

Share this post


Link to post
Share on other sites
  • 0
13 minutes ago, BaroN said:

those should work. make sure to keep tabs of the total number of items at the top and increase/decrease the number as necessary and taking into account that the first item is Item0.

Also is that 


class Radiation 

the correct one for whichever map you're using. The next time up from the code block you posted should tell you the case.

Hi,

That is located in the

class Markers

I do not have a

class Radiation

in the mission.sqm I think that's why it is not working.

Share this post


Link to post
Share on other sites
  • 0

sorry for late reply. no my question was back in your config.cpp.... make sure you have a case for the map you are using and that you have 

class Radiation 
{
// 1 = enabled, 0 = disabled
enable = 1;

set like that for the map you are using. For instance, here's mine for Malden:

	class Malden: Altis
	{
		class FireFlies: FireFlies
		{
			enable = 1;
		};

		class Anomalies: Anomalies
		{
			enable = 0;
		};

		class Breathing: Breathing
		{
			enable = 0;
		};

		class Snow: Snow
		{
			enable = 0;
		};

		class Radiation: Radiation
		{
			enable = 1;
		};

		class Temperature: Temperature
		{
			daytimeTemperature[] = {15.93,16.89,18.42,20.40,22.68,25.10,27.48,29.63,31.40,32.66,33.32,33.80,33.80,33.32,32.66,31.40,29.63,27.48,25.10,22.68,20.40,18.42,16.89,15.93,15.93};
		};
	};

 

  • Like 1

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.