Sign in to follow this  
Missa LaHache

[A3 DMS] AI spawn bug (AI cannot move)

4 posts in this topic

Hello there,

I hope everyone's going good on this sunny day !

My name is Missa and I am a beginner Arma 3 scriptwriter.

With a good friend of mine, we're building up a mod compilation with exile mod as a base just because we like programming and two or three friends are interested by an Exile PVE mod.

My friend is more specialized with server functionality (auto restart - server loads - our own launcher) and I am more concerned about the mod and gameplay itself.

Here is my problem :

Recently, I've started modifying A3 DMS mission file in order to include custom self-made scenarios in order to help AI with more covers (like camps, real construction site, etc...).

Speaking of AI, I've implemented the simple VCOMAI scripts into my mission files (if it can help to resolve my following question).

Additional infos : I am developing and testing it on a Windows 10 environment, but our main dedicated server is running on a linux debian 8.9.

- Strange behaviour :

When I am testing my mission dynamically generated with A3 DMS on my test computer (the one running with window 10), the AI spawn properly and everything works fine.


When I am putting these files into production mode (on our Linux server), AI spawn are bugged. Let me explain myself :

The AI is supposed to spawn at the center of the dynamic mission, they does indeed spawn, but they can not move, like if they were glitched into an invisible vehicle or so. They can still turn on themself, see you and even fire.

Here is my question :

Does anyone knows a fix or have any clues on what is going on ?

I supposed at first that the AI may spawn a bit under the 0 surface and then be glitched like that, but I realised that it wasn't that, because others vehicles and even mission objects (like construction, etc...) spawn at the right location, with a everything okay.

I also tried to disable VCOMAI, which were throwing errors (for something else, but still errors) but it doesn't change a thing with spawned units.

I am also running A3 Occupation mod, some units may spawn with CUP weapons (but this shouldn't affect the way they spawn). I've got others mods running too, if you think it is worth to put a list of running mods on the server I can do it.


Thanks in advance, I apologize for typo errors,





Share this post

Link to post
Share on other sites

Hello everyone,

Well after some hard research, I found that it was enhanced movements mod that was causing AI spawn to be bugged. It is rather strange cause everything worked fine until now, and it is only occurring with Arma 3 server on Linux.

Here are some funny pics I took yesterday while trying to fix things : -

I will try to fix enhanced movements mod soon. I will get back here If I've got some news.

Have a nice day !



Edited by Missa LaHache

Share this post

Link to post
Share on other sites

Hey everybody,

has anybody found a solution ?

The npc do nothing, just stand and fire, but not moving... :-(

I removed Enhanced Movement, som Missions the NPC move, on some Mission the lie or stand next to the loot crate



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.