[RG] Salutesh

Exile Scavenge Framework - 0.7 BETA (23.10.2017)

256 posts in this topic

Advertisement

ok so I have been having problems, the script worked out of the box but I wanted specific loot from scavenging different places so as normal went to my loot tables and set some new ones up but when I swapped the tables over in the script it stopped working (although normal loot drops were still happening) so I reverted back to the standard ones and it worked again.

After 3 attempts I am scratching my head, it may be I have been coding too much and now I am code-blind but I  cant see why it doesn't work, if you could take a look and tell me what the hell I did wrong - cheers.

CfgExileScavenge is here: https://pastebin.com/pDW8Emdj

LootItemGroups is here: https://pastebin.com/4EjFVVYB

LootTables ia here: https://pastebin.com/W83zLMbZ

and full CfgExileLootServer output is here: https://pastebin.com/7M3aW2Xw

cheers for any help

ned

Share this post


Link to post
Share on other sites
15 hours ago, red_ned said:

ok so I have been having problems, the script worked out of the box but I wanted specific loot from scavenging different places so as normal went to my loot tables and set some new ones up but when I swapped the tables over in the script it stopped working (although normal loot drops were still happening) so I reverted back to the standard ones and it worked again.

After 3 attempts I am scratching my head, it may be I have been coding too much and now I am code-blind but I  cant see why it doesn't work, if you could take a look and tell me what the hell I did wrong - cheers.

CfgExileScavenge is here: https://pastebin.com/pDW8Emdj

LootItemGroups is here: https://pastebin.com/4EjFVVYB

LootTables ia here: https://pastebin.com/W83zLMbZ

and full CfgExileLootServer output is here: https://pastebin.com/7M3aW2Xw

cheers for any help

ned

how you have it connected seems good to me while looking at it on a monday morning.

though, don't think this is it but..

your cfgexilelootserver has html in 1st line.

span class="re5"> class CfgExileLootServer

Share this post


Link to post
Share on other sites

hey guys

 

awesome script!!!! but i have a issue i use the EXAD script and inside it it have a CfgFunctions.cpp file it use where u call it from description.ext and also in this script it gets a calls up from the description.ext with CfgFunctions.cpp file

So how do i merge these to files so it works as from now the exad is not working anymore

Please check the pics if it makes sense!!!

thanks

Spoiler

issue1.jpg

Spoiler

issue2.jpg

Spoiler

issue3.jpg

 

Share this post


Link to post
Share on other sites
1 hour ago, yukihito23 said:

how you have it connected seems good to me while looking at it on a monday morning.

though, don't think this is it but..

your cfgexilelootserver has html in 1st line.

span class="re5"> class CfgExileLootServer

When I had this issue, I was testing it out on my test server, but when I decided to just push it to my main server where my players are on, they told me right away that they were finding the new items through the scavenge system. Not sure why I could see it on one server but not the other when they're identical lol.

Share this post


Link to post
Share on other sites
12 minutes ago, DEADPOOL_ZA said:

hey guys

 

awesome script!!!! but i have a issue i use the EXAD script and inside it it have a CfgFunctions.cpp file it use where u call it from description.ext and also in this script it gets a calls up from the description.ext with CfgFunctions.cpp file

So how do i merge these to files so it works as from now the exad is not working anymore

Please check the pics if it makes sense!!!

thanks

  Hide contents

issue1.jpg

  Hide contents

issue2.jpg

  Reveal hidden contents

issue3.jpg

 

In the cfgfunctions fIle from the framework, just use the #include "Exad...." line before the closing bracket and delete the other section inside description.ext file that called the Exad file. 

Share this post


Link to post
Share on other sites
17 minutes ago, Johnny_Bravo said:

In the cfgfunctions fIle from the framework, just use the #include "Exad...." line before the closing bracket and delete the other section inside description.ext file that called the Exad file. 

thanks for coming back to me bro

so it must be like this

class CfgFunctions
#include "ExAdClient\CfgFunctions.cpp"
{    

    class ExileExpansionMission
    {
        class Bootstrap
        {
            file="bootstrap";
            class preInit
            {
                preInit=1;
            };
        };
    };
};

Edited by DEADPOOL_ZA

Share this post


Link to post
Share on other sites
18 minutes ago, Johnny_Bravo said:

When I had this issue, I was testing it out on my test server, but when I decided to just push it to my main server where my players are on, they told me right away that they were finding the new items through the scavenge system. Not sure why I could see it on one server but not the other when they're identical lol.

have you ever tried a diff between filea on prod and dev?

maybe a difference which makes it work on one but not the other

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.