Stoll

[SOLVED] RussianRouletteChair Directions

3 posts in this topic

First of all: :swear:
What's wrong with the Roulette Chairs?!
I get the code with the Exile Mod 3DEN Plugin export function like this e.a.:

["Exile_RussianRouletteChair", [11506.6, 11273.6, 316.945], [0.0348995, 0.999391, 0], [0, 0, 1], true],
["Exile_RussianRouletteChair", [11507.5, 11273.5, 316.947], [0.0871557, 0.996195, 0], [0, 0, 1], true],
["Exile_RussianRouletteChair", [11505.4, 11272.6, 316.941], [-0.997564, 0.069757, 0], [0, 0, 1], true],
["Exile_RussianRouletteChair", [11508.5, 11272.4, 316.945], [0.997564, -0.0697565, 0], [0, 0, 1], true],
["Exile_RussianRouletteChair", [11507.1, 11271.4, 316.941], [-0.0697566, -0.997564, 0], [0, 0, 1], true],
["Exile_RussianRouletteChair", [11506.4, 11271.4, 316.942], [-0.0697566, -0.997564, 0], [0, 0, 1], true]

But when I get ingame the chairs don't stand in the direction anymore I placed them. >:(
I tried disabling simulation as well. Nothing....they do what they want. These chairs are mystically...
...I tried a dozen times to replace them, always with the same result. I don't want anymore...
HEEEEEEEEELP O.o

Edited by Stoll

Share this post


Link to post
Share on other sites

Well, I still had a lot of trial and error on this and finally the chairs are almost placed now in the wanted direction.
It's still a mystic phenomenon for me...2 chairs were facing the correct direction from the very beginning.
So, I compared the directions I set with the results I got and turned the chairs back in the direction at the degree it turned too far.
This means if the chair was set to zero degree and the result was 90 degrees to the right, I turned it 90 degrees to the left in the editor.
Even that needed 2 tries sometimes but it worked for me. The directions in the editor of course aren't correct now anymore, but ingame they flip in the direction they should face.

I appreciate that it was simplified to place these chairs, compared with the old method it should be easy now, just place and export the data. But this does not work for some reason and it took me hours to reach a result.
Maybe some devs can look into this again or are already aware of this (crap)...thankee!

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.