• 0
General_Jacob

Server Crash on Reading Mission (Noob)

Question

Hey guys, 

First post so I apologize if there is an easy fix and I don't know any better yet, I'm here to learn hopefully so thanks for your patience in advance. I am essentially launching a vanilla as can be server just to get it up and begin to play with settings and customization. I followed the newest guide on this site with downloads and things went pretty well.

My problem is when I launch my server using the Exile Auto Start bat it gets to reading mission file and shuts down. I have read various other posts on this and I was not able to properly apply concepts or solutions to my situation. I am (attempting) to include my rpt file via hastebin as per the rules but again this is my first question. If it doesn't come across I will try again. 

Really tons of thanks in advance, all help no matter how basic is just more for me to learn. 

https://hastebin.com/aqebuqikiv.tex

 

-- EDIT --

So thanks to you kind individuals I realized that I skimmed right over the part where the rpt says "your error is here." My bad. 

The log is telling me it is in fact a MySQL issue and it reads as follows:

[01:20:05:360216 --4:00] [Thread 6932] extDB2: Database Type: MySQL
[01:20:06:374274 --4:00] [Thread 6932] extDB2: Database Exception Error: Connection attempt failed: Can't connect to MySQL server on '127.0.0.1' (10061)
[01:20:06:374274 --4:00] [Thread 6932] extDB2: Sending Shutdown to Armaserver
 

I will look into more about the MySQL stuff to see if I can figure it out but quick tips from those of you who know what you're doing would be great. I expect it to be a generic "first timer" issue.

Thanks again. 

Edited by General_Jacob
Update

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

Have a look in this log like it tells you here and pastebin that 

- Please have a look at @ExileServer/extDB/logs/ to find out what went wrong."

Share this post


Link to post
Share on other sites
  • 0

Did you setup a database, mysql?

Did you configured your armaroot\@ExileServer\extdb-conf.ini?

 

[exile]
Type = MySQL
Name = HereYourDatabaseName // this one from you hoster
Username = HereYourDatabeseUsername // this one from you hoster
Password = HereTheDatabasePassword // this one from you hoster
IP = HereTheIPtoTheDatabase // IP or url like this: database.myhoster.tld from your Hoster
Port = 3306 // Port must match with the Port from your Hoster, too
minSessions = 2
idleTime = 60
; Really should only use this if MySQL server is external. Also only for MySQL
compress = false
; Recommend you turn this on  http://dev.mysql.com/doc/refman/5.6/en/mysql-command-options.html#option_mysql_secure-auth
Secure Auth = true

 

Share this post


Link to post
Share on other sites
Advertisement
  • 0
[01:20:06:374274 --4:00] [Thread 6932] extDB2: Database Exception Error: Connection attempt failed: Can't connect to MySQL server on '127.0.0.1' (10061)

Either you'r not even running mysql service or the conections infos in armaroot\@ExileServer\extdb-conf.ini are not correct.

Make sure service is running, you could also try to connect with another client such as HeidiSQL to see if you can establish a connection to your DB

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thanks a lot @WURSTKETTE

I have MySQL up and running (unless its running incorrectly but I followed the guide to the letter. Assuming that part is ok, I'm looking into the extdb  config. By connection infos you mean the port numbers and things?

Also thanks again guys, I know hand-holding someone new is like pulling teeth. 

Share this post


Link to post
Share on other sites
  • 0

So for an update, Wurstkette was correct and I needed to realign all the parameters in my extdb. A few entries there did not match other files entries. Thanks very much for the help, my problem is solved. 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.