• 0
ILGMĀRS - ARMA.LV

After Update all clients get kicked by battleye!

Question

After dedicated server update clients get battleye initialization failed! i have tried removing battleye folder, filters, reinstalling server completely.

any ideas?

client RTP shows nothing but initialization failed

Edited by ILGMĀRS - ARMA.LV

Share this post


Link to post
Share on other sites

28 answers to this question

  • 1

there is an issue with the ExileServer_system_garbageCollector_deleteObject.sqf so here is the fix just overwrite the old one

Spoiler

/**
 * ExileServer_system_garbageCollector_deleteObject
 *
 * Exile Mod
 * www.exilemod.com
 * © 2015 Exile Mod Team
 *
 * This work is licensed under the Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License. 
 * To view a copy of this license, visit http://creativecommons.org/licenses/by-nc-nd/4.0/.
 */
 
private["_object", "_fliesSound", "_fliesParticles"];
_object = _this;
if (_object getVariable ["ExileIsSimulationMonitored", false]) then
{
    _object call ExileServer_system_simulationMonitor_removeVehicle;
};
_object removeAllMPEventHandlers "MPKilled";
_object removeAllEventHandlers "Dammaged";
_object removeAllEventHandlers "GetIn";
_object removeAllEventHandlers "GetOut";
removeAllActions _object;
clearBackpackCargoGlobal _object;
clearWeaponCargoGlobal _object;
clearItemCargoGlobal _object;
clearMagazineCargoGlobal _object;
removeAllContainers _object;
if !(isNull (attachedTo _object)) then 
{
    detach _object;
};
_fliesSound = _object getVariable ["ExileFliesSound", objNull];
if !(isNull _fliesSound) then 
{
    deleteVehicle _fliesSound;
};
_fliesParticles = _object getVariable ["ExileFliesParticles", objNull];
if !(isNull _fliesParticles) then 
{
    _fliesParticles setDamage 999; 
};
{
    _x call ExileServer_system_garbageCollector_deleteObject;
}
forEach (attachedObjects _object);
deleteVehicle _object;

the change was

this 

_object removeAllEventHandlers "MPKilled";
_object removeAllEventHandlers "Damaged";

to this

_object removeAllMPEventHandlers "MPKilled";
_object removeAllEventHandlers "Dammaged";

on lines 18 and 19

Share this post


Link to post
Share on other sites
Advertisement
  • 0
16 minutes ago, ILGMĀRS - ARMA.LV said:

yea, i seen it, i got server on 2302 and ports opened till 2306 atm .. will widen the range a bit
so far no change (no traffic is going tru them)

You need to change your RCON port to 2307

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Beowulfv said:

You need to change your RCON port to 2307

will try that man, atm we are in the middle of testing few things. after that will test it and report .. probably tomorrow

 

 

btw, i had rcon on port 2320 before that, it was well out of the way

 

 

it did not work .. 0 trafiic on those ports
http://prntscr.com/hhihx7

Edited by ILGMĀRS - ARMA.LV

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.