WolfkillArcadia

Arma 1.78/1.80 Bugs Megathread !! READ THE RULES!!

53 posts in this topic

On 12/1/2017 at 0:53 AM, WURSTKETTE said:
  • Once sending shutdown thru rcon or killing the arma3server.exe task in any other way (closing armaconsol window), the server crash on killing the task - did someone else experienced this behaviour or has any idea what could lead to that?
  • Windows Server 2008 R2 Standard

Distribution: 0
Version 1.78.143717
Fault time: 2017/12/01 02:59:45
Fault address:  014CA8BD 01:006298BD C:\Users\exile\a3M\arma3server.exe
file:     Exile (__cur_mp)
world:    Altis
Prev. code bytes: 39 4E 08 74 1C 8B 46 08 89 08 8B 4E 04 8B 46 08
Fault code bytes: 89 41 04 C7 46 08 00 00 00 00 C7 46 04 00 00 00

Registers:
EAX:92BB2B1C EBX:92E6B880
ECX:00000000 EDX:92F60000
ESI:92E87218 EDI:00000026
CS:EIP:0023:014CA8BD
SS:ESP:002B:00B2EE0C  EBP:23BBB86C
DS:002B  ES:002B  FS:0053  GS:002B
Flags:00210282
=======================================================
note: Minidump has been generated into the file logs\arma3server_2017-12-01_00-01-33.mdmp
  • Fixed: The issues was caused due to a serverside pbo placing custom mapobjects

I removed all of my custom  pbo mapobjects ( server 2012 r2 )  .. still crashes on restart 
See full rpt here https://pastebin.com/LQ2tB7t2
 

Spoiler

Distribution: 0
Version 1.78.143717
Fault time: 2017/12/03 02:14:37
Fault address:  014EA8BD 01:006298BD E:\Games\Arma3\arma3server.exe
file:     Exile (__cur_mp)
world:    Lythium
Prev. code bytes: 39 4E 08 74 1C 8B 46 08 89 08 8B 4E 04 8B 46 08
Fault code bytes: 89 41 04 C7 46 08 00 00 00 00 C7 46 04 00 00 00

Registers:
EAX:1270FC94 EBX:5011B7E0
ECX:00000000 EDX:50190000
ESI:51075618 EDI:0000000C
CS:EIP:0023:014EA8BD
SS:ESP:002B:0311EE9C  EBP:228518EC
DS:002B  ES:002B  FS:0053  GS:002B
Flags:00010202
=======================================================
note: Minidump has been generated into the file sc\arma3server_2017-12-02_23-13-57.mdmp
 

 

Edited by Chainsaw Squirrel

Share this post


Link to post
Share on other sites

Guys the dammaged / damaged   error from within infiSTAR was fixed minutes after the patch release, please stay up 2 date on the infiSTAR files so you don't have problems like this :)

XD4hOp4QmN3BLcOYagwPH.png

  • Like 8

Share this post


Link to post
Share on other sites
Advertisement
Guest

Guys it isn't that difficult to look at the OP and follow the format. Discussions aren't allowed here. This thread is for you to follow the format so the devs can look at it and try to perform a fix or tell you that it has nothing to do with exile mod. If you want a discussion post it in the proper subforum. Thank you

Share this post


Link to post
Share on other sites

Okay hopefully i have not missed anything in the OP this time.

 

Found this error in our rpt file.  Not sure if it is related to new arma update, have not notice this before.

Spoiler

16:43:23 Error in expression <] call BIS_fnc_param;
_publicMessage = [ExileClientSessionId, _messageName, _mes>
16:43:23   Error position: <ExileClientSessionId, _messageName, _mes>
16:43:23   Error Undefined variable in expression: exileclientsessionid
16:43:23 File exile_client\code\ExileClient_system_network_send.sqf, line 15

 

 

Share this post


Link to post
Share on other sites

With V1.80 have added to the  ExileServer_system_garbageCollector_deleteObject .sqf

_object removeAllEventHandlers "MPKilled";
_object removeAllEventHandlers "Damaged";

replaced with 

_object removeAllMPEventHandlers "MPKilled";
_object removeAllEventHandlers "Dammaged";

also added 

ExileServer_object_construction_network_upgradeConstructionRequest .sqf which i replaced

CAN_COLIDE  with   CAN_COLLIDE

then as we get into the vehicle we get kicked from the server, as well server restarts with the minidump

Spoiler

Mods: @ExileServer;@Advance_Rappelling;@Advance_Urban_Rappelling;@JSRS;@Enigma;@Thermal;@Zab;A3;curator;kart;heli;mark;expansion;jets;argo;orange;tacops;dlcbundle;dlcbundle2;@Exile;@LYTHIUM;@JBAD;@ExtendedBaseMod;@Extended_Survival_Pack;@FFAA;@Ryan_Zombies;@RZInfections
ServerMods: @Zab;@Thermal;@Enigma;@JSRS;@Advance_Urban_Rappelling;@Advance_Rappelling;@ExileServer
Distribution: 0
Version 1.80.143751
Fault time: 2017/12/08 18:44:30
Fault address:  0135DDB4 01:0047CDB4 D:\TCAFiles\Users\russells\21713\arma3server.exe
file:     Exile_Crazy (__cur_mp)
world:    Lythium
Prev. code bytes: 08 57 8B F9 83 7E 04 00 74 22 8B 56 08 8B 46 04
Fault code bytes: 89 02 8B 4E 04 8B 46 08 89 41 04 C7 46 08 00 00

Registers:
EAX:87F9A664 EBX:00000064
ECX:115267F0 EDX:00000000
ESI:52D28818 EDI:115267F0
CS:EIP:0023:0135DDB4
SS:ESP:002B:00BEF3EC  EBP:115267F4
DS:002B  ES:002B  FS:0053  GS:002B
Flags:00210282
=======================================================
note: Minidump has been generated into the file profile\arma3server_2017-12-08_18-41-12.mdmp

all my objects are inside a a3_custom.pbo and this is for the lythium map as my altis works ok

So maybe for others who will have the same issue we will get it fixed SOON

Share this post


Link to post
Share on other sites

Hello Devs,

found another enum failure:

 

Spoiler

11:42:17 "ExileServer - Player herzblut (UID 76561198031286691) connected!"

11:42:20 "ExileServer - Starting session for 'herzblut' with ID 'HNCSorUc'..."

11:42:20 "ExileServer - Dispatching hasPlayerRequest for session 'HNCSorUc'..."

11:42:20 Inventory item with given name: [Rangefinder] not found

11:42:57 "ExileServer - Calling ExileServer_system_event_ambientFlyOver_start..."

11:42:57 "ExileServer - Ambient Fly Over - Heading to R chaotengruppe:1 (herzblut) REMOTE..."

11:42:57 Error in expression <n) * _distance,

800

];

_pilot = _group createUnit ["I_helicrew_F", _startPositi>

11:42:57 Error position: <createUnit ["I_helicrew_F", _startPositi>

11:42:57 Error Foreign error: Unknown enum value: "PRIVATE"

11:42:57 File exile_server\code\ExileServer_system_event_ambientFlyOver_start.sqf, line 47

11:42:57 Error in expression <n) * _distance,

800

];

_pilot = _group createUnit ["I_helicrew_F", _startPositi>

11:42:57 Error position: <createUnit ["I_helicrew_F", _startPositi>

11:42:57 Error Foreign error: Unknown enum value: "PRIVATE"

11:42:57 File exile_server\code\ExileServer_system_event_ambientFlyOver_start.sqf, line 47

11:50:58 "ExileServer - Spawning ExileServer_system_event_supplyBox_start..."

Thanks for help and support

Stefan

Share this post


Link to post
Share on other sites

Im getting this in last 2-3 days. It starts spamming RPT, server freezes completely. Even after closing server window i have to go to task manager and kill armaserver_64 manually. Had it happening 3 times already, first time in 8 months of running that server.

NetServer::finishDestroyPlayer(1402123561): DESTROY immediately after CREATE, both cancelled
BEServer::finishDestroyPlayer(1402123561): users.get failed

https://pastebin.com/7vA01b7W
Now its right after XM8 mesage sent but on the other times it was just random.

Edited by dima054
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, dima054 said:

Im getting this in last 2-3 days. It starts spamming RPT, server freezes completely. Even after closing server window i have to go to task manager and kill armaserver_64 manually. Had it happening 3 times already, first time in 8 months of running that server.


NetServer::finishDestroyPlayer(1402123561): DESTROY immediately after CREATE, both cancelled
BEServer::finishDestroyPlayer(1402123561): users.get failed

https://pastebin.com/7vA01b7W
Now its right after XM8 mesage sent but on the other times it was just random.

I had the same problem a while back. In my case it was the XM8.dll causing issues. How I fixed it back then was simply removing the XM8.dll from the @ExileServer folder. However, this problem might have another cause but you could try.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.