• 0
Sign in to follow this  
General_Jacob

Serverside Mod Placement Question (noob)

Question

Hello again friends, 

I have modded a map with slight changes in editor such as creation of traders and all that, I repacked the edited mission into my mission pbo in replacement of the old one, but when I run my server I get errors that certain objects are missing over and over. 

I have a feeling that my mods are in the wrong place and wanted to double check where they are supposed to go in my server folders. Specifics would be really great. I added them to my auto start batch but I think my folders are not placed properly. I did quite a bit of searching on what would cause this error but could not piece it together exactly myself. I solved the error for a few pieces but it keeps giving me new ones.

Specific examples would be really great so I can wrap my head around how things work. Thanks in advance for your patience.  

If its helpful, this is at the bottom of my RPT

 1:23:02 Cannot register unknown string STR_3DEN_CAMERA_NAME
 1:23:02 Cannot register unknown string STR_DIFF_SCENE_ONLY
 1:23:02 Cannot register unknown string STR_DIFF_SCENE_AND_MAP
 1:23:02 Initializing stats manager.
 1:23:02 Stats config disabled.
 1:23:02 sessionID: 193b2d1514ccc9e3a52f11b0eef56660a6af50d7

Edited by General_Jacob
Included RPT

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

I suppose more specifically to maybe bump this, with my mod placement I am afraid I do not understand which files go in which addons folder and I have not found a clear answer independently. I think my modified map is returning errors on launch because it is attempting to locate the addons but I only have them in the root addon folder, not say the server addon folder but before I make a mess I wanted to ask here. 

Share this post


Link to post
Share on other sites
Advertisement
  • 0

These are due to the Arma3 1.78 update nothing to do with your mods etc .. we all have these .. the traders are all in the initServer.sqf , you cant edit the existing traders ( pull them in and edit ) .. but you can recreate the traders in new locations or same locations but redo all the traders and objects associated with the traders in the editor . you will need the 3DEN Plugin available here  http://www.exilemod.com/downloads/  to export the traders and the associated objects to the initServer.sqf.  It will copy the items to your windows clipboard and paste that into a new notepad ++ file .. make sure to always backup your old files , or call them initServer.bak .. so you can revert the changes if needed .. the trader locations can be moved or add new ones too .. all using the existing mission.sqm .. how to do that is posted on here many times .. it's really pretty easy ..I hope this helped .. it's a lot to take in when you're new to doing all this.
As far as the objects used .. its best to stick with existing arma assets objects .. not using 3rd party objects such as cups etc .. until u get the basics down pat .. then you can import objects from other mods.

As far as where the mods go - they all go in your arma server folder if you self hosting on your own box .. if you use a hosting company, they may have other locations , they want you to use. 
Like mine I .. I have a dedicated box here at home for arma3 servers .. I have my server on a separate SSD drive, in a folder called Arma3 .. all the mods @cups, @exile, etc etc all go in that folder, then you call the mods in your startup batch file 

arma3server.exe" -config=E:\Games\Arma3\@ExileServer\config.cfg -cfg=E:\Games\Arma3\@ExileServer\basic.cfg -port=2302 -autoInit -cpuCount=4 -malloc=tbbmalloc
-mod=@exile;@Pook_H-13;@NATO_Rus_Vehicle;@NATO_Rus_Weapons;      -servermod=@exileserver;@infiSTAR_Exile; -profiles=sc -name=sc  .. or what ever yours is 

Server Side mods go in @ExileServer/addons  u dont use @mod etc in the addons folder those all stay in the main arma directory , server side mods are always packed into a PBO .. or they don't work .. you need PBO manager to pack and unpack PBO files .. 
http://www.armaholic.com/page.php?id=16369 .

On 12/2/2017 at 1:26 AM, General_Jacob said:

 

 1:23:02 Cannot register unknown string STR_3DEN_CAMERA_NAME
 1:23:02 Cannot register unknown string STR_DIFF_SCENE_ONLY
 1:23:02 Cannot register unknown string STR_DIFF_SCENE_AND_MAP
 1:23:02 Initializing stats manager.
 1:23:02 Stats config disabled.
 1:23:02 sessionID: 193b2d1514ccc9e3a52f11b0eef56660a6af50d7

Edited by Chainsaw Squirrel

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.