Sign in to follow this  
Chainsaw Squirrel

[ SOLVED ] DMS mission build error ??

10 posts in this topic

I think this is causing this error in RPT .. mission loading up . not sure.. but pretty sure ..  
just not sure what mission is causing error anyone have a way to tell which mission this might be ? obviously it has a vehicle  or its calling a crate a vehicle .. just look for the 7,0.0178668,0.00996966,0.999791 in the missions ? 
 

Spoiler

13:45:27 Error in expression <7,0.0178668,0.00996966,0.999791,[[],[]],<null>,<null>,"0000","","",0]]]>
13:45:27   Error position: <<null>,<null>,"0000","","",0]]]>
13:45:27   Error Invalid number in expression
13:45:27 Error in expression <7,0.0178668,0.00996966,0.999791,[[],[]],<null>,<null>,"0000","","",0]]]>
13:45:27   Error position: <<null>,<null>,"0000","","",0]]]>
13:45:27   Error Invalid number in expression
13:45:27 Error in expression <"extDB2" callExtension _query);
switch (_result select 0) do
{
case 0:
{
(format>
13:45:27   Error position: <_result select 0) do
{
case 0:
{
(format>
13:45:27   Error Undefined variable in expression: _result
13:45:27 File exile_server\code\ExileServer_system_database_query_selectSingle.sqf, line 16
13:45:27 Error in expression <texture = _data select 21;
try 
{
if !((vectorMagnitude _vectorUp) isEqualTo 1) >
13:45:27   Error position: <vectorMagnitude _vectorUp) isEqualTo 1) >
13:45:27   Error Type Any, expected Number
13:45:27 File exile_server\code\ExileServer_object_vehicle_database_load.sqf, line 22
13:45:27 Error in expression <000)
];
_vehicleObject = createVehicle [_vehicleClassName, _temporaryPositionInO>
13:45:27   Error position: <_vehicleClassName, _temporaryPositionInO>
13:45:27   Error Undefined variable in expression: _vehicleclassname
13:45:27 File exile_server\code\ExileServer_object_vehicle_carefulCreateVehicle.sqf, line 23
13:45:27 Error in expression <ode = _this select 4;
_vehicleObject = [_className, _position, _direction, _useP>
13:45:27   Error position: <_className, _position, _direction, _useP>
13:45:27   Error Undefined variable in expression: _classname
13:45:27 File exile_server\code\ExileServer_object_vehicle_createPersistentVehicle.sqf, line 18
13:45:27 Error in expression <
_items = _this select 1;
if ((typeName _items) isEqualTo "ARRAY") then 
{
if!(_>
13:45:27   Error position: <_items) isEqualTo "ARRAY") then 
{
if!(_>
13:45:27   Error Undefined variable in expression: _items
13:45:27 File exile_server\code\ExileServer_util_fill_fillItems.sqf, line 15
13:45:27 Error in expression <gazines = _this select 1;
if ((typeName _magazines) isEqualTo "ARRAY") then 
{    
>
13:45:27   Error position: <_magazines) isEqualTo "ARRAY") then 
{    
>
13:45:27   Error Undefined variable in expression: _magazines
13:45:27 File exile_server\code\ExileServer_util_fill_fillMagazines.sqf, line 15
13:45:27 Error in expression <weapons = _this select 1;
if ((typeName _weapons) isEqualTo "ARRAY") then
{
if!(>
13:45:27   Error position: <_weapons) isEqualTo "ARRAY") then
{
if!(>
13:45:27   Error Undefined variable in expression: _weapons
13:45:27 File exile_server\code\ExileServer_util_fill_fillWeapons.sqf, line 15
13:45:27 Error in expression <tabase_query_selectSingle;
_position = [_data select 8, _data select 9, _data se>
13:45:27   Error position: <_data select 8, _data select 9, _data se>
13:45:27   Error Undefined variable in expression: _data
13:45:27 File exile_server\code\ExileServer_object_vehicle_database_load.sqf, line 15

 

Edited by Chainsaw Squirrel

Share this post


Link to post
Share on other sites
8 minutes ago, Chainsaw Squirrel said:

I think this is causing this error in RPT .. mission loading up . not sure.. but pretty sure ..  
just not sure what mission is causing error anyone have a way to tell which mission this might be ? obviously it has a vehicle  or its calling a crate a vehicle .. just look for the 7,0.0178668,0.00996966,0.999791 in the missions ? 
 

  Hide contents

13:45:27 Error in expression <7,0.0178668,0.00996966,0.999791,[[],[]],<null>,<null>,"0000","","",0]]]>
13:45:27   Error position: <<null>,<null>,"0000","","",0]]]>
13:45:27   Error Invalid number in expression
13:45:27 Error in expression <7,0.0178668,0.00996966,0.999791,[[],[]],<null>,<null>,"0000","","",0]]]>
13:45:27   Error position: <<null>,<null>,"0000","","",0]]]>
13:45:27   Error Invalid number in expression
13:45:27 Error in expression <"extDB2" callExtension _query);
switch (_result select 0) do
{
case 0:
{
(format>
13:45:27   Error position: <_result select 0) do
{
case 0:
{
(format>
13:45:27   Error Undefined variable in expression: _result
13:45:27 File exile_server\code\ExileServer_system_database_query_selectSingle.sqf, line 16
13:45:27 Error in expression <texture = _data select 21;
try 
{
if !((vectorMagnitude _vectorUp) isEqualTo 1) >
13:45:27   Error position: <vectorMagnitude _vectorUp) isEqualTo 1) >
13:45:27   Error Type Any, expected Number
13:45:27 File exile_server\code\ExileServer_object_vehicle_database_load.sqf, line 22
13:45:27 Error in expression <000)
];
_vehicleObject = createVehicle [_vehicleClassName, _temporaryPositionInO>
13:45:27   Error position: <_vehicleClassName, _temporaryPositionInO>
13:45:27   Error Undefined variable in expression: _vehicleclassname
13:45:27 File exile_server\code\ExileServer_object_vehicle_carefulCreateVehicle.sqf, line 23
13:45:27 Error in expression <ode = _this select 4;
_vehicleObject = [_className, _position, _direction, _useP>
13:45:27   Error position: <_className, _position, _direction, _useP>
13:45:27   Error Undefined variable in expression: _classname
13:45:27 File exile_server\code\ExileServer_object_vehicle_createPersistentVehicle.sqf, line 18
13:45:27 Error in expression <
_items = _this select 1;
if ((typeName _items) isEqualTo "ARRAY") then 
{
if!(_>
13:45:27   Error position: <_items) isEqualTo "ARRAY") then 
{
if!(_>
13:45:27   Error Undefined variable in expression: _items
13:45:27 File exile_server\code\ExileServer_util_fill_fillItems.sqf, line 15
13:45:27 Error in expression <gazines = _this select 1;
if ((typeName _magazines) isEqualTo "ARRAY") then 
{    
>
13:45:27   Error position: <_magazines) isEqualTo "ARRAY") then 
{    
>
13:45:27   Error Undefined variable in expression: _magazines
13:45:27 File exile_server\code\ExileServer_util_fill_fillMagazines.sqf, line 15
13:45:27 Error in expression <weapons = _this select 1;
if ((typeName _weapons) isEqualTo "ARRAY") then
{
if!(>
13:45:27   Error position: <_weapons) isEqualTo "ARRAY") then
{
if!(>
13:45:27   Error Undefined variable in expression: _weapons
13:45:27 File exile_server\code\ExileServer_util_fill_fillWeapons.sqf, line 15
13:45:27 Error in expression <tabase_query_selectSingle;
_position = [_data select 8, _data select 9, _data se>
13:45:27   Error position: <_data select 8, _data select 9, _data se>
13:45:27   Error Undefined variable in expression: _data
13:45:27 File exile_server\code\ExileServer_object_vehicle_database_load.sqf, line 15

 

you have a few issues in your mission, looks like the initial vehicle string is wrong which is leading to all the other errors happening.

check your rpt to see if it gives a name, if it doesn't add these lines to your static/bandit missions (making sure its after defining the mission name)

so look for:

// Define mission name (for map marker and logging)
_missionName = "Name of mission";

and add after:

Quote

//export to logs for testing
diag_log format ["Running DMS MISSION %1",_missionName];

now each mission that loads will add an RPT line to say its triggered then you can see which one is bugged

  • Like 1

Share this post


Link to post
Share on other sites
Advertisement

I think it was a static mission I.. cause I got the error and it didnt show up .. but the bandits did and they show which is running .. I didn't put the diag on the static . so I commented them out and wait for next restart .. to see if it was them 

Share this post


Link to post
Share on other sites
8 hours ago, Chainsaw Squirrel said:

I think it was a static mission I.. cause I got the error and it didnt show up .. but the bandits did and they show which is running .. I didn't put the diag on the static . so I commented them out and wait for next restart .. to see if it was them 

at least you are narrowing it down!

Share this post


Link to post
Share on other sites

nah it wasnt .. I turned static off .. still did it .. whatever it is .. its calling it  as soon as server starts, might also be VEMF spewing the error .. since it dosnt mention DMS anywhere..

 

Edited by Chainsaw Squirrel

Share this post


Link to post
Share on other sites
22 minutes ago, Chainsaw Squirrel said:

nah it wasnt .. I turned static off .. still did it .. whatever it is .. its calling it  as soon as server starts, might also be VEMF spewing the error .. since it dosnt mention DMS anywhere..

 

try this thread:

 

Share this post


Link to post
Share on other sites

yea thats old as hell but prob related.. guess will take this over to exile discord .. and see what they say .. sounds like they were talking about exile version update .. but this was a fresh 1.03 install .. of course arma 1.78 may be the issue

 

Share this post


Link to post
Share on other sites
34 minutes ago, Chainsaw Squirrel said:

yea thats old as hell but prob related.. guess will take this over to exile discord .. and see what they say .. sounds like they were talking about exile version update .. but this was a fresh 1.03 install .. of course arma 1.78 may be the issue

 

should be 1.80 now as hot fixes came out

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.