Super Jerome

[UPDATE] VCOM AI (Exile 1.0.4)

117 posts in this topic

I think i found a fix for DMS AI leaving missions.
Go to your DMS mission file and search for this 7 lines listed below and then add the lines you see after  "call DMS_fnc_SpawnAIGroup;"
Do this for every mission and AI stays on the mission ! Needs more testing to confirm it, but so far it looks good !

If you have AI vehicles, Static MG's or multiple groups in the mission add it after the last "call DMS_fnc_SpawnXYZ;" related to AI spawns.

Quote

_group =     [
                _pos,                    // Position of AI
                _AICount,                // Number of AI
                _difficulty,            // "random","hardcore","difficult","moderate", or "easy"
                "random",                 // "random","assault","MG","sniper" or "unarmed" OR [_type,_launcher]
                _side                     // "bandit","hero", etc.
            ] call DMS_fnc_SpawnAIGroup;

_group setVariable ["VCM_TOUGHSQUAD",true];
_group setVariable ["VCM_NORESCUE",true];
_group setVariable ["VCM_NOFLANK",true];           

 

2 people like this

Share this post


Link to post
Share on other sites
Advertisement

Looking at adding this again as it's a brilliant addition.  We had to remove it last time as FPS did drop and also they still stole vehicles even though it was set to false. Thanks in advance.  And great work on getting this working ok. 

Share this post


Link to post
Share on other sites

are those FPS drops gone with this fix too? they are the reason why i kicked VCOM from my server :-/

1 person likes this

Share this post


Link to post
Share on other sites
2 hours ago, Monkeynutz said:

Judging by the post. It was made for V2 of VCOM. We are now on V3. @Super Jerome it would be nice of you to share updated files if you have got some.

On 5/18/2018 at 2:00 AM, arc7r7 said:

Looks like getting the script version working of  VCOM v3 is really simple. 

https://forums.bohemia.net/forums/topic/216611-release-vcom-ai-3-dangerous-ai/

download the script version. Drop VCOM folder and userconfig folder into your mission pbo. 

Add   [] execVM "Vcom\VcomInit.sqf";   into your init.sqf 

Add #include "vcom\cfgFunctions.hpp" into the class CfgFunctions in the description.ext.

I havnt seen any errors and it seems to be working fine. Probably will need more testing but all seems to be good.

Also you'll need to revert any changes made from the older version install of vcom.

 

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.