4 posts in this topic

Ran into an issue tonight whilst adding a few changes to my server

Mods running = Ryan's Zombies and Demons   & Mozzies

Server mods running = Exile & infistar

Addons = DMS & Occupation& ExAd

i had tested ExAdand all was working fine then i added Grinding and Hacking and this is when i got this issue yet it show it is to do with Occupation

Latest Server .rpt bellow

https://pastebin.com/w7hHr0Xv

The issue from the rpt:

Spoiler

{
diag_log >
 6:39:54   Error Undefined variable in expression: fnc_a3_customlog
 6:39:54 File x\addons\a3_exile_occupation\scripts\occupationLog.sqf, line 10
 6:39:54 Error in expression <N")) then
{
[_fileName,_logDetail] call FNC_A3_CUSTOMLOG;    
}
else
{
diag_log >
 6:39:54   Error position: <FNC_A3_CUSTOMLOG;    
}

 

Latest client side .rpt bellow

https://pastebin.com/1a4CEXft

I have gone into the  \@ExileServer\addons\a3_exile_occupation and tried changing the config setting

Spoiler

SC_infiSTAR_log                    = true;                        // true Use infiSTAR logging, false logs to server rptto both 

To both true or false and i get the same result

 

Here is my \@ExileServer\addons\a3_exile_occupation\scripts\occupationLog.sqf

Spoiler

// Logging function to use either infiSTAR logging function or server RPT

_logDetail  = format["%1 %2",SC_occupationVersion,_this select 0];
_fileName   = _this select 1;

if(isNil "_fileName") then { _fileName = "OCCUPATION"; };

if(SC_infiSTAR_log && !(isNil "INFISTARVERSION")) then
{
    [_fileName,_logDetail] call FNC_A3_CUSTOMLOG;    
}
else
{
    diag_log _logDetail;
};

 

Any ideas?

TIA

Smoke

Share this post


Link to post
Share on other sites
Advertisement
1 hour ago, red_ned said:

remove occupation mod and try again

Yeah that was my first thought but then it stalled at something else, I've now  got a bit further with this issue and think it was bad syntax/parsing so I got the server to load with the hacking script in place (just for safes), but we get no scroll menu hints/actions. but whenever someone goes near a safe they get this error in the debug window (check screenshot in attachment) do you or anyone else have any idea why ExAd Hacking would cause this?

 

20180106003614_1.jpg

Edited by twitch.tv/smokedog77

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.