• 0
Fin ¯\_(ツ)_/¯

Ryans Zombies + ExileZ Spawner - Object not found?

Question

Hi, I'm getting this error:

Spoiler

Client: Object 3:211 (type Type_128) not found.

Yes i have googled and read about it, i get that lots of people get this issue.

But no-one (as far as i can tell) has seen the link between players running in the cities and this message then being spammed in the server

So, I'm trying to use the ExileZ spawner to get zombies in my server on Altis. And zombies spawn when players run into cities right?

So when i run into cities, my server goes crazy and gets spammed with messages such as:

Spoiler

11:16:43 Client: Object 3:212 (type Type_115) not found.
11:16:43 Client: Object 3:211 (type Type_127) not found.
11:16:43 Client: Object 3:211 (type Type_161) not found.
11:16:43 Client: Object 3:211 (type Type_457) not found.
11:16:43 Client: Object 3:212 (type Type_114) not found.

Sometimes followed by:

Spoiler

11:16:43 Cannot create non-ai vehicle RyanZombieB_Soldier_02_f_1_1slow,
11:16:43 Cannot create object 3:218 with type[Entity], param[RyanZombieB_Soldier_02_f_1_1slow], NMT code[91]:
11:16:43 Cannot create object 3:219 with type[AIUnit], param[unit], NMT code[113]:

But i hardly ever see the zombies, every now and then i see a zombie for a split second and he goes again?

Any ideas? Help is ever so greatly appreciated!

Edited by Fin ¯\_(ツ)_/¯

Share this post


Link to post
Share on other sites

16 answers to this question

  • 0
8 minutes ago, kuplion said:

Which version of ExileZ are you using?

Well here's another thing, i'm confused about the whole 3.2 and 3.2 serverside thing, Which one should i be using?

I'm using 3.2 serverside.

Share this post


Link to post
Share on other sites
Advertisement
  • 0
9 minutes ago, Fin ¯\_(ツ)_/¯ said:

Ok, thanks alot ill try it, is there anything i need to do to get rid of the old one?

Just undo any changes you've made when installing it.

Share this post


Link to post
Share on other sites
  • 0

@kuplion

Ok so i get this error:

Spoiler

12:40:33 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.ryanzombies, ryanzombiesfunctions

i also had it when i had a capital "R" in the addons part of the mission.sqm but i changed it to "ryanszombies" because i thought it might help. It didnt haha...

This also shows up towards the beginning of start-up:

Spoiler

12:40:10 Error in expression < select 0) + EZM_BlacklistExtendDistance;
];
};
}
forEach allMapMarkers;


EZM_B>
12:40:10   Error position: <;
];
};
}
forEach allMapMarkers;


EZM_B>
12:40:10   Error Missing ]
12:40:10 File exilez_mod\init\fn_postInit.sqf [exilez_mod_fnc_postInit], line 419
12:40:10 Error in expression < select 0) + EZM_BlacklistExtendDistance;
];
};
}
forEach allMapMarkers;


EZM_B>
12:40:10   Error position: <;
];
};
}
forEach allMapMarkers;


EZM_B>
12:40:10   Error Missing ]
12:40:10 File exilez_mod\init\fn_postInit.sqf [exilez_mod_fnc_postInit], line 419
12:40:11 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.
a3_characters_f
 

Thanks alot for this!

Share this post


Link to post
Share on other sites
  • 0

It looks like you're not loading RyanZombies on the server. And the second error looks like you've edited the config and missed a bracket?

Share this post


Link to post
Share on other sites
  • 0
23 minutes ago, kuplion said:

It looks like you're not loading RyanZombies on the server. And the second error looks like you've edited the config and missed a bracket?

Oh ok, regarding the second error, i haven't edited it, but i navigated down to line 419 which it said was the line with the error:

Spoiler

// Add and extend traders to blacklisted areas
if ((EZM_UseAreaBlacklist) && (EZM_BlacklistExtendTraders)) then
{
    {
        if ((getMarkerType _x) isEqualTo "ExileTraderZone") then
        {
            EZM_BlacklistedTraders pushBack
            [
                getMarkerPos _x, 
                ((getMarkerSize _x) select 0) + EZM_BlacklistExtendDistance;
            ];
        };
    }
    forEach allMapMarkers;

    // Add the new blacklist to the old
    EZM_BlacklistedPositions append EZM_BlacklistedTraders;
};

any idea? 

And do you know of steps i can take to see what's going wrong in terms of loading ryanszombies?

Share this post


Link to post
Share on other sites
  • 0

When installing the Ryanszombies mod, i get a little confused.

  1. The folder I add to my Dir is called "@Zombies and Demons" but all installations say to add "@ryanzombies" to server params, so i just presume and i rename the folder in my root directory to "@ryanzombies" instead of "@Zombies and Demons".
  2. When i have installed it, do i then need to do anything with the files inside the folder, i am aware that i have to move the file in the "/@ryanzombies/Keys" folder into the arma keys folder, but do i do anything with the PBO in the "/@ryanzombies/addons" folder?

I hope you get what i mean, sorry for the noob questions.

EDIT

Ok so, i added the contents of "/@ryanzombies/addons" into "arma3/addons" and the "You cannot play this mission,......" error went, nice.

But i now spawn in to see that there is no zombies being loaded in the towns?

Edited by Fin ¯\_(ツ)_/¯

Share this post


Link to post
Share on other sites
  • 0

Don't remove anything from the @ryanszombies folder. Instead, add  "ryanzombies", "ryanzombiesfunctions" to your mission.sqm also make sure to add @ryanszombies; to your startup parameters.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.