• 0
TroyT

Looking for basic.cfg Advice

Question

I looked around but couldn't find much info on optimizing bandwidth settings in the basic.cfg that wasn't 5 years old.  Does anyone have any pearls of wisdom here?  We've got a dedicated box with a managed OS with End of Reality.  Although they should be setting this config up based on their network, I have very little confidence that it has been looked at since the QGS days.  

The current basic.cfg:

Spoiler

language="English";
adapter=-1;
MinBandwidth=800000;
MaxBandwidth=25000000;
MaxMsgSend=384;
MaxSizeGuaranteed=512;
MaxSizeNonguaranteed=256;
MinErrorToSend=0.003;
MaxCustomFileSize=100000;
Windowed=0;
serverLongitude=0;
serverLatitude=52;
serverLongitudeAuto=0;
serverLatitudeAuto=52;

 

We are currently running 5 Exile servers, 1 7D2D,, &1 Empyrion - if that matters.
Server Specs (as advertised):

Spoiler

Processor: E3-1270v5/v6
Memory: 32GB DDR4 ECC
HD: 1 512gb SSD $25.00 USD
Network Port Speed: 1gbps 
Bandwidth: 10TB Premium Internap
DDoS Protection: 4gbps / 8,000,000 pps 
Windows 2016 Game Optimized w/ TCAdmin

 

 

Edited by TroyT

Share this post


Link to post
Share on other sites

11 answers to this question

  • 0

Touching it always ends up bad.

arma 2, this was the holy grail that set servers apart, SHARPLY. 

it's not worth touching.

I have had low, mid and full for months servers without any issues whatsoever and the players never complained about desync or any other bandwidth / performance related issues. 

I realize that there will be other comments on here that say, "Oh, he doesn't know what he's talking about" and that's perfectly fine. This is only my opinion and my experience.

Good luck with this though. Reporting back here the results would be a welcome change. 

 

Share this post


Link to post
Share on other sites
  • 0

That's the problem... we are having desync issues.  That's why I'm looking at this.  Even building from the ground up, they seem to keep coming back, which makes me think that it has something to do with the network and not my files.  Also, the setting set by the host are not stock, so someone has already tweaked them.  I just don't know who yet.

Share this post


Link to post
Share on other sites
Advertisement
  • 0

That makes a lot more sense, I completely understand sorry Bud. I wish I could help more the only thing I would say is to replace it with the stock one if it's possible, as a test if nothing else.

Share this post


Link to post
Share on other sites
  • 0

Also, sometime last year, while researching other bugs, someone that seemed in the know said that those numbers appeared to be way out of date. I had bigger fish to fry at the time and so didn't pursue it.

Share this post


Link to post
Share on other sites
  • 0

I am using these values that Dave from MGT was kind enough to give me. They fixed desync.

//from DB(Dave)
MaxMsgSend=512;
MaxSizeGuaranteed=768;       
MaxSizeNonguaranteed=256;
MinErrorToSend=0.006;
MinErrorToSendNear=0.05;
MaxCustomFileSize=0;
//end from DB(Dave)

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Interesting.  I've also had intermittent desynch issues and network lag (multiple players getting it) using the default settings.   I'm going to try these.  I'm running four Arma 3 game servers on a rented bare-iron host that has 100GB bandwidth into the server from their ISP!  I installed Windows Server 2012R2 on it.  I had bumped up the minBandwidth and maxBandwidth but still get issues.   I don't recall the values I set and I'm not at home to take a look.

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, Bob_the_K said:

 I'm running four Arma 3 game servers on a rented bare-iron host

DyKpm.gif

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hey @TroyT

I currently run 4 Exile servers all extDB3 x64.

2 with zeds and AI/Roaming AI

2 with just AI/Roaming AI

My servers specs are 

Dual Intel Xeon 2670 v3's

32GB ECC Ram

1TB SSD (Raid 1)

Windows Server 2012 R2 x64,

This rack is owned by myself and a mate and is hosted on a 1GB Colocation service

 

Here is my basic.cfg that i use on all server and i don't seen to have any issues with,

//
// Exile Mod basic.cfg Settings
//
// This file has been tuned for a box running only one Arma 3 server on a 
// 1 GBit/s pipe with 100 slots
//
// See https://community.bistudio.com/wiki/basic.cfg
//

///////////////////////////////////////////////////////////////////////////////
// Default Options
///////////////////////////////////////////////////////////////////////////////
language = "English";
adapter = -1;
3D_Performance = 1.000000;
Resolution_W = 800;
Resolution_H = 600;
Resolution_Bpp = 32;

///////////////////////////////////////////////////////////////////////////////
// Bandwidth Tuning 
//
// Be sure to adjust this to your server settings!
// This example is for 1GBit/s pipe
///////////////////////////////////////////////////////////////////////////////
// 100MB * 1024 * 1024 = 104857600
MinBandwidth = 107374182;

// Do NOT set this too high or your Arma server will simulate ego-ddos
// 600MB * 1024 * 1024 = 629145600
MaxBandwidth = 1073741824;

///////////////////////////////////////////////////////////////////////////////
// Network Tuning 
// 
// Usually something we developers set. Only change these if you really know
// what you are doing. Do something wrong here and your sever will burn in hell 
// and cause massive desych.
///////////////////////////////////////////////////////////////////////////////
MaxMsgSend = 16384;
//MaxSizeGuaranteed = 958;
//MaxSizeNonguaranteed = 224;	
MinErrorToSend = 0.001;
MinErrorToSendNear = 0.01;
MaxCustomFileSize = 2920000;

Cheers

xDeejayCrazyx

Edited by xDeejayCrazyx

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.