Sign in to follow this  
ThN

[SOLVED] infiSTAR problem with setup? Doesnt work for no reason

8 posts in this topic

Hello,

today I tried to get infistar working on my server - with no result. I finnaly look in the RPT file to found this:

Quote

15:54:33 "<infiSTAR.de> 0 - TESTING IF serverCommandPassword IS SET PROPERLY"
15:54:33 "<infiSTAR.de> 0 - serverCommandPassword NOT SET!   [1000MS - 16-03-2018 12-56-29 - v90 - [WIP] -EXILE- Tanoa Hardcore/Oldschool - [""Arma 3"",""Arma3"",180,143869,""Stable"",true,""Windows"",""x86""]]"
15:54:33 "<infiSTAR.de> 0 - serverCommandPassword   in EXILE_AHAT_CONFIG.hpp is []"
15:54:33 "<infiSTAR.de> 0 - serverCommandPassword   is defined in your servers config.cfg"
15:54:33 "<infiSTAR.de> 0 - serverCommandPassword   has to be set it in EXILE_AHAT_CONFIG.hpp where it says serverCommandPassword = ""changeme"";"
15:54:33 "<infiSTAR.de> 0 - serverCommandPassword   FILE: [a3_infiSTAR_Exile\fn_preInit.sqf]"
15:54:33 "<infiSTAR.de> 0 - serverCommandPassword   LINE: [1584]"
15:54:33 "<infiSTAR.de> 0 - infiSTAR will NOT START if passwords are not set properly!"

However my EXILE_AHAT_CONFIG.hpp looks like this:

Quote

class Cfg_infiSTAR_settings {
/*
    "serverCommandPassword" is serverCommandPassword - in your servers config.cfg
    if your config.cfg does not have serverCommandPassword yet, simply add it in a new line:
    serverCommandPassword = "changeme";
    
    This is   VERY IMPORTANT   as it is needed to KICK & BAN people.
    
    It will try to get this password from "@ExileServer\addons\exile_server_config" first. If you did not set a password there (config.cpp),
    then it will take what you put here.
*/
serverCommandPassword = "admin123start";

/*
    "passwordAdmin" is passwordAdmin - in your servers config.cfg, needed for servercommands from client
    
    This is used to be able to use the "login" function ingame. Will log you in as Arma "Admin".
*/
passwordAdmin = "admin123startA";
/* serverCommandPassword and passwordAdmin should always be different passwords or it could cause problems! */

I believe that I set it right ... or?

Many thanks in advance.

MORE FILES:

description.ext:

Quote

showHUD[] =
{
    true,   // Scripted HUD (same as showHUD command)
    true,   // Vehicle + soldier info
    true,   // Vehicle radar
    true,   // Vehicle compass
    true,   // Tank direction indicator
    false,  // Commanding menu
    false,  // Group Bar
    true,   // HUD Weapon Cursors
    true   // Vehicle Panel (Required for GPS)
};

#include "config.cpp"
#include "CfgRemoteExec.hpp"
#include "infiSTAR_defines.hpp"
#include "infiSTAR_AdminMenu.hpp"
#include "infiSTAR_chat.hpp"
#include "infiSTAR_KeyBinds.hpp"

config.cfg:

Quote

hostname                            = "exilemod.com (1.0.4|1.80)";
password                             = "";
passwordAdmin                          = "admin123startA";
serverCommandPassword                = "admin123start";
logFile                                = "server.log";

 

Edited by ThN

Share this post


Link to post
Share on other sites

You have to set the same passwords in your servers config.cfg (that is the file where you can change the server name, missiontemplate, enable/disable battleye and so on)

Share this post


Link to post
Share on other sites
Advertisement

Thank you for quick aswer.

Sorry I could post it also - I have both passwords in config, see below.

Quote

hostname                            = "exilemod.com (1.0.4|1.80)";
password                             = "";
passwordAdmin                          = "admin123startA";
serverCommandPassword                = "admin123start";
logFile                                = "server.log";

I really dont know what to do about this.

Edited by ThN

Share this post


Link to post
Share on other sites

I tried to set it up all again step by step and still no change.

Quote

 6:53:29 "<infiSTAR.de> 0 - serverCommandPassword   in EXILE_AHAT_CONFIG.hpp is []"
 6:53:29 "<infiSTAR.de> 0 - serverCommandPassword   is defined in your servers config.cfg"
 6:53:29 "<infiSTAR.de> 0 - serverCommandPassword   has to be set it in EXILE_AHAT_CONFIG.hpp where it says serverCommandPassword = ""changeme"";"
 6:53:29 "<infiSTAR.de> 0 - serverCommandPassword   FILE: [a3_infiSTAR_Exile\fn_preInit.sqf]"
 6:53:29 "<infiSTAR.de> 0 - serverCommandPassword   LINE: [1584]"
 6:53:29 "<infiSTAR.de> 0 - infiSTAR will NOT START if passwords are not set properly!"

 

Share this post


Link to post
Share on other sites

OK - I get it to work.

Nothing is better than using bad server provider.

I found out that every time I launched the server, my configs (server.cfg) change adminpassword and commandpassword to be the same and that caused this error.

Should anyone else have this problem, check your configs AFTER you star server.

Thank you all for your help, can be marked as closed.

Share this post


Link to post
Share on other sites

Sorry that you had to go through that trouble, it might not be an issue anymore to have the same password for both (well maybe an security issue :P )

When I first introduced the statement about it being a problem, it cause hardcore server lag when having the same password in both fields. Even when you ran a vanilla arma server without any addons/mods.

Seemed to be some weird engine bug

 

well good you have found your solution! :)

Share this post


Link to post
Share on other sites
Advertisement
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.