Fewture

Weird issue with fog

6 posts in this topic

Running a server and have been having a weird issue with the fog. When I log in, as the screen is fading in, the fog looks perfect, but then it suddenly just disappears. I log off, then back on, and it is exactly as it should be. However, as I play, after about 20 minutes, the fog degenerates into a slightly opaque white strip across he center of the screen. I looked around but couldn't see any other posts with that issue.

Any ideas?

Share this post


Link to post
Share on other sites

I think this is an issue with ARMA.  I have seen this with versions 1.7's.  I THINK the problem is with time acceleration and fog.

Sadly, without running the time as normal or doing away with the fog, there is nothing you can do.  I am 99.9% sure it is not a video brd or driver issue as I have this too as well as a friend of mine as well.

Weird part too, it does not happen every time either.

???

 

 

Share this post


Link to post
Share on other sites
Advertisement
2 hours ago, Fewture said:

Running a server and have been having a weird issue with the fog. When I log in, as the screen is fading in, the fog looks perfect, but then it suddenly just disappears. I log off, then back on, and it is exactly as it should be. However, as I play, after about 20 minutes, the fog degenerates into a slightly opaque white strip across he center of the screen. I looked around but couldn't see any other posts with that issue.

Any ideas?

 

Share this post


Link to post
Share on other sites

hve you tried ground fog if not give this ago.

1st make a .sqf called Ground_Fog.sqf and add this to it below

Spoiler

// Ground Fog - TorturedChunk - Kaysi - mmmyum @ OpenDayZ.net

//Modify By CNSU
waitUntil {!isNull player};                                                                                                                                                                                                                                                                                                                                                                                     
doofog = {
private ["_obj","_pos","_fog1","_fog2","_fog3","_inVehicle"];
        _inVehicle = (vehicle player != player);
 
        if (_inVehicle) then {
            _obj = (vehicle player);
        } else {
            _obj = player;
        };
 
        _pos = position _obj;
 
        _fog1 = "#particlesource" createVehicleLocal _pos;
        _fog1 setParticleParams [
        ["\A3\Data_F\ParticleEffects\Universal\universal.p3d" , 16, 12, 13, 0], "", "Billboard", 1, 10,
            [0, 0, -6], [0, 0, 0], 1, 1.275, 1, 0,
            [7,6], [[1, 1, 1, 0], [1, 1, 1, 0.04], [1, 1, 1, 0]], [1000], 1, 0, "", "", _obj
        ];
        _fog1 setParticleRandom [3, [55, 55, 0.2], [0, 0, -0.1], 2, 0.45, [0, 0, 0, 0.1], 0, 0];
        _fog1 setParticleCircle [0.001, [0, 0, -0.12]];
        _fog1 setDropInterval 0.01;
 
        _fog2 = "#particlesource" createVehicleLocal _pos;
        _fog2 setParticleParams [
        ["\A3\Data_F\ParticleEffects\Universal\universal.p3d" , 16, 12, 13, 0], "", "Billboard", 1, 10,
            [0, 0, -6], [0, 0, 0], 1, 1.275, 1, 0,
            [7,6], [[1, 1, 1, 0], [1, 1, 1, 0.04], [1, 1, 1, 0]], [1000], 1, 0, "", "", _obj
        ];
        _fog2 setParticleRandom [3, [55, 55, 0.2], [0, 0, -0.1], 2, 0.45, [0, 0, 0, 0.1], 0, 0];
        _fog2 setParticleCircle [0.001, [0, 0, -0.12]];
        _fog2 setDropInterval 0.01;
 
        _fog3 = "#particlesource" createVehicleLocal _pos;
        _fog3 setParticleParams [
        ["\A3\Data_F\ParticleEffects\Universal\universal.p3d" , 16, 12, 13, 0], "", "Billboard", 1, 10,
            [0, 0, -6], [0, 0, 0], 1, 1.275, 1, 0,
            [7,6], [[1, 1, 1, 0], [1, 1, 1, 0.04], [1, 1, 1, 0]], [1000], 1, 0, "", "", _obj
        ];
        _fog3 setParticleRandom [3, [55, 55, 0.2], [0, 0, -0.1], 2, 0.45, [0, 0, 0, 0.1], 0, 0];
        _fog3 setParticleCircle [0.001, [0, 0, -0.12]];
        _fog3 setDropInterval 0.01;
 
        _this setVariable ["playerfog", floor time + 5];
 
        sleep 120;
 
        deleteVehicle _fog1;
        deleteVehicle _fog2;
        deleteVehicle _fog3;
    };
[] spawn {
    while {true} do {
        if(daytime < 7 || daytime > 19) then {
            if (player getVariable ["playerfog", -1] < time) then {
                player setVariable ["playerfog", floor time + 5];
                player spawn doofog;
                sleep 120;
            };
        };
    };
};
 

then add that to your mission.pbo in a the folder Custom\Ground_Fog\

Then add this line to your init .sqf

[] execVM "Custom\Ground_Fog\Ground_Fog.sqf";                                       // Ground Fog

 

You can call this fog from anywhere you like, as long the path is correct

 

Give it ago.

Share this post


Link to post
Share on other sites

is this the one that follows the player around? If so.. Its very nice, except when your not on the ground. Like in a heli, or in your base.. kinda ruins the effect.

Share this post


Link to post
Share on other sites
2 hours ago, geekm0nkey said:

is this the one that follows the player around? If so.. Its very nice, except when your not on the ground. Like in a heli, or in your base.. kinda ruins the effect.

Yes that is the script 

Fog has been an issue in arma for a while, but there are 3rd party weather scripts available that work better than the built in system

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.