• 0
Nuffbutter

Hamachi baised exile server having issues with people spawning in ground

Question

I am trying to run a locally hosted server from my computer and will use hamachi to LAN host it. everything works up to the point where I spawn in the ground at start, i haven't yet tried it with a friend joining but i have done all the changes that other form questions have been told to do. i have hitbox set at 1024, i reset the information like i was told (i doubt these are the right terms but oh well, i hope what i'm trying to say is getting across). i have even reinstalled my database file, remade my SQL schema, still nothing has fixed it, i spawn in in the ground and have to either ald f4 my way out or wait for the server to disconnect me. some other information that may help (idk im new to this). the server is being run through TADST. below is where i think the error is coming from in my RPT file, im not sure what is wrong with my database ( i assume that this is where the error is), can someone please take a look and tell me whats wrong.

 

"ExileServer - Player Nuffbutter (UID 76561198080798051) connected!"
"ExileServer - Database Error: Error Statement Exception"
Error in expression <se_handleBig;
};
};
((_result select 1) select 0) select 0>
  Error position: <select 0) select 0>
  Error Generic error in expression
File exile_server\code\ExileServer_system_database_query_selectSingleField.sqf, line 27
Error in expression <se_handleBig;
};
};
((_result select 1) select 0) select 0>
  Error position: <select 0) select 0>
  Error Generic error in expression
File exile_server\code\ExileServer_system_database_query_selectSingleField.sqf, line 27
 Mission id: 1f9be88f0177eb5d94c89ff2e0e2963639277581
"exileserverforhamanchi/BIS_fnc_log: [BIS_fnc_preload] ----- Scripts initialized at 23103 ms -----"
EPE manager release (0|25|0)
Deinitialized shape [Class: "C_Soldier_VR_F"; Shape: "a3\characters_f_bootcamp\common\vr_soldier_f.p3d";]
Deinitialized shape [Class: "Exile_Unit_GhostPlayer"; Shape: "a3\characters_f\common\invisibleman.p3d";]
c:\bis\source\stable\futura\lib\network\networkserver.cpp ClearNetServer:NOT IMPLEMENTED - briefing!
Extensions:
  extDB2 (C:\Users\conno\Desktop\A3Eserver\@ExileServer\extDB2.dll) [ÁÖ?ðž[T]

this is taken from the end of my RTP file for the server where the problem is, i don't know what is wrong or how to fix it but its wrong.

Share this post


Link to post
Share on other sites

8 answers to this question

  • 0

You need to edit your MySQL ini file so that it isn't strict, and you need to setup your ExileServer  extdb-conf  so it has the database name and password.

MySQL ini File location (this can be located and named a few different places, and ways.)
Check ProgramData >> MySQL >> MySQL Server (version Number) >> my.ini (It will be a configuration type file and it will most likely say only my)
Other names it goes by is MySQL or MySQL-(Version Number)

extdb-conf is located in the @ExileServer folder.

You're going to need to learn how to search for files on your own as there is never one answer to any problem. If you want to run your own server you need to get in the mindset of server development. The only person who cares about your server and it working is you.

Share this post


Link to post
Share on other sites
  • 1

This is a hidden file so make sure you have enabled so you can see them

Check this file C:\ProgramData\MySQL\MySQL Server 5.7]my.ini

look for sql-mode make sure it looks like this

sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

Share this post


Link to post
Share on other sites
Advertisement
  • 0
5 hours ago, Thomas1973 said:

This is a hidden file so make sure you have enabled so you can see them

Check this file C:\ProgramData\MySQL\MySQL Server 5.7]my.ini

look for sql-mode make sure it looks like this

sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

That's assuming he's using MySQL

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, Beowulfv said:

That's assuming he's using MySQL

yeah i am using my sql, sorry should have said that, but it is my sql workbench

Edited by Nuffbutter

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, Thomas1973 said:

That file is located in your @ExileServer folder

i think im misunderstanding you, i cant seem to find any files that match that anywhere, if you have the time, do you think you could join my discord and walk me through

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.