Sign in to follow this  
VipWip

ExileClient_gui_traderDialog_updateStoreDropdown

3 posts in this topic

Hello,

j'aurais besoin d'une petite confirmation ou un coup de pouce pour éclaircir un petit souci.

Dans une fonction, je lis la conf d'Exile suivante : configfile >> "CfgVehicles" >> _traderType >> "UserActions" et ses descendants.

Je l'utilise pour manipuler des addactions, en 'essayant' de respecter les mécanismes d'origine.

Tout fonctionne bien à l'exception d'une erreur signalée avec le script d'origine "ExileClient_gui_traderDialog_updateStoreDropdown".

Il me signale une variable non définie : _categoryComboBox et effectivement en regardant le code on lui applique un lbSetPicture alors qu'elle n'a encore aucune valeur. En remplaçant _categoryComboBox par _storeDropdown, là ça fonctionne et j'ai bien l'image coté store.

Spoiler

/**
 * ExileClient_gui_traderDialog_updateStoreDropdown
 *
 * Exile Mod
 * www.exilemod.com
 * © 2015 Exile Mod Team
 *
 * This work is licensed under the Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License.
 * To view a copy of this license, visit http://creativecommons.org/licenses/by-nc-nd/4.0/.
 */
 
private["_traderConfig", "_dialog", "_storeDropdown", "_categoryClass", "_categoryConfig", "_categoryName", "_categoryIcon", "_categoryIndex", "_categoryComboBox"];
_traderConfig = missionConfigFile >> "CfgTraders" >> ExileClientCurrentTrader;
_dialog = uiNameSpace getVariable ["RscExileTraderDialog", displayNull];
_storeDropdown = _dialog displayCtrl 4008;
lbClear _storeDropdown;
_storeDropdown lbAdd "All";
_storeDropdown lbSetData [0, ""];
_storeDropdown lbSetCurSel 0;
{
    _categoryClass = _x;
    _categoryConfig = missionConfigFile >> "CfgTraderCategories" >> _categoryClass;
    _categoryName = getText(_categoryConfig >> "name");
    _categoryIcon = getText(_categoryConfig >> "icon");
    _categoryIndex = _storeDropdown lbAdd _categoryName;
    _storeDropdown lbSetData [_categoryIndex, _categoryClass];
    //_categoryComboBox lbSetPicture [_categoryIndex, _categoryIcon]; <-- ICI
    _storeDropdown lbSetPicture [_categoryIndex, _categoryIcon]; <-- là ok j'ai bien l'image
}
forEach getArray(_traderConfig >> "categories");
true

Pour résoudre le problème il me suffit effectivement de faire un overwrite coté custom code, mais je me dis que je passe peut-être à coté de quelque-chose que je n'ai pas bien compris.

Ce que je ne comprends pas très bien, c'est comment j'arrive à avoir cette erreur (et surtout, 'uniquement' celle là) lorsque j'utilise directement les mécanismes client/traders, alors que dans un contexte normal (trader standard) je n'ai pas cette erreur. C'est une variable locale, et tous les paramètres nécéssaires sont automatiques (et je n'ai aucune erreur de ce coté là) ??

Quelqu'un pourrait me confirmer que dans le script en question il y a soit un problème avec cette variable ou soit généreusement :P m'expliquer pourquoi cela devrait quand même fonctionner ? ( Je débute coté scripts).

Merci beaucouuuuup ! :P

Edited by VipWip
Titre plus parlant

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.