Sign in to follow this  
geekm0nkey

[Solved] Castle Worm Hole?

9 posts in this topic

Anyone ever seen this? What could be causing it..  Player goes to a base, dunno if it effects all bases, but it did this one.. Runs up the tower, when he reaches the landing.. Poof, teleported to the ground.. At first i though he was making it up, but it was reproducible to the point I was able to capture it happening.  So I thought maybe the height, so i teleported him to the next landing up and had him run up the next tower.. Once he reached its landing.. Poof, back to the ground.. So odd. No haven't delved into the logs yet.. Probably will be doing that while your watching the video.. lol

Logs had nothing to offer, no anti-teleport triggers. so dunno, going to have him put a castle at his base and test, and maybe test another base tower..

 

 

Edited by geekm0nkey

Share this post


Link to post
Share on other sites
Advertisement

Ok had a few more players test... See this corner/wall.

20180602115940_1.jpg

when a player makes it to this spot, if they slow down and don't touch the corner or the wall, they are fine, works as intended. But if they walk into it.. BOOM back to the ground in front of the base.. I have tried 2 different locations and 3 towers. All with the same result. Could it be a glitch in the infistart anti teleport? or maybe something that catches wall glitches? Now as the admin, it doesn't effect me, which makes me believe it is something in infistar?

Share this post


Link to post
Share on other sites

I think I have found it.. Will do some more testing before considering this solved. However this needs to be "Fixed" so that it can be used without it happening on the castles.

Found inside infistar config. had to set wall_glitch_revert to false.

	/*
	checks if a players tries to glitch through a wall (if player is allowed to build in that territory, it will not be logged.)
	*/
	wall_glitch_object = "true";	//	This checks if the Player Object is glitching through a wall/base part
	wall_glitch_revert = "false";	//	Teleport player back to last "safe" postion if a glitch was detected. Needs: wall_glitch_object = "true";

yes, this was the issue, reported it to infistar, maybe they can add a work around for the castle so this doesn't have to be disabled.

Edited by geekm0nkey

Share this post


Link to post
Share on other sites
25 minutes ago, geekm0nkey said:

However this needs to be "Fixed" so that it can be used without it happening on the castles

Open infiSTAR pbo >> Open EXILE_AH >> Search _fn_checkWallGlitch it should be the first one on line 2246 >> On line 2253  add the castle class name !(_type in ['Land_Castle_01_tower_F',

It'll ignore any class name placed in that section.

  • Like 2

Share this post


Link to post
Share on other sites

Honestly though, I wouldn't use the revert script. It can still be abused to glitch into bases. I also don't use the anti-teleport setting as it can mess with players while driving. UAT = "false"; but you do what you want. I've only had bad experiences with those two options.

Share this post


Link to post
Share on other sites
13 minutes ago, Beowulfv said:

Open infiSTAR pbo >> Open EXILE_AH >> Search _fn_checkWallGlitch it should be the first one on line 2246 >> On line 2253  add the castle class name !(_type in ['Land_Castle_01_tower_F',

It'll ignore any class name placed in that section.

Good catch.. Thanks

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.