• 0
FlipM0d3

Problem K40 and Stomper

Question

Hi,
I had drones on my server from the start and they always worked.
When i buy them at the trader they work  like they did before, but when i store them in VG and take them back out i can't connect to it.
Anyone having the same problem or knows how to fix it, this happend with the last Exile 1.04 update.

Edited by FlipM0d3

Share this post


Link to post
Share on other sites

9 answers to this question

  • 0

k40 yes, stomper no. The reason for this is those require a crew.. Guess the crew starve to death while locked in the VG.. lol Seriously, what would have to happen is a crew be resigned upon retrieval of the drone. Might have to reuse the same code that (should have been added) to be able to use them when purchased.

See if this helps.

 

  • Like 1

Share this post


Link to post
Share on other sites
Advertisement
  • 0
On 29-6-2018 at 4:24 PM, geekm0nkey said:

The reason for this is those require a crew.. Guess the crew starve to death while locked in the VG..

It was only for 2 days, they probably were bored to death :P

When i log in as a admin, i can see the crew in the stomper and i can even take two shots in the gunners before it freezes. But your right it needs to be reassigned to the player on the same way it does when you purchased it. I tried hacking it but even that doesn't work.

I thought maybe the code is also used when you unpack a normal drone from a backpack, but i can't find the file that does that.

Anyway thanks for the link GeekMonkey, i will try my luck there.

Share this post


Link to post
Share on other sites
  • 0

Well turns out one of my players now want to be able to do this, so I tried my hand at adding the code it, but reports are that it doesn't work. My problem is I don't know enough about the back end of the code to know if the _vehicleObject in question will return the "type" or not to compare against. You would think it should but.. Or maybe the database needs an extra field called "hasCrew" and if true, then add the crew to the vehicle? Here is the code I tried.

https://hastebin.com/gexocufudo.cs

Don't know if the code should be...

if (typeOf _vehicleObject == "I_UGV_01_F") then
{
 createVehicleCrew _vehicleObject;
};

or

if (_vehicleObject isKindOf "I_UGV_01_F") then
{
 createVehicleCrew _vehicleObject;
};

 

If anyone knows how to properly assign the crew to the drone after restore from VG, let us know.
Thanks.

Update: After looking at the database, seems the class is stored, but not called so made some changes. Will test and see if this works. Here is the changed file.

https://hastebin.com/jobalucuzi.cs

Edited by geekm0nkey
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Ok no joy, and here is a list of issue with the UAVs. Now I know, most will be like, doesn't matter, but for those who wanted to use them it would be nice to figure out the issues. So here is what I've seen during my testing.

1. UVAs need a crew when purchased (this has been resolved.)
2. Storing UAV into VG breaks it in a few ways, 1st, when restored, its can no longer be controlled. 2nd, if using r3f_log you loose functionality.
3. Other can access your drones from anywhere. (may not be fixable)

So if someone want to tackle these issue, would be cool. But for now, I'm having to pull them.. Just too many issues. However one possible option if someone want to try is to write a script to check if vehicle nearby player is a UAV and assign a crew, this should fix this for all situations. But doesn't address the hijacking issue.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
15 hours ago, geekm0nkey said:

Ok no joy, and here is a list of issue with the UAVs. Now I know, most will be like, doesn't matter, but for those who wanted to use them it would be nice to figure out the issues. So here is what I've seen during my testing.

1. UVAs need a crew when purchased (this has been resolved.)
2. Storing UAV into VG breaks it in a few ways, 1st, when restored, its can no longer be controlled. 2nd, if using r3f_log you loose functionality.
3. Other can access your drones from anywhere. (may not be fixable)

So if someone want to tackle these issue, would be cool. But for now, I'm having to pull them.. Just too many issues. However one possible option if someone want to try is to write a script to check if vehicle nearby player is a UAV and assign a crew, this should fix this for all situations. But doesn't address the hijacking issue.

I placed the same problem on the link you gave me and i spoke to Hogansheroes. He's telling me it works on his server but he's using a old vg, i asked  if it was the Exad vg and he's not using that one?

So i dont know which vg he is using and if it still works with exad vg? Maybe someone can confirm if it's still works with Exad vg?

 

The weirdt thing is i'm able to shoot 2 times from the stomper and then it freezes.

When turning on the engine on any drone it doesnt work, same as folding the wings.

But when i fold the wings you can hear it's making the sound and i'm able to store it back in the vg??

 

 

 

Edited by FlipM0d3

Share this post


Link to post
Share on other sites
  • 0

I have found the fix, you where in the right file.

Make a overwrite for ExileServer_object_vehicle_database_load.sqf

goto line 100 and change ->

_vehicleObject enableSimulationGlobal false;  to 

_vehicleObject enableSimulationGlobal true;

Allready thought something was wrong with the simulation.

Don't know if this will cause any other problems, but tested it and it works fine. 

 

Edited by FlipM0d3
  • Like 1

Share this post


Link to post
Share on other sites
  • 0
13 hours ago, geekm0nkey said:

Cool, do you still have to assign a crew, or does just enabling the simulation solve all of the issues?

You only have to enable simultion and its solved, crew is allready in.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.