• 0
Lt. Ike

Server is starting fine but players can't load in | RHS mods

Question

So, basically I am adding more weapons into my server, I just tried adding the 4 RHS mods into the server, but it's causing a weird bug where the server is up and running fine according to the .rpt file (which can be found here https://pastebin.com/FGjVm4JC) but on a client end, according to the player .rpt file (Here https://pastebin.com/GxsyR5Lk), the game is trying to load Tanoa when the server is set to Chernarus... The game ONLY tries to load Tanoa when the 4 RHS packs are loaded on the server, but when they aren't, the player loads Chernarus just fine... Ideas?

Share this post


Link to post
Share on other sites

3 answers to this question

  • 0

It appears you are missing RHSSAF in your cmd line to have all 4 RHS

also this in ur RPT:

Spoiler

 6:08:30 Warning Message: File mpmissions\__cur_mp.Chernarus\TRADERS\RHSW\TraderCategoriesRHSW.hpp, line 600: Config: '"' encountered instead of ','
 6:08:30 Warning Message: Config : some input after EndOfFile.
 6:08:30 Mission Exile.Chernarus: Missing 'description.ext::Header'

and this for Infistar

Spoiler

 6:08:36 "<infiSTAR.de> 0 - infiSTAR_defines.hpp is not in your MPMission or you forgot to #include it within your description.ext

im not gonna even mention this

Spoiler

 6:08:37 Error in expression <0.00998767,-0.00236225,0.999947,[[],[]],<null>,<null>,"4444","","",0]]]>
 6:08:37   Error position: <<null>,<null>,"4444","","",0]]]>
 6:08:37   Error Invalid number in expression
 6:08:37 Error in expression <0.00998767,-0.00236225,0.999947,[[],[]],<null>,<null>,"4444","","",0]]]>
 6:08:37   Error position: <<null>,<null>,"4444","","",0]]]>
 6:08:37   Error Invalid number in expression
 6:08:37 Error in expression <"extDB2" callExtension _query);
switch (_result select 0) do
{
case 0:
{
(format>
 6:08:37   Error position: <_result select 0) do
{
case 0:
{
(format>
 6:08:37   Error Undefined variable in expression: _result
 6:08:37 File exile_server\code\ExileServer_system_database_query_selectSingle.sqf, line 16
 6:08:37 Error in expression <texture = _data select 21;
try
{
if !((vectorMagnitude _vectorUp) isEqualTo 1) >
 6:08:37   Error position: <vectorMagnitude _vectorUp) isEqualTo 1) >
 6:08:37   Error Type Any, expected Number
 6:08:37 File exile_server\code\ExileServer_object_vehicle_database_load.sqf, line 22
 6:08:37 Error in expression <000)
];
_vehicleObject = createVehicle [_vehicleClassName, _temporaryPositionInO>
 6:08:37   Error position: <_vehicleClassName, _temporaryPositionInO>
 6:08:37   Error Undefined variable in expression: _vehicleclassname
 6:08:37 File exile_server\code\ExileServer_object_vehicle_carefulCreateVehicle.sqf, line 23
 6:08:37 Error in expression <ode = _this select 4;
_vehicleObject = [_className, _position, _direction, _useP>
 6:08:37   Error position: <_className, _position, _direction, _useP>
 6:08:37   Error Undefined variable in expression: _classname
 6:08:37 File exile_server\code\ExileServer_object_vehicle_createPersistentVehicle.sqf, line 18
 6:08:37 Error in expression <
_items = _this select 1;
if ((typeName _items) isEqualTo "ARRAY") then
{
if!(_>
 6:08:37   Error position: <_items) isEqualTo "ARRAY") then
{
if!(_>
 6:08:37   Error Undefined variable in expression: _items
 6:08:37 File exile_server\code\ExileServer_util_fill_fillItems.sqf, line 15
 6:08:37 Error in expression <gazines = _this select 1;
if ((typeName _magazines) isEqualTo "ARRAY") then
{    
>
 6:08:37   Error position: <_magazines) isEqualTo "ARRAY") then
{    
>
 6:08:37   Error Undefined variable in expression: _magazines
 6:08:37 File exile_server\code\ExileServer_util_fill_fillMagazines.sqf, line 15
 6:08:37 Error in expression <weapons = _this select 1;
if ((typeName _weapons) isEqualTo "ARRAY") then
{
if!(>
 6:08:37   Error position: <_weapons) isEqualTo "ARRAY") then
{
if!(>
 6:08:37   Error Undefined variable in expression: _weapons
 6:08:37 File exile_server\code\ExileServer_util_fill_fillWeapons.sqf, line 15
 6:08:37 Error in expression <tabase_query_selectSingle;
_position = [_data select 8, _data select 9, _data se>
 6:08:37   Error position: <_data select 8, _data select 9, _data se>
 6:08:37   Error Undefined variable in expression: _data
 6:08:37 File exile_server\code\ExileServer_object_vehicle_database_load.sqf, line 15

and this

Spoiler

 6:08:42 Error in expression <onitor to ExileServer Thread";
};
 
 
if (EZM_UseHarassingZombies) then
{
if (EZM_>
 6:08:42   Error position: <EZM_UseHarassingZombies) then
{
if (EZM_>
 6:08:42   Error Undefined variable in expression: ezm_useharassingzombies
 6:08:42 File exilez_mod\init\fn_postInit.sqf [exilez_mod_fnc_postInit], line 331

and the 1st rule of config editing: - never edit config when you are sleepy! :D

j/k it should be: add one thing at a time, and create backup before any change

Edited by Brenner
  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Hi Brenner, I appreciate you having a look at the rpt file!

I must say, a lot of those errors were there from the spawn of the server, don't ask, because simply put, I. Have. No. Clue. It was shoddy that I had to upload my own exile.ini just to get people to spawn in since the server host had a previous, non-updated version of it... I dunno...

As for the InfiSTAR_defines.hpp, it is there, I can bet all I own on it. The #include is also there. I ran that past an InfiSTAR service rep and they weren't sure what was the go. All InfiSTAR files and #includes are where they need to be...

At the point of the rpt being grabbed, I was trying to troubleshoot what file was causing the spawn-stall, so I'd taken a mod out, BUT I can assure that I had tested all mods loaded at once and the player would still sit on a loading screen... That explains the RHSSAF missing from the commandline, unfortunately, you need all four running on the server at once to get the server to run, but then, for some unknown reason, server and scripts run, but players get an infinite loading screen...

*Edit: I did fix that RHWS.hpp line 600 error, but the whole load screen still persisted...

*Doubly-edit: Those EZM scripts haven't been touched by me, which confuses me so eff'n much. I've used this heaps of times and never seen those. I might try uploading fresh exile files to my test server to clean up some of those errors. I have no clue how a server provider has outdated files...

Edited by Lt. Ike

Share this post


Link to post
Share on other sites
  • 0

Yes even thou infistar files are there, some other error is preventig it to load properly or being detected, so you need to look into it.

This would be my number one priority:

Spoiler

Missing 'description.ext::Header'

Could be that this causes other issues, but it doesnt have to be.

As for traders, I have been browsing trader files multiple times looking for missing "," through endless lines, so I know its a pain in the ass.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.