Sign in to follow this  
Followers 0
Brenner

Safe construction extdb2 vs extdb3

4 posts in this topic

Posted (edited)

Hi everyone,

on my extdb3 server safes dont work as they should unless constructed inside territory, tried reading topics here, and googling and consulting on Discord, and for testing purpouses created a new extdb2 server and c/p all mods/addons and mission file to it, so it is identical to extdb3 one, minus extdb3 override.

Now what is going on:

EXTDB3

when constructed outside of territory:

  • got the toast saying PIN is 0000
  • using scroll menu on safe there are only two options, inventory and pack
  • when using pack option and type PIN 0000 get the toast that PIN is wrong, which makes packing impossible
  • safes are NOT being written to database
  • if no safe is constructed there is no error in rpt, however if one is constructed the following error appears:
    18:58:14 Exile_Construction_Safe_Preview: doorrotation - unknown animation source dooranimationsource
    18:58:15 Error in expression <llExtension _query); (_result select 1) select 0 >
    18:58:15 Error position: <select 0 >
    18:58:15 Error Generic error in expression'
    18:58:15 File extdb3_server\code\ExileServer_system_database_query_insertSingle.sqf, line 16

when constructed on territory:

  • got a complete scroll menu
  • can pack, lock, change PIN
  • safe is written to database

EXTDB2

  • got complete scroll menu regardless of territory
  • can pack, lock, change PIN
  • safe is written to database

Beside the above error there is no major error in rpt, and the same files work as they should without extdb3 overrides.

Which leads to conclusions:

  1. there is something wrong with extdb3, the way it is installed, or some lines of code in it, since they cannot be used outside of territory
  2. there is something wrong with extdb2, the way it is installed, or some lines of code in it, and I got used to safes not working properly and being able to place them where I want to regardless of the territory on extdb2, and the above error is a result of my poor server administration.

Can you help me solve this mystery?

Thanks in advance. :)

Edited by Brenner

Share this post


Link to post
Share on other sites

Posted (edited)

@Brenner are you using ExItems mod?

also can you pastebin your entire RPT?

 

@kuplion move to problems & bugs -> server side?

Edited by StokesMagee

Share this post


Link to post
Share on other sites
Advertisement

I dont use ExItems, what I use is:

cba, rhs, ebm, dms, occupation, a3xai, vemfr, vcomai, zcp, exad, claim crates and vehicles, sell crates, enigma revive, tanoa bridges, salvage wrecks, rearm/repair, dynamic locker, easy traders, xs spawn, server restart notification script and r3f
 
Fresh rpt is comming right after i deal with work and family. :)
 
 

Share this post


Link to post
Share on other sites

Sorry for the delay, RL rushed in.

Was busy with RL and havent touch server for a few days.

Fired it up today to get fresh RPTs to upload here, and guess what..no error in RPT, safes are being written to db fine, even outside of territory, can pack, change PIN, and everything works as it should?!

Can someone pls explain this to me? O,O

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.