• 0
Mirolife

Error in expression

Question

Hello, 

So, here's my problem, installed server, first join is ok, but after relog and second join is: Waiting for server to load.

"ExileServer - Database Error: Error Unknown Protocol"
Error in expression <se_handleBig;
};
};
((_result select 1) select 0) select 0>
  Error position: <select 0) select 0>
  Error Generic error in expression
File exile_server\code\ExileServer_system_database_query_selectSingleField.sqf, line 27
Error in expression <se_handleBig;
};
};
((_result select 1) select 0) select 0>
  Error position: <select 0) select 0>
  Error Generic error in expression
File exile_server\code\ExileServer_system_database_query_selectSingleField.sqf, line 27

And this is this file .sqf

/**
 * ExileServer_system_database_query_selectSingleField
 *
 * Exile Mod
 * www.exilemod.com
 * © 2015 Exile Mod Team
 *
 * This work is licensed under the Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License. 
 * To view a copy of this license, visit http://creativecommons.org/licenses/by-nc-nd/4.0/.
 */
 
private["_parameters", "_query", "_result"];
_parameters = _this;
_query = [0, ExileServerDatabaseSessionId, _parameters] joinString ":";
_result = call compile ("extDB2" callExtension _query);
switch (_result select 0) do
{
	case 0:
	{
		(format["Database Error: %1", (_result select 1)]) call ExileServer_util_log;
	};
	case 2:
	{
		_result = (_result select 1) call ExileServer_system_database_handleBig;
	};
};
((_result select 1) select 0) select 0

line 27 is this ----->       ((_result select 1) select 0) select 0

Share this post


Link to post
Share on other sites

1 answer to this question

  • 0

Hello @Mirolife,

When you have an issue, ALWAYS USE A STANDARD!  ;)

TEMPORARILY, put in the DEFAULT mission file that came with the server download.  Does it work?

Yes - error is in YOUR mission file.  Where?  Only YOU can answer that one!  Put ONE THING IN AT A TIME AND TEST IT!

No - YOUR DB OR DB settings (port, password, etc.) are not set up correctly - make sure 'strict mode' is OFF in the MySQL settings

 

That is all there is too it!  It is just that simple!

:)

  • Like 1

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.