aussie battler

Macross - ADR-04-Mk X Defender - No Ladder to get in...

15 posts in this topic


I am looking at the Macross - ADR-04-Mk X Defender

There is an option to bring down the ladder on the scroll wheel, but nothing happens. The ladder works in Eden editor.

I have also loaded the mod without infistar & Battleye, still no ladder & nothing in the logs...

The other options such as "flip", "refuel" and "repair" work.

Do I have to add "extend ladder" in the CfgInteractionMenus in config.cpp & point it to the extend ladder script in the addon?


 * Sort this by probability of occurence to speed things up a bit
class CfgInteractionMenus
    class ADR-04
        targetType = 2;
        target = "ADR-04";

        class Actions
            // extend ladder
            class Extend: ExileAbstractAction
                 title = "Extend Ladder";
                 condition = "((locked ExileClientInteractionObject) isEqualTo 0) && ((locked ExileClientInteractionObject) != 1)";
                 action = "ExileClientInteractionObject call Extend_Ladder";


Then in initPlayerLocal:



    _code = '';
    _function = _x select 0;
    _file = _x select 1;

    _code = compileFinal (preprocessFileLineNumbers _file);

    missionNamespace setVariable [_function, _code];
    ['Extend_Ladder', 'custom\Ladder\Extend_Ladder.sqf']


Any ideas?



Edited by aussie battler

Share this post

Link to post
Share on other sites

I think it MIGHT be BEST to contact the author on this.  It is his mod and he should know what it needs.

Do note, the author states that this is basically an 'alpha' version and there are issues in MP.

I think you should contact him for the 'best' results.


  • Like 1

Share this post

Link to post
Share on other sites
Advertisement MAY be....BUT, only the author can really answer that one.  He knows his mod.  You can try to put those things in, it will not hurt.  I HIGHLY recommend that you do a BACK UP of ALL files modified in this 'test'.

That way, if it does not work, you can 'restore' things right away.

Personally, I do not think it is an 'Exile' problem.  Notice how you can use other mods such as CUP and RHS with NO issues.

But I am not a mod expert or any where close.  I just know that other mods such as CUP and RHS require NO special 'stuff' to get them to work - They just 'do' and that the author would know (you would think) what you might have to do.

Who knows...



Share this post

Link to post
Share on other sites

@Z80CPU I think it might be an exile thing. Here is what the author said:

GP|Battlestad  [author] 6 hours ago 
@aussie battler
this is the condition for extending the ladder:
condition = "this animationSourcePhase ""ladder_hatch_src"" == 0";

I've tested it in SP, MP as client, as server and on a local dedicated server.

Does something on Exile servers fuck this up?

Share this post

Link to post
Share on other sites

Not that I am aware of.  For example, on CUP vehicle BTR-90 HQ, it has an extending radio mast.  It works PERFECTLY.  So, animations OUTSIDE of 'moving' DO work.  I had to do NOTHING to make that work on my server except add the vehicle to Exile Traders.

So, with that in mind, it makes me think that his mod is NOT 'standard'.  I am NOT a modder AT ALL.  I am just using plain 'common sense'.

You CAN create a script which will 'teleport' a player into these things thus BYPASSING this issue all together.

That IS another option for when they get like 1m away, they will get an option to 'get in'.  BUT, you will HAVE TO CHECK if it is empty FIRST.

Here is the script for pushing back boats - YOU need to modify it....  ;)



in the vehicle init put:

this addAction ["<t color='#FF9900'>Push</t>","PushBoat.sqf",[],-1,false,true,"","_this distance _target < 8"];


Boat push script - v0.1
Pushes the boat in the direction the player is looking
Created by BearBison
if (isDedicated) exitwith {};
private ["_Object","_Soldier","_isWater"];
_Object = _this select 0;
_Soldier = _this select 1;
_isWater = surfaceIsWater position _Soldier;
if (_isWater) exitwith {titleText ["You can't push from in the water","PLAIN DOWN",1];};
if (_Soldier in _Object) exitwith {titleText ["You can't push from inside the vehicle","PLAIN DOWN",1];};
_Object setOwner (owner _Soldier);
_Soldier playMove "AmovPercMstpSnonWnonDnon_AinvPercMstpSnonWnonDnon_Putdown";
if (currentWeapon _Soldier == "") then {sleep 1;} else {sleep 2;};
_Object setVelocity [(sin(direction _Soldier))*3, (cos(direction _Soldier))*3, 0]; 




  • Like 1

Share this post

Link to post
Share on other sites

Thanks @Z80CPU you have given me some ideas, I'll give it a crack.

I am going to bypass dropping the ladder & get the guy to go straight in.

Will post back here is I get it working.

Edited by aussie battler
  • Thanks 1

Share this post

Link to post
Share on other sites

I am making progress. If I run the "get In" script found in the Mech Mod the mech makes a warm up engine sound :)

I can get a "get In vehicle" scroll wheel function but it wont automatically throw me into driver. It shoots blanks.

Can anyone see what is wrong with: action = ["getInDriver", cursorTarget]; ?

Should it be action = ["getInDriver", "BTLSTD_Defender_IND"]; ? 


action = "_this call getInDriver";   ?

            class Get_In : ExileAbstractAction
                 title = "Get In Vehicle";
                 condition = "((locked ExileClientInteractionObject) isEqualTo 0) && ((locked ExileClientInteractionObject) != 1)";
                action = ["getInDriver", cursorTarget];


Share this post

Link to post
Share on other sites

What you put will not work.  If the object's class name is 'asd' and you had 5 of them, which one would arma stick you in?  #1?  #2?  #3?  etc.

So using the class name will NOT work.

This is why I suggested to use the script.  It 'activates' ONLY when YOU get within a set distance and ONLY for that unit, even if you had 100 of them.


Also 'cursorTarget' is an arma command.  What the Exile devs did was to 're-write' the 'action menu' and how it works, meaning you might not be able to employ straight out arma commands in the manner in which you have them.

For example, I have a mod and one line is:

m1 = player addaction ["* Game Options","HelpMe\MainMenu\submain.sqs"] - This will add the text '* Game Options' to the player's 'action menu'.  When selected, it will run the script 'submain.sqs'.

If I add my mod to Exile, the above line will NOT SHOW AT ALL!  ONLY after a do a 'special' trick will it show.  But, just by itself?  Nope!  It is a 'no show'.

This is what I mean, Exile has 'modified' how the 'action menu' works.  I ONLY have this 'problem' in Exile ALONE.


Also, with the 'get in' command, you notice that Exile devs have NOTHING for this, thus by you inserting it means you are in a possible conflict with arma's method and Exile's method.  From the brief look over, NO ACTIONS are arma defaults.  They are ALL custom entries.  And here you are inserting a REAL COMMAND.  It MIGHT be 'conflicting' on some level that you're not aware of.  But not all is lost on....


I would examine how they did the code for the 'car flip'.

            class Flip: ExileAbstractAction
                title = "Flip";
                condition = "call ExileClient_object_vehicle_interaction_show";
                action = "_this call ExileClient_object_vehicle_flip";

Examine it and when the actually 'flip it', this is when you remove that and insert the 'get in' command.

Reason being, they are getting the name for the car that is RIGHT AT THE PLAYER'S FEET.  And then they perform 'actions' on THAT vehicle ONLY.

This is EXACTLY what you want to do as well....

You will have to rename it from ExileClient_object_vehicle_flip to something like ExileClient_object_giddy_up_robot or what ever you wish to call it...  ;)

I would also insert it right ABOVE OR BELOW the real code.  This way, you KNOW it is in the 'right spot'.


BUT, you need to VERIFY that after you get in, that someone else can NOT get in.  ;)


DO NOT CALL THE CLASS 'GET IN'!  There could be a possible conflict!

Be creative, use something like

Class MountTheRobot: ExileAbstractAction

You will not have a conflict with that name and a valid arma name.


You also need to put in the 'proper area'.  If this 'robot' is classified as an 'Air' unit, then put your code under the 'Air Units'.  Make 100% SURE you KNOW what it is.  The classes are:  Car, Tank, Plane, Air, Ship, Submarine.

Which one is this and do you KNOW this?  Without examining the actual configs files of this thing or asking the author which one, you will be GUESSING.  And that might not cut it...  ;)





  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.