• 0
Sign in to follow this  
Steven1230[SS]

XM8 error on fresh server install

Question

Hey all. I am getting a Exile.Malden\config.cpp, line 7134: .XM8_App01_Button: Undefined base class 'RscExileXM8AppButton1x1' error pop up when i launch the server. Anyone one have an idea what could be causing this as everything looks fine within the config.cpp file and matches up with other configs. 

I tried a fresh install and even download the mission pbo from the server pack again.

RPT file

Spoiler

=====================================================================
== C:\\gameservers\arma3\44368\arma3server.exe
== "C:\\gameservers\arma3\44368\arma3server.exe"  -mod=@Exile;@Extended_Base_Mod;@Ryanzombies -servermod=@ExileServer -ip=216.244.93.98 -port=5302 -profiles=Admin -config=Admin\server.cfg -cfg=Admin\arma3.cfg -name=Admin -autoinit -nolog 

Original output filename: Arma3Retail_Server
Exe timestamp: 2018/07/24 22:39:33
Current time:  2018/10/01 19:22:46

Type: Public
Build: Stable
Version: 1.84.144923

Allocator: C:\gameservers\arma3\44368\Dll\tbb4malloc_bi.dll [2017.0.0.0] [2017.0.0.0]
PhysMem: 256 GiB, VirtMem : 4.0 GiB, AvailPhys : 36 GiB, AvailVirt : 3.9 GiB, AvailPage : 67 GiB
=====================================================================

19:22:46 SteamAPI initialization failed. Steam features won't be accessible!
19:22:46 Cannot register unknown string STR_3DEN_CAMERA_NAME
19:22:46 Cannot register unknown string STR_DIFF_SCENE_ONLY
19:22:46 Cannot register unknown string STR_DIFF_SCENE_AND_MAP
19:22:47 Initializing stats manager.
19:22:47 Stats config disabled.
19:22:47 sessionID: 785265d8de9fdcda1081bfe73993fc39a7426ba6
19:23:05 Item str_a3_to_c01_m02_036_ta_mechanized_briefing_SOLDIERC_0 listed twice
19:23:07 ErrorMessage: File Exile.Malden\config.cpp, line 7134: .XM8_App01_Button: Undefined base class 'RscExileXM8AppButton1x1'
19:23:07 Application terminated intentionally
ErrorMessage: File Exile.Malden\config.cpp, line 7134: .XM8_App01_Button: Undefined base class 'RscExileXM8AppButton1x1'
=======================================================
-------------------------------------------------------
Exception code: 0000DEAD  at 751B5EF8
Version 1.84.144923
Fault time: 2018/10/01 19:24:18
Fault address:  751B5EF8 01:00014EF8 C:\Windows\SYSTEM32\KERNELBASE.dll
file:     
world:    
Prev. code bytes: 75 1F 21 4C 24 10 8D 04 24 50 FF 15 2C 63 26 75
Fault code bytes: 8B 4C 24 54 33 CC E8 B1 8D FF FF 8B E5 5D C2 10

Registers:
EAX:02F5C868 EBX:2167E100
ECX:00000005 EDX:00000000
ESI:215F6940 EDI:02F5E384
CS:EIP:0023:751B5EF8
SS:ESP:002B:02F5C868  EBP:02F5C8C0
DS:002B  ES:002B  FS:0053  GS:002B
Flags:00000212
=======================================================
note: Minidump has been generated into the file Admin\arma3server_2018-10-01_19-22-46.mdmp
 

 

Edited by Steven1230[SS]

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

Hi,

-nolog

parameter in your command line means no logs are being generated in rpt besides the error.

i would suggest to remove it, than run the server again, than pastebin generated rpt and link it here.

Also wouldn't hurt to pastebin your Exile.Malden\config.cpp  and link it here so we can see what is actually in there.

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, Brenner said:

Hi,

-nolog

parameter in your command line means no logs are being generated in rpt besides the error.

i would suggest to remove it, than run the server again, than pastebin generated rpt and link it here.

Also wouldn't hurt to pastebin your Exile.Malden\config.cpp  and link it here so we can see what is actually in there.

Thank you for replying. I took a look in the parameter line and I am not seeing the -nolog. The server gets the pop up error soon as it tries to boot up which is why you are not seeing much in it. Here is the pastebin for the config.cpp thou

https://pastebin.com/tY5iYa4q

Share this post


Link to post
Share on other sites
Advertisement
  • 0

glad that it is sorted, btw this is your cmd line from your rpt:

Spoiler

== "C:\\gameservers\arma3\44368\arma3server.exe"  -mod=@Exile;@Extended_Base_Mod;@Ryanzombies -servermod=@ExileServer -ip=216.244.93.98 -port=5302 -profiles=Admin -config=Admin\server.cfg -cfg=Admin\arma3.cfg -name=Admin -autoinit -nolog 

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.