• 0
Creig Willams

Need help after using loot compliler. copying to config.cpp server wont start

Question

 

LootItemGroups.h    https://justpaste.it/3czfd

LootTables.h              https://justpaste.it/3rb2u

 CfgExileLoot.hpp     https://justpaste.it/3t3wz

config.cpp                  https://justpaste.it/1zdxj    

 

 

I need help my server will not start and. i followed the tutorials. not sure why it wont start up.

im using for mission 

Exile.ChernarusRedux.pbo           

with the map configs

Please help me. i need it!

 

Edited by Creig Willams

Share this post


Link to post
Share on other sites

17 answers to this question

  • 1

Yes it was the spacing in the config. the server is running now

Just a recap for anyone wanting to know how i we fixed it.

In all your configs, you need to check and make sure if you have any extra spaces to remove them

example 

>  //rhs stuff < remove it. 

rhs.11111

 

  • Like 1

Share this post


Link to post
Share on other sites
Advertisement
  • 0
1 hour ago, Creig Willams said:

i try to open that with notepad++ but cant seem to view it since it is a bunch of symbols and stuff. my best guess is that if it is something to do with the loot compiler it could have been when you pasted in the new loot table, id say grab a fresh copy of that configg and change any setting as you did, then double check anything you added to the compiler for any spacing or name mishaps. re-run it and copy into the new config ensuring its in the right spot. 

sorry if im not more helpful. i have had your problem before and it was because when i added hap item to the table i had (2, "HAP_ITEM") instead of (2, HAP_ITEM) minus the parentheses ofcourse. ill post an example of how i modded the file for you even though you may already know. 

 in "LootItemGroups" i did this when adding things to that file:

Spoiler

3, Exile_Weapon_M4                // M4
3, Exile_Weapon_M16A4            // M16A4
3, Exile_Weapon_M16A2            // M16A2
10, Exile_Weapon_LeeEnfield
3, HAP_MX_yellow    <------------ADDED ITEMS HERE UNDER THE RIFLES SECTION
3, HAP_MX_green
3, HAP_MX_teal
3, HAP_MX_pink
3, HAP_MX_red

that is a slice of what i added under the rifles section

then after running the .bat i copied all the file it puts out and found that section in @Exileserver/addons/exile_server_config (unpacked) replacing what was there ofcourse. 

the repacked and launched. 

 

as i said the first time i had the items entered incorrectly and it messed it up

Edited by MickScandalous

Share this post


Link to post
Share on other sites
  • 0
14 minutes ago, MickScandalous said:

i try to open that with notepad++ but cant seem to view it since it is a bunch of symbols and stuff. my best guess is that if it is something to do with the loot compiler it could have been when you pasted in the new loot table, id say grab a fresh copy of that configg and change any setting as you did, then double check anything you added to the compiler for any spacing or name mishaps. re-run it and copy into the new config ensuring its in the right spot. 

sorry if im not more helpful. i have had your problem before and it was because when i added hap item to the table i had (2, "HAP_ITEM") instead of (2, HAP_ITEM) minus the parentheses ofcourse. ill post an example of how i modded the file for you even though you may already know. 

 in "LootItemGroups" i did this when adding things to that file:

  Hide contents

3, Exile_Weapon_M4                // M4
3, Exile_Weapon_M16A4            // M16A4
3, Exile_Weapon_M16A2            // M16A2
10, Exile_Weapon_LeeEnfield
3, HAP_MX_yellow    <------------ADDED ITEMS HERE UNDER THE RIFLES SECTION
3, HAP_MX_green
3, HAP_MX_teal
3, HAP_MX_pink
3, HAP_MX_red

that is a slice of what i added under the rifles section

then after running the .bat i copied all the file and found that section in @Exileserver/addons/exile_server_config (unpacked) replacing what was there ofcourse. 

the repacked and launched. 

 

as i said the first time i had the items entered incorrectly and it messed it up

Do you think you could help me over discord possibly ?

Share this post


Link to post
Share on other sites
  • 0

one thing i see could be the spaces you have in the group title here 

Spoiler

//RHSAFRF///////////
///////////////////////////////////////////////////////////////////////////////
// Thanks to @GamerJesus on Exilemod.com
///////////////////////////////////////////////////////////////////////////////

///////////////////////////////////////////////////////////////////////////////
// Rifle
///////////////////////////////////////////////////////////////////////////////

> Russian Rifles RHSAFRF
1, rhs_weap_ak103
1, rhs_weap_ak103_1
1, rhs_weap_ak103_2

at the > Russian Rifles RHSAFRF section. not sure if it matters

Share this post


Link to post
Share on other sites
  • 0
18 minutes ago, Creig Willams said:

Do you think you could help me over discord possibly ?

also i just saw a thing in you config.hpp. It seems to start with the loot table and doesnt have the CfgBuilding part and i see you said it was replaced on the note there. 

Spoiler

// Chernarus Redux Loot Positions - Replaced CfgBuildings
#include "chernarusreduxloot.cpp"
// Chernarus Redux Loot Positions - Replaced CfgBuildings

class CfgExileEscapeLootServer
{
class LootTables
{

/*

but i have in mine this

Spoiler

/**
 * config
 *
 * Exile Mod
 * www.exilemod.com
 * © 2015 Exile Mod Team
 *
 * This work is licensed under the Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License. 
 * To view a copy of this license, visit http://creativecommons.org/licenses/by-nc-nd/4.0/.
 */
 
class CfgPatches
{
    class exile_server_config
    {
        requiredVersion = 0.1;
        requiredAddons[] = {};
        units[] = {};
        weapons[] = {};
        magazines[] = {};
        ammo[] = {};
    };
};


class CfgBuildings
{
    
    ///////////////////////////////////////////////////////////////////////////
    // Castles & Lighthouses & Life Guard Towers
    ///////////////////////////////////////////////////////////////////////////
    class Land_LifeguardTower_01_F
    {
        table = "Tourist";
        positions[] = {{-0.498047, -0.222656, 1.13312}};
    };

    class Land_LightHouse_F

followed by the building ofcourse, so i dont know if you have made sure that file has the correct things like for lighthouse it says the group is "tourist"

 

secondly i think it is the spaces in the group names as i pointed out before because ive learned exile doesnt like that. try it after removing those spaces on the RHS stuff and let me know.

Share this post


Link to post
Share on other sites
  • 0
16 minutes ago, MickScandalous said:

also i just saw a thing in you config.hpp. It seems to start with the loot table and doesnt have the CfgBuilding part and i see you said it was replaced on the note there. 

  Reveal hidden contents

// Chernarus Redux Loot Positions - Replaced CfgBuildings
#include "chernarusreduxloot.cpp"
// Chernarus Redux Loot Positions - Replaced CfgBuildings

class CfgExileEscapeLootServer
{
class LootTables
{

/*

but i have in mine this

  Reveal hidden contents

/**
 * config
 *
 * Exile Mod
 * www.exilemod.com
 * © 2015 Exile Mod Team
 *
 * This work is licensed under the Creative Commons Attribution-NonCommercial-NoDerivatives 4.0 International License. 
 * To view a copy of this license, visit http://creativecommons.org/licenses/by-nc-nd/4.0/.
 */
 
class CfgPatches
{
    class exile_server_config
    {
        requiredVersion = 0.1;
        requiredAddons[] = {};
        units[] = {};
        weapons[] = {};
        magazines[] = {};
        ammo[] = {};
    };
};


class CfgBuildings
{
    
    ///////////////////////////////////////////////////////////////////////////
    // Castles & Lighthouses & Life Guard Towers
    ///////////////////////////////////////////////////////////////////////////
    class Land_LifeguardTower_01_F
    {
        table = "Tourist";
        positions[] = {{-0.498047, -0.222656, 1.13312}};
    };

    class Land_LightHouse_F

followed by the building ofcourse, so i dont know if you have made sure that file has the correct things like for lighthouse it says the group is "tourist"

 

secondly i think it is the spaces in the group names as i pointed out before because ive learned exile doesnt like that. try it after removing those spaces on the RHS stuff and let me know.

ok heres my discord name contact me when you can Gopnik
#9921

 

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.